VLAN: TP-LINK Easy Smart Switch

Hallo,
ich möchte mir gerne das Freifunk Mesh und das Freifunk Client netzt in meinem LAN Jeweils auf ein vlan legen und so von meinem Privaten LAN Trennen.
Dafür habe ich nun all meine switche gegen die VLAN tauglichen von TP-LINK getauscht.
Als Router ist bei mir der Ubiquiti edge Router Lite im einsatz welcher ebenfalls VLAN kann.
Der Aufbau sieht ungefähr so aus: Router <-> Switch-1 <-> Switch-2 <-> Switch-3
An allen 3 switches sollen sich später sowohl Freifunk als auch private Geräte befinden.

Ich habe nun aber Probleme mit der Konfiguration, es scheint so als wenn die Daten nicht von dem einem Switch zu dem anderen kommen. Kennt sich damit zufällig jemand aus?
VLAN 1 ist überall verfügbar, VLAN 10 und 20 scheinen tot zu sein.

Du musst die VLAN ID’s auf den Ports der zu den anderen Switches geht jeweils ebenfalls tagged übermitteln…

Warum kommen ff-client und ff-mesh tagged auf unterschiedlichen Ports an? Hängt Dein Router mit mehreren Lan Ports an Port 5 und Port 6 vom Switch?

Ich habe hier mehrere Router, und ich möchte nicht im gluon irgendwelche vlans konfigurieren sonder diese einfach ins LAN Hängen, darum auch getaggte Ports.
Ich hatte das Port Tagging so verstanden das da ein Dummes Gerät sitzen kann, und alle Pakete die da ankommen, bekommen ein bestimtmes vlan tag zugewiesen.
Der Switch von dem der Screenshot stammt ist mit Port 1 an Port 1 des 2. switch angeschlossen, und der wiederum mit Port 5 an Port 3 des 3. Switch.

Also getagged bedeutete an dem Port kommen die Pakete mit dem VLAN-Tag raus. Also wenn das Gerät was da dran hängt nicht den gleichen Vlan-Tag kennt bekommst Du keine Verbindung. In der Regel hast Du auf einenm Port 1 Vlan Untagged und x Vlans Getagged und da hängt dann der nächste Switch dran der genauso Konfiguriert ist. Überall wo ein dummes Endgerät dran hängt musst Du das Vlan untagged drauf konfigurieren welches Du haben möchtest. Das gilt erstmal für Paket die raus kommen. Die Pakete die dein Dummes Endgerät selber verschickt müssen auch einen VLan-Tag bekommen. Dafür ist 802.1Q PVID zuständig. Bedeutet also im normal Fall ist die VLAN ID des Ports identisch mit der ID des untagged vlan.

Bei dummen Endgeräten müssen die ungetagged VLan-ID und die PVID identisch sein.

Bei mir ist es meist so das ich auf Port 1-7 die Dummen Endgeräte hänge mit den verschiedenen VLans und an Port 8 liegen alle VLANs getagged drauf Richtung nächsten Switch.

Hoffe habe keinen Mist erzählt :smile:

3 Likes

Hier ist das Thema VLAN recht einfach beschrieben:

1 Like

Ich habe das mal so versucht, aber funktionieren tut es trotzdem noch nicht :frowning:

Also so ist es richtigt. Ist nur die Frage was Du machen möchtest.
So hast Du nur an Port 5 ein Netzwerkgerät das im VLan 10 hängt alleine und an Port 6 ein Gerät im Vlan 20.
Wenn Du jetzt an Port 1 einen anderen Switch anschließt mit der gleichen Konfig. Dann ist dort am Port 5 das Gerät vom Switch1 Port5 zu erreichen usw.

1 Like

Vorerst möchte ich das Router an Switch A mit Router an Switch B Mesh. Langfrisitg möchte ich auch noch das Client netzt in einem eigenen VLAN, und meinem Server im Keller eine VM für Offloader Aufgaben geben.

Dann passt das so wie ich geschrieben habe. Jedes vlan ist quasi ein separates Netzwerk. Für die Clients musst du halt die Ports untagged konfigurieren mit der gleichen Pvid und auf den Querverbindungen zwischen den Switchen müssen alle tagged sein. Und natürlich ist die vlanid vom zB mesh-Netz überall gleich.

1 Like

Blöde Frage: wenn alle Ports 1-8 untaggt im default VLAN sind, woher weiss der Switch was zum VLAN10/20 gehört? -Teurere Switche unterbinden das man mehrere VLANs untagt auf einen Port legt.

Bei den Smartmanaged Switchen ist es glaube ich immer so zumindest bei Tplink und Netgear(die ich kenne). Das default Vlan 1 kann man nicht ändern und greift nur dann wenn nichts anderes konfiguriert ist. So bald ein Vlan eingerichtet wird zählt dieses. Das man die Pvid extra einstellen muss ist auch dem Smartmanaged geschuldet bei extreme zum Beispiel macht der das automatisch wenn ich ein Vlan untagged auf einen Port lege.
Die Smartmanaged Switch sind halt eingeschränkt aber für das Vlan Thema aber echt gut wenn man auf das Geld achten muss.

An VLAN 1 kann ich überhaupt nichts ändern. keine Ports wählen, nicht löschen, einfach nichts.

Ich habs jetzt nach der Anleitung von TobiTX geschafft. Ein Problem war das ich die Kabel durcheinander gebracht habe :smiley:

1 Like

Hallo @kevinq,

welchen Switch (Modell) hast Du verwendet?

Grüße vom revolverheld

2x TP-LINK TL-SG108E und 1x TL-SG105E
Aber vorsicht, die haben keine Weboberfläche sondern nur ein Windows Programm. Das wusste ich beim Kauf leider auch noch nicht.

Ist halt ein Smartmanaged die sind meist mit extra Software. Eine Alternative wäre der GS108Ev2 oder 3 von Netgear. Der liegt bei ca 60€ und hat ein webinterface aber nicht mehr Funktionen als der von Tplink. Glaube beide Dinger werden vom gleichen Hersteller gemacht bloß anderes Label.
Passt beim Kauf auf der v1 ist einer reiner Switch!!! Er hat kein Management

1 Like

Ich habe nun zwei TL-SG108E v2. Die liegen im Moment bei 35-45€.

Ich finde die Kombination aus Webinterface und Windowstool ganz praktisch. Die haben naemlich unterschiedliche Qualitaeten. Beide haben ein paar Usabilityissues, aber nichts was ich als echten Bug bezeichnen wuerde.

Das Windowstool benutze ich zT lieber, weil es zum einen nach den Switches scanned. Wenn man sich ins Knie schiesst, kommt man evtl doch noch ran und es findet heraus, wie das Ding doch erreichbar ist. Wenn ein Switch mit IP Mitteln nicht mehr erreichbar ist, dann gibt es einen Menuepunkt, der bei einem entdeckten Device per spezieller Kommunikation die IP Adresse setzt, wenn login und PW bekannt sind.

Danach kann man sich dann einloggen. Das Windowstool ist auch bei der VLAN Einstellung und dem Portmirroring etwas bequemer zu bedienen.

Das WebInterface erfordert den ein oder anderen Klick mehr, aber man hat den Vorteil, dass man mehrere WebGUIs gleichzeitig darstellen kann. Gerade auch zum Vergleich ganz praktisch.
Leider hat das WebIf einen nervig kurzen idle Timer, den das Windowstool nicht hat.
Die Switches sind nicht verschluesselt erreichbar. Mittlerweile bin ich der Meinung, dass das in keinem Kundensegment mehr akzeptabel ist.

Bei beiden GUIs fehlt mir sehr die Ansicht, welche VLANs auf einem Port vorzufinden sind. Da muss man dann immer die VLAN Liste abscannen.

Nachdem ich lange genug damit mal gespielt hatte, fing ich an die Switches einzubauen und habe mir dann erst mal einen Wolf nach vermeintlichen Loops gesucht, wo definitiv keine sein konnten -

WENN man nicht vergessen haette, das Portmirroring abzustellen !! Das spiegelt dann auch die Loopdetectionframes und man kriegt tolle Symptome und red herrings, wenn dann auch noch die Mirrorpaare auf beiden Seiten unterschiedliche waren. Ganz grosses Kino !! :smile:

Wie immer muss man erst mal nach sowas ein paar Stunden vergeblich gesucht haben, dass man das nie wieder vergessen wird !

Das erstaunlich ist, dass die SG105E hingegen kein Webinterface mitbringen.

Diese „Intelligenz“ des Scanners wird einem leider auch zum Verhängnis, weil jedes Device nur einmal reported wird, auch wenn man es auf mehreren Schnittstellen (Vlans, Interface) sehen könnte.
Da wird dann eine IP reported, die nicht im gleichen Layer2-Segment wie der Management-Node liegt.
Und dann mag das Windowstool überhaupt nicht… (Web geht aber nach wie vor…)

[Vlan]

Das Setup ist so dusselig gemacht mit der Teilung in mehrere komplett getrennte Konfig-Dialoge für Tagging/Untagging/etc, dass viele Leute der Meinung sind, es sei kein echte Vlan. (Was ich nicht bestätigen mag,

Ich kann das nicht bestätigen, zumindest bei den SG1024E funktioniert es hinreichend.

Bist Du sicher, dass es sich hier beim SG1024E um dieselbe SW handelt ? Ich kann zumindest „komplett getrennte Dialoge“ jetzt nicht so richtig auf das abbilden, das ich kenne.
Der 802.1Q betreffende Teil hat bei beiden GUIs genau zwei Seiten, PVID Setting und Vlan Setting wie oa. der Screenshot oben. Der WebGUI ist in der Struktur
identisch. Der krause Ansatz, die VLAN id oben manuell eingeben zu muessen, damit man was sieht, ist alles andere als intuitiv (das windowstool loest das besser).
Aber es gibt imho nur einen Dialog.

Ja, das meinte ich. PVID und VLANs zu trennen.
Aber vielleicht fehlt mir auch nur der Background, um zu erkennen, in welchen Situationen man das trennen wollte. „Eine zusätzliche Spalte“ wäre das, was ich da eher benötigen könnte.

1 Like