WDR4900 - LAN Ports individuell einstellen (WAN Bridge, MoL, FF Client)


#1

Moin Moin,

ich möchte bei meinem WDR4900 folgende LAN Port Config:

  • LAN 1,2 brigde auf WAN
  • LAN 3 FF Mesh On LAN
  • LAN 4 FF Client

1,2,4 funktioniert, ich bekomme es jedoch nicht hin, dass auf Port 3 FF
MoL läuft. Hat jemand ne Idee?

Meine Config (Gluon 2016.2.1):
24.04.2017 - entfernt da unfunktional

Lösung:


Mesh des privaten WIFI und Freifunk über einen VPN leiten
Uplink einstellungen
#2

Ich hab bei mir mesh_lan als bridge drin, das funktioniert soweit:

config interface 'mesh_lan'
option igmp_snooping '0'
option ifname 'eth0.3'
option transitive '1'
option fixed_mtu '1'
option proto 'gluon_mesh'
option type 'bridge'
option macaddr 'big:mac'
option auto '1'

#3

Gucke ich mir gleich morgen an danke dir. Eingetragen habe ich es schon bin aber bis morgen nicht vor Ort. Auf den ersten Blick fällt mir auf, dass du nur “option proto ‘gluon_mesh’” gesetzt hast ich hatte noch “option mesh ‘bat0’ und option proto ‘batadv’” drin…


#4

Im Prinzip ist das der Standardeintrag, nur mit angepasstem ifname. (Gluon v2016.2.2)
Ich hab auf WR841ND WAN und MoL über den gleichen Port (VLAN) und auf einem WDR3600 WAN, MoL und Client über gleichen Port (VLAN), das funktioniert super soweit. Der Unterschied zu dir wäre da nur die switch-Config.


#5

Konnte es nun testen und klappt leider nicht -.-


#6

Das hier ist meine komplette Config (WDR3600). eth0.1 ist wan, eth0.10 ist mesh und eth0.11 ist client.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd37:5e88:113e::/48'

config interface 'wan6'
        option proto 'dhcpv6'
        option sourcefilter '0'
        option ifname 'br-wan'
        option ip6table '1'
        option peerdns '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1'

config switch_vlan
        option device 'switch0'
        option vlan '10'
        option vid '10'
        option ports '0t 2'

config switch_vlan
        option device 'switch0'
        option vlan '11'
        option vid '11'
        option ports '0t 3'

config interface 'wan'
        option ifname 'eth0.1'
        option multicast_querier '0'
        option peerdns '0'
        option auto '1'
        option type 'bridge'
        option proto 'dhcp'
        option macaddr 'mac'

config rule6 'wan6_lookup'
        option mark '0x01/0x01'
        option lookup '1'

config route6 'wan6_unreachable'
        option type 'unreachable'
        option table '1'
        option target '::/0'
        option metric '65535'
        option gateway '::'
        option interface 'loopback'

config interface 'ibss_radio0'
        option proto 'gluon_mesh'

config interface 'mesh_radio0'
        option proto 'gluon_mesh'

config interface 'ibss_radio1'
        option proto 'gluon_mesh'

config interface 'mesh_wan'
        option ifname 'br-wan'
        option transitive '1'
        option fixed_mtu '1'
        option proto 'gluon_mesh'
        option auto '0'

config interface 'mesh_lan'
        option igmp_snooping '0'
        option ifname 'eth0.10'
        option transitive '1'
        option fixed_mtu '1'
        option proto 'gluon_mesh'
        option type 'bridge'
        option auto '1'
        option macaddr 'mac'

config interface 'client'
        option type 'bridge'
        option macaddr 'mac'
        option proto 'dhcpv6'
        option reqprefix 'no'
        option robustness '3'
        option query_interval '2000'
        option query_response_interval '500'
        option peerdns '1'
        option sourcefilter '0'
        list ifname 'eth0.11'
        list ifname 'bat0'

config interface 'bat0'
        option multicast_router '2'
        option ifname 'bat0'
        option macaddr 'mac'
        option learning '0'
        option proto 'none'

config interface 'client_lan'
        option unicast_flood '0'
        option ifname 'eth0.11'

config interface 'mesh_vpn'
        option ifname 'mesh-vpn'
        option mtu '1406'
        option proto 'gluon_mesh'
        option fixed_mtu '1'
        option transitive '1'

config device 'local_node_dev'
        option macaddr 'mac'
        option ifname 'br-client'
        option name 'local-node'
        option type 'macvlan'

config interface 'local_node'
        option ifname 'local-node'
        option ipaddr '10.24.192.1'
        option ip6addr 'fd4e:f2d7:88d2:ffff::1/128'
        option netmask '255.255.192.0'
        option proto 'static'

config route6 'local_node_route6'
        option target 'fd4e:f2d7:88d2:ffff::/64'
        option gateway '::'
        option interface 'client'

#7

ich fuchs mich da nochmal durch danke


#8

die Ports 1/2/3 sind dann die Ports am LAN?
(oder gibt es da “abhängig vom Modell und Revision” noch “Mapping” was man irgendwo nachlesen kann?)


#9

Beim WDR3600 sind 1 WAN und 2-5 die LAN-Ports. Muss man nachschauen: TP-Link TL-WDR3600 (N600) [OpenWrt Wiki]

Beim WR841N/ND zum Beispiel ist der WAN-Port nicht Teil des Switches, deswegen gibt es da eth0 und eth1.


#10

Ich drösel das später mal auseinander…


#11

das scheint ja nun plain OpenWRT feature zu sein. Aber gluon autoupdate faehig ist das doch dann mal sicher nicht, oder doch ? wäre gut zu wissen, wenn man zB auch beim 841 die switchports einzeln verdrahten koennte (es sei denn der 841 kann das nicht)


#12

Vlan-Configs waren bei mir bislang updatesicher (erstaunlicherweise eigentlich)
Also Bridges und zusätzliche Interfaces bleiben erhalten.
Auch die Zuordnung der eth-Bridges zu den dem batman-switch.

Ich werde aber keine Garantien dafür abgeben :wink:


#13

Ich arbeite auch mit VLAN Configs am Offloader (Mesh, Client) und bei einem Knoten (Mesh). Das hat bei mir die Updates auch problemlos überlebt. FIrmware aus Aachen.


#14

So läuft es nun bei mir unter Gluon 2016.2.5.

Die Konfig wurde vollständig manuell erstellt, Mesh on LAN/WAN darf nicht über den Konfig Modus aktiviert worden sein.

cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd98:6d88:a86c::/48'

config interface 'wan6'
        option proto 'dhcpv6'
        option sourcefilter '0'
        option ifname 'br-wan'
        option ip6table '1'
        option peerdns '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1 2 3'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 4'

config interface 'wan'
        option ifname 'eth0.2'
        option multicast_querier '0'
        option peerdns '0'
        option auto '1'
        option type 'bridge'
        option proto 'dhcp'
        option macaddr 'hierstehtnemac'

config rule6 'wan6_lookup'
        option mark '0x01/0x01'
        option lookup '1'

config route6 'wan6_unreachable'
        option type 'unreachable'
        option table '1'
        option target '::/0'
        option metric '65535'
        option gateway '::'
        option interface 'loopback'

config interface 'mesh_wan'
        option ifname 'br-wan'
        option auto '0'
        option transitive '1'
        option fixed_mtu '1'
        option proto 'gluon_mesh'

config interface 'mesh_lan'
        option igmp_snooping '0'
        option transitive '1'
        option fixed_mtu '1'
        option proto 'gluon_mesh'
        option type 'bridge'
        option macaddr 'hierstehtnemac'
        option auto '1'
        option mesh 'bat0'
        option ifname 'eth0.1'

config interface 'mesh_port3'
        option macaddr 'hierstehtnemac'
        option fixed_mtu '1'
        option proto 'gluon_mesh'
        option auto '1'
        option ifname 'eth0.3'

config interface 'client'
        option type 'bridge'
        option macaddr 'hierstehtnemac'
        option proto 'dhcpv6'
        option reqprefix 'no'
        option robustness '3'
        option query_interval '2000'
        option query_response_interval '500'
        option peerdns '1'
        option sourcefilter '0'
        list ifname 'bat0'
        list ifname 'eth0.1'

config interface 'mesh_vpn'
        option ifname 'mesh-vpn'
        option transitive '1'
        option macaddr 'hierstehtnemac'
        option fixed_mtu '1'
        option proto 'gluon_mesh'

config interface 'ibss_radio0'
        option proto 'gluon_mesh'

config interface 'ibss_radio1'
        option proto 'gluon_mesh'

config interface 'bat0'
        option multicast_router '2'
        option ifname 'bat0'
        option macaddr 'hierstehtnemac'
        option learning '0'
        option proto 'none'

config interface 'client_lan'
        option unicast_flood '0'
        option ifname 'eth0.1'

config device 'local_node_dev'
        option macaddr 'hierstehtnemac'
        option ifname 'br-client'
        option name 'local-node'
        option type 'macvlan'

config interface 'local_node'
        option ifname 'local-node'
        option ipaddr '10.116.254.254'
        option ip6addr 'fda1:384a:74de:4242::ffff/128'
        option netmask '255.255.128.0'
        option proto 'static'

config route6 'local_node_route6'
        option target 'fda1:384a:74de:4242::/64'
        option gateway '::'
        option interface 'client'

#15

Könnte man super als Paket bauen.

Patches Welcome: