Wie WR743NDv1.2 mit alter Rader/Wupper Firmware neu Flashen

Fortsetzung der Diskussion von TP-LINK WR743ND Vers. 1.2 für Gluon geeignet?:

Möchte die Router mit Gluon Firmware ausstatten bzw. testen, ob die des WR741 funktioniert.

Kann mir jemand sagen, wie ich in eine Konsole oder GUI komme? Vor zwei Jahren wurde von @phip oder @solo dort eine Firmware für Radevormwald installiert.

Wenn ich per LAN drauf gehe, dann bekomme ich eine IP aus 192.168.1.0. Dort ist aber kein Port 80 oder 22 verfügbar. Per W-LAN bekomme ich eine HTML Seite angezeigt, dass der Knoten gerade kein Internet hat und nur interne Dienste zur Verfügung stehen. Ich soll Internet einstecken oder einen Knoten in der Nachbarschaft mit Internet suchen.

Da kann man irgendwo unter mein Router ein Passwort setzen, danach mit scp die neue Firmware nach /tmp und dann mit sysupgrade -n /tmp/… die neue Firmware installieren.

Danke für den Tipp. Bin auf der Konsole. Ist wirklich eine Firmware von 2012 :wink:

Leider lässt sich die Firmware des 741 nicht installieren. Da ist ein Versionscheck eingebaut und ich bekomme die Fehlermeldung

Invalid image, hardware ID mismatch, hw:07430001 image:07410001

Leider hat @solo noch einige von den Teilen. Da müsste dann wohl eine für den 743 gebaut werden. Könnte das @phip machen? Oder so einen Eintrag erstellen? Siehe hier:

Leider hab ich da nicht so´n Plan von. Hatte eigentlich gehofft, die Router nächste Woche online zu bringen :disappointed_relieved:

Hey Stefan

Für die 743er nimmst Du die Firmware der 741er. Installation erfolgt mit sysupgrade -n -f. Danach ist das Gerät offiziell hw:07410001 und kann später ohne Probleme mit der 741er Firmware bespielt werden.

Ich habe bereits 3 Router von @solo damit bespielt, die haben aber noch die alte Rader Firmware mit der falschen BatmanSSID.

Keine Ahnung warum die eine Zeile mehr nicht ins Gluon gepackt wurde, um die Firmware für das Gerät zaubern zu lassen.

Grüße

1 Like

Habe es gerade mit:

/sbin/sysupgrade -n -F /tmp/gluon-ffrade-sysupgrade.bin

versucht. Leider klappt das nicht und es kommt nur die Befehlshilfe:

Usage: /sbin/sysupgrade [options] <image file or URL>
[...]

Ohne die Option -F wird der Befehl ausgeführt, dann kommt aber die Hardware ID Fehlermeldung.

Versuch mal --force und nicht -f oder -F

Das hatte ich auch schon getestet. Leider ohne Erfolg… Komm immer wieder in die Hilfe. Kann @phip sich noch erinnern, wie er es genau gemacht hat?

root@ffnode:~# /sbin/sysupgrade -n --force /tmp/gluon-ffrade-sysupgrade.bin
Usage: /sbin/sysupgrade [options] <image file or URL>

Options:
        -d <delay>   add a delay before rebooting
[...]