WR841 StockFW zurückflashen (kein "Riesen Problem")

Ich habe oben genannten TP-Link. Ich möchte auch Freifunk router betreiben. Jedoch habe ich mir einen anderen besorgt, der leistungsfähiger ist, bezüglich W-LAn etc. Ich werde diesen ales wieder zurücksenden. Das Problem ist, ich habe zu Testzwecken Freifunk dort installiert. WIE bekomme ich die alte Firmware wieder drauf?? Habe schon überall geschaut, ich komme nicht weiter. Ich logge mich mit WinSCP au dem Router ein und kopiere das orig. Image in das Temp Verteichnis - abe rdann? WAS musas ich machen? Ich bitte echt um eine Anleitung, bitte. Vielen DANK im Voraus!

Edit: Es ist die Ver. 10., also Router.

Hallo.
Alle Angaben ohne Gewähr, da du uns deine Community und die geflashte Version der FF-Firmware nicht verraten hast:

Die Anleitung zum Zurückflashen findest du hier
https://wiki.openwrt.org/toh/tp-link/tl-wr841nd#go_back_to_original_firmware

Bereits gestrippte Images (also ohne Bootloader) kannst du von hier runterladen:
http://www.friedzombie.com/tplink-stripped-firmware/

Viel Erfolg.

warum überhaupt zurückschicken? Mach den doch fertig und schenke ihn einem Nachbarn / Freund / Arbeitskollegen. Dann hast du direkt noch jemanden mit Freifunk „angesteckt“ und den Freifunk Gedanken weiter-getragen… Für die 15 Euro lohnt sich doch der Aufwand kaum.

P.S.: In welcher Community bist du denn unterwegs?

1 Like

@DL3DCF

Hallo, ich kann auch keine Community nennen, ich bin noch nicht einmal in einer. Ich möchte das in Zukufnt nur mahcen und komme aus dem Kreis Stuttgart.

Welche Version drauf ist, weiß ich nicht genau, es war die aktuellste aus Stuttgart vor 3 Wochen etwa. Aber für das flashen spielt das eig. keine Rolle.

-Kenne die Anleitungen, aber das muss doch aucch unter Win7 gehen, oder? Mit Putty oder WinSCP kann ich das Image in den tmp Prdner scieben - aber dann?ß?? wie gehts weiter=?

Geht es mit der gestrippten dann autom., wenns im Tmp is?

@HeavyMettAal

Weil ich Schüler bin und jetzt nicht sovuek zu verschenken habe. Außerdem will das ja nicht jeder und meine Nachbarn sind im Rentenalter.

Bitte um hilfe.

Wenn die Firmware, die du auf dem Gerät hast den ConfigMode kennt (daher ist es für Hilfe z.B. schon wichtig zu wissen welche Firmware auf dem Gerät ist), kannst du auch in den ConfigMode wechseln (5 Sekunden Reset-Taster drücken) und auf der Seite des Routers (192.168.1.1) eine TP-Link Firmware ohne Bootloader flashen.

Beschnittene TP-Link Images gibt es hier: friedzombie.com - Informationen zum Thema friedzombie.

Du musst in keiner Community sein, aber Du solltest wissen, welche FF Firmware Du zu Testzwecken installiert hast. Dann - wenn möglich - in den Configmode wechseln und das gestrippte Image flashen.

Ansonsten hilft vielleicht das hier:
Google nach „von freifunk wieder original firmware flashen“
Erste Ergebnisseite erster Treffer ist

Vielleicht hilft es ja und wir schreiben nicht alles immer wieder.

Rentenalter… naja… das Internet gibt es seit Ende der 70er Jahre des letzten Jahrhunderts…
Meine beiden Opas sind weit über 80 und beide benutzen intensiv das Internet. Einem von den beiden stelle ich diese Woche noch einen 841er ins Haus… also: nur Mut! Freifunk lebt vom Community Gedanken :smile:

So, ich habe nun mittels der beschnittenen Firmware den Router geflasht - nun ist es so, wenn ich mich auf den router einloggen wll, kommt das luCi Interface, aber in der Browserleiste „zittert“ es nur, es geht gar nix.

Wenn ihr schon das Thema abändetr, könnt ihr mir nicht einfach sage, was ich tun muss?ß Ich kenne die Tutorials, aber komme bet weiter. Bitte, ich möchte ihn zurücksenden, bitte akzeptiert das. Davon kann ich mir Rohlinge etc. kaufen, ich bin schüler - und lerne muss ich auch :frowning:
Ich kann wie gesagt auch in den Temp ordenr schieben - und dann?ßß WO gebe ich die Befehle rein. BIITE helft mir.

@HeavyMettAal

Bitte, ich möchte einfach den Roter zurücksenden,

Versuchst du die falsche IP aufzurufen?
Die TP-Link Router haben orig. 192.168.0.1 für das Configinterface.

Also, du musst in den Config Mode und dort im Web Interface (192.168.1.1) die original Firmware flashen.

Danach ist der Router wieder wie früher unter der 192.168.0.1 zu erreichen und du müsstest das Original TP-Link Interface sehen.

Manchmal liegt im Browser Cache noch alter „Müll“ rum, das kann zu Problemen führen. Halte mal die SHIFT Taste gedrückt während du das Interface aufrufst.

Nein, außerdem ist der Router noch gar nicht unter der orig. IP erreichbar, sondern 192.168.1.1 - komme aber nict rein. und oer Putty auch nicht, das Pw ist nun nucht mehr admin - was ist es nun#ß?

@HeavyMettAal

Ja, und wie komme ich in Config Mode? Mit der Resettaste geht es nicht mehr, ich komme dqa nict mehr weiter.

Danke, erde es testen. Bitte überlegt mal weiter.

Wenn er auf der 1.1 lauscht, ist noch Freifunk drauf. Woher weißt du denn das er darüber erreichbar ist? Helfe dir gerne, aus der Ferne ist es nur etwas schwer ohne selber etwas zu „sehen“. Also beschreibe bitte ganz genau was du wie machst. Dann kriegen wir das hin.

Kannst du mal den Router pingen?

O.K., endlich geht es!!! Tatsächlich lag es am Cache im Browser. VErstehe zwar nicht, da ich davor ohnehin geleert habe, aber Gotte sei Dank ist nun die Original Firmware Drauf! DANKE AN ALLE!!! Gerade auc han HeavyMettAal für den Tipp :slight_smile:

Allerdings ist der Router nach wie vor unter 192.168.1.1 erreichbar,m nicht unter x.x.0.1. Lieft das evtl .daran, dass der Router an meinem eigenen TP-Lionk hängt? Mein eigener vergibt auch IP Adressen in dem Adressenpool.

Aber nochmal: wenn ich die Firmware mit Bootanhang in dem tmp order schiebe (mit Putty oder WinSCP) - wie geht es dann weioter??? Bitte, würde mich interessieren.

Edit: Ja, der Router konnte unte 192.168.1.1 angepingt werden - was mich auch gewundetr hat, da ich eben nicht aufs Interface kam - lag aber am Cache.

Übrigens, das war drauf:

Gluon version

v2015.1-334-gd295d6e

Super, freut mich das es geklappt hat.
Wenn man ein Gerät flasht sollte es direkt mit dem PC über ein Ethernet Kabel verbunden sein. Alles andere führt zu Problemen. Zur Frage mit dem tmp Ordner: Ich habe bei den Münchenern das hier gefunden:

cd /tmp/

wget http://firmware.ffmuc.net/stable/sysupgrade/gluon-ffmuc-v2015.7-tp-link-tl-wr841n-nd-v9-sysupgrade.bin

echo 3 > /proc/sys/vm/drop_caches

sysupgrade gluon-ffmuc-v2015.7-tp-link-tl-wr841n-nd-v9-sysupgrade.bin

Die URLs und der Dateiname müssen natürlich an die entsprechende Community angepasst werden.

Wie hast du das denn genau gemacht? Soweit ich weiß läuft SFTP doch garnicht auf einem 841er…