5 GHz funktioniert nicht auf Archer C7 V 4.0


#1

Ich habe das Problem schon in Archer C7 V 4.0 angerissen, aber will es noch mal hier her auslagern, da es ein eigener Aspekt ist und bisher ungelöst. Da es keine offizielle Stable für das Gerät gibt, habe ich eine 2018.1.1-1~exp20180930 / gluon-v2018.1.1 eingespielt. Funktioniert auch prinzipiell, aber es wird kein Netz auf 5 GHz ausgestrahlt. Konfig sieht auf den ersten blick OK aus, oder fällt euch da etwas auf?
wireless.radio0=wifi-device
wireless.radio0.type=‘mac80211’
wireless.radio0.hwmode=‘11a’
wireless.radio0.path=‘pci0000:00/0000:00:00.0’
wireless.radio0.channel=‘44’
wireless.radio0.htmode=‘VHT20’
wireless.radio0.country=‘DE’
wireless.radio1=wifi-device
wireless.radio1.type=‘mac80211’
wireless.radio1.channel=‘11’
wireless.radio1.hwmode=‘11g’
wireless.radio1.path=‘platform/qca956x_wmac’
wireless.radio1.htmode=‘HT20’
wireless.radio1.country=‘DE’
wireless.radio1.supported_rates=‘6000’ ‘9000’ ‘12000’ ‘18000’ ‘24000’ ‘36000’ ‘48000’ ‘54000’
wireless.radio1.basic_rate=‘6000’ ‘9000’ ‘18000’ ‘36000’ ‘54000’
wireless.ibss_radio0=wifi-iface
wireless.ibss_radio0.ifname=‘ibss0’
wireless.ibss_radio0.network=‘ibss_radio0’
wireless.ibss_radio0.device=‘radio0’
wireless.ibss_radio0.bssid=‘CA:FE:52:FF:AC:52’
wireless.ibss_radio0.disabled=‘0’
wireless.ibss_radio0.mcast_rate=‘12000’
wireless.ibss_radio0.mode=‘adhoc’
wireless.ibss_radio0.macaddr=‘8a:b3:d0:2b:91:52’
wireless.ibss_radio0.ssid=‘wifimesh-a-ac’
wireless.ibss_radio1=wifi-iface
wireless.ibss_radio1.ifname=‘ibss1’
wireless.ibss_radio1.network=‘ibss_radio1’
wireless.ibss_radio1.device=‘radio1’
wireless.ibss_radio1.bssid=‘CA:FF:24:FF:AC:24’
wireless.ibss_radio1.disabled=‘0’
wireless.ibss_radio1.mcast_rate=‘12000’
wireless.ibss_radio1.mode=‘adhoc’
wireless.ibss_radio1.macaddr=‘8a:b3:d0:2b:91:56’
wireless.ibss_radio1.ssid=‘wifimesh-g-ac’
wireless.client_radio0=wifi-iface
wireless.client_radio0.ifname=‘client0’
wireless.client_radio0.network=‘client’
wireless.client_radio0.disabled=‘0’
wireless.client_radio0.device=‘radio0’
wireless.client_radio0.mode=‘ap’
wireless.client_radio0.macaddr=‘b0:4e:26:a7:a5:68’
wireless.client_radio0.ssid=‘Freifunk’
wireless.client_radio1=wifi-iface
wireless.client_radio1.ifname=‘client1’
wireless.client_radio1.network=‘client’
wireless.client_radio1.disabled=‘0’
wireless.client_radio1.device=‘radio1’
wireless.client_radio1.mode=‘ap’
wireless.client_radio1.macaddr=‘8a:b3:d0:2b:91:54’
wireless.client_radio1.ssid=‘Freifunk’
wireless.wan_radio0=wifi-iface
wireless.wan_radio0.disabled=‘0’
wireless.wan_radio0.macaddr=‘8a:b3:d0:2b:91:53’
wireless.wan_radio0.network=‘wan’
wireless.wan_radio0.encryption=‘psk2’
wireless.wan_radio0.device=‘radio0’
wireless.wan_radio0.mode=‘ap’
wireless.wan_radio0.key=***
wireless.wan_radio0.ssid=***
wireless.wan_radio1=wifi-iface
wireless.wan_radio1.disabled=‘0’
wireless.wan_radio1.macaddr=‘8a:b3:d0:2b:91:57’
wireless.wan_radio1.network=‘wan’
wireless.wan_radio1.encryption=‘psk2’
wireless.wan_radio1.device=‘radio1’
wireless.wan_radio1.mode=‘ap’
wireless.wan_radio1.key=***
wireless.wan_radio1.ssid=***

Was könnte das sein? Lohnt es sich mal die gluon-ffac-2017.1.8-1~exp20180617-tp-link-archer-c7-v4.bin zu versuchen? Per Weboberfläche konnte ich die nicht einspielen, geht das per scp?


#2

Woran glaubst du zu erkennen das kein 5ghz gesendet wird? Erwartest du 2 unterschiedliche SSID’s ? Laut config wird nämlich 2,4 & 5 GHz mit “Freifunk” ausgestrahlt.


#3

Meine Wlan-Analyse-App zeigt keinerlei Aktivität auf dem 5 GHz-Band im Gegensatz zu meinem anderen Freifunk Router. Die App erlaubt mir auch, das Wlan neben SSID auch über den Kanal zu differenzieren. In dem verlinkten Thread habe ich Screenshots gepostet.


#4

Überprüfe mit opkg list-installed | grep ath10k welcher Treiber bei dem Gerät installiert ist. Für IBSS-mesh brauchst du kmod-ath10k-ct und ath10k-firmware-qca988x-ct.


#5

Ich habe hier kmod-ath10k-ct so weit so gut und ath10k-firmware-qca988x ohne “-ct”. Ist das ein Problem?


#6

Ja, das ist eines. Frag am besten bei deiner Community nach einem Image bei welchem GLUON_WLAN_MESH auf “ibss” gesetzt ist. Solltest du die Site deiner Community haben kannst du diesen Parameter auch selbst in der site.mk setzen.


Archer C7 V 4.0
#7

Habe mal ein anderes Image meiner Community auf Basis der 2017.1 über scp geflashed mit dem Ergebnis, dass mein Router jetzt offenbar tot ist :frowning: Bei booten leuchtet nur kurz die Power-LED und dann nichts mehr. Ich bekomme auch keine Adresse per dhcp vom Router. Kann ich da noch etwas machen?


#8

5GHz Mesh doesn't work with 2018.1 · Issue #1584 · freifunk-gluon/gluon · GitHub kennst Du aber, oder?

Dann ist es völlig normal, dass auch das 5GHz nicht funktoniert.


#9

Ist das jetzt ernst gemein? Das bezog sich natürlich auf den Zustand nach dem fehlgeschlagenen Versuch ein anderes Image einzuspielen.


#10

Das musst Du Dich fragen. Du sprichst in einem Wifi-5GHz-Thread an, dass das Gerät nicht bootet.
Aber wenn das Gerät nicht mehr sauber bootet, dann wird es auch mit dem 2.4GHz nimmer laufen.


#11

Bin ich auch mal drauf gestoßen aber verstehe ich leider nur so halb. Hatte vermutet, dass sich das nur auf das mash bezieht.


#13

Der Fehler wurde doch schon gefunden hier im Thema, beim Build der Firmware war GLUON_WLAN_MESH falsch gesetzt.

ja klar. Die meisten TP-Link Geräte kann man über TFTP “wiederbeleben”.
Wie man dazu genau vorgehen muss ist an diversen Stellen dokumentiert und hängt auch stark von deinem Betriebssystem ab (Linux, MacOS, windows)

EDIT: oh, das TFTP wurde im anderen Thread ja schon besprochen.