Fastd MeshVpn an dedizierten 50/5 MBit/s-Anschluss (und diese auch nutzen)

Hallo,

habe hier in OLPE demnächst für Freifunk einen separaten 50.000 UP / 5.000 Down Business Anschluss
von Unitymedia zur Verfügung.

In den FAQ hab ich folgendes gefunden:

Ich habe eine Dröllfzig-MBit Anbindung und will einspeisen!
Oh wow, super. Funktioniert so ähnlich wie oben beschrieben, nur das der Freifunk-Router noch an deinen eigenen Router angeklemmt wird. Melde dich einfach bei uns, wir machen das schon.

Müsste aber noch 2x Ubiquiti PicoStation2HP daran betreiben.

Ist ein Einspeisen dann noch möglich(sinvoll) ?

Sonnst würde ich die Picostations Mesh an WAN „hinter“ einem TL-WR1043N/ND betreiben,
dann bleibt aber was „über“ …

Das ist die einzig sinnvollste Lösung. Du kannst natürlich Mesh-VPN (also Internetzugang) für die Picos freischalten, sodass die selber VPN Tunnel aufbauen aber die Ubiquitygeräte haben auch nicht viel Rechenpower sodass die Lastverteilung zum 1043 besser geeignet wäre.

Zu deiner Teilauslastung:
Mir würde als unschöne Lösung nur 2 x 1043 einfallen…

1 Like

Gibt’s auch Tabellen in denen die UBNT Geräte mit aufgeführt sind?

Du hättest gern einen BananaPI als VPN-Offloader.
Oder ein VM-Ware-Gluon. (hier an einem UM200/10)
Hilft aber alles nichts, da die Supernodes idR nicht mehr als maximal 20MBit/s „heraustun“. 90% liegen als immer brach. Unitymedia freuts.

Spricht etwas dagegen, zwei Uplinks parallel zu betreiben? Das wären dann ja 40MBit/s, oder?

Das funktioniert leider nicht, Batman nutzt immer nur einen Pfad gleichzeitig. Es ist zwar möglich dies auf „Bonding“ zu ändern aber nur mit einem zusätzlich dafür konfigurierten Supernode.

Ich wollte ja schon den fastd auf „null“ setzen, aber leider wird das von den Rheinufer-Supernodes offensichtlich nicht unterstützt und leider findet sich auch kein Admin dort, der dazu etwas sagen mag.

Null wird auch nicht unterstützt, dieser Mode hat nämlich keine Authentifizierung :wink:

Du musst „null+salsa2012+umac“ verwenden :slight_smile:

Na, ich bin ja mal gespannt, ob noch jemand antwortet.
Notfalls muss ich mit den Nodes halt nach Möhne wechseln, wenn das hier klappt. :wink:

Wie ich das sehe steigt die Nachfrage nach einem VPN Offloader immer mehr…

Naja, solange die Supernodes in allen mir bekannten Domains bei (spätestens) 20MBit/s „zumachen“, meist schon bei 8MBit/s reicht auch ein 841v8… notfalls halt ein WR1043v2 als dedizierter Offloader.Und der ist dann Gluon-Updatefähig.

1 Like

Ich habe 5 Beiträge in ein neues Thema verschoben: Nanostation batman-mesh performance

Machen die das? Ist das gewollt oder Technisch nicht anders möglich?

die 8MBit kann ich bestätigen mehr ist „so gut wie nie“ drinn.

Da ein 841er ja laut Tabelle ebenfalls 20Mbit schafft könnte
dann ja auch das „15€-Plastik-Klötzchen“ die VPN/fastd arbeit machen
wenn die Supernodes bei 8(20)Mbit dicht machen.

Wenn die Supernode mit 1 Gbit/s angeschlossen ist und 100 Tunnel drauf sind, kann man ja mal rechnen, wieviel unten rauskommen kann. :wink:

1 Like

Naja, das gilt ja nur in Mittel. Der typische Knoten Zuhause ist ja oft auf Idle.
Die offloader Gedanken sind ja die Versorgung von Plätzen und großen Einrichtungen. Wenn es gut läuft ist tagsüber viel Last auf dem Outdoor Knoten, später dann auf der Bar.

Ist das in der Möhne FW 0.6-stable20150118 // 0.6.1-snapshot20150216 per Default eingestellt,
oder muss das (wo auch immer) per Console eingefrickelt werden?

Mit Offloadern könnte man auch die Gesamtzahl der Tunnel minimieren…

Musst du manuell auf der shell regeln. Jetzt frag mich nicht wie :slight_smile:

war ja klar :wink:
@thomasDOTwtf => bitte "null+salsa2012+umac"per default in die 0.6.1-stable packen (falls möglich)

hab mal ein bischen gestöbert und für alle Fälle ein Sicherungskopie von /etc/config/fastd erstellt :wink:

------8<-------Auszug aus /etc/config/fastd-----=> config fastd 'mesh_vpn ------8<---------

    list method 'salsa2012+umac'

list method ‚null+salsa2012+umac‘

    list method 'salsa2012+gmac'
    option mtu '1426'

list method ‚null+salsa2012+umac‘ eingefügt und für alle Fälle mal den Router rebootet
=> :cold_sweat:

Sicherung der /etc/config/fastd zurückgespielt + reboot = :wink: (wieder OK)

muss vermutlich noch wo anders angepasst werden… gebe erst mal auf