Freifunk Offloader Mesh on Lan

Moin zusammen,

ich habe einen Offloader am laufen.
ETH0 ist Client (WLAN)
ETH1 ist WAN
ETH2 soll Mesh on LAN sein.
ich habe folgendes eingestellt:
„etc/config/network“

   config interface 'mesh_lan'
            option igmp_snooping '0'
            option ifname 'eth2'
            option index '4'
            option proto 'gluon_wired'
            option transitive '1'
            option macaddr '4a:f6:99:f0:ac:a4'
            option disabled '0'
    config interface 'client'
            option igmp_snooping '1'
            option type 'bridge'
            option auto '1'
            option ra_holdoff '30'
            option multicast_querier '1'
            option macaddr '00:15:5d:01:64:0b'
            list ifname 'eth0'
            list ifname 'local-port'
            list ifname 'bat0'
            list ifname 'eth2'
            option ipv6 '1'
            option keep_ra_dnslifetime '1'
            option sourcefilter '0'
            option peerdns '0'
            option robustness '9'
            option reqprefix 'no'
            option query_interval '2000'
            option query_response_interval '500'
            option proto 'dhcpv6'

uci show network

network.loopback=interface
network.loopback.ifname=‚lo‘
network.loopback.proto=‚static‘
network.loopback.ipaddr=‚127.0.0.1‘
network.loopback.netmask=‚255.0.0.0‘
network.globals=globals
network.globals.ula_prefix=‚fdd9:2fdd:3f07::/48‘
network.wan6=interface
network.wan6.proto=‚dhcpv6‘
network.wan6.ifname=‚br-wan‘
network.wan6.ip6table=‚1‘
network.wan6.sourcefilter=‚0‘
network.wan6.peerdns=‚0‘
network.wan6.reqprefix=‚no‘
network.wan=interface
network.wan.igmp_snooping=‚1‘
network.wan.ifname=‚eth1‘
network.wan.multicast_querier=‚0‘
network.wan.peerdns=‚0‘
network.wan.auto=‚1‘
network.wan.type=‚bridge‘
network.wan.proto=‚dhcp‘
network.wan.macaddr=‚4a:f6:99:f0:ac:a0‘
network.wan6_lookup=rule6
network.wan6_lookup.mark=‚0x01/0x01‘
network.wan6_lookup.lookup=‚1‘
network.wan6_unreachable=route6
network.wan6_unreachable.type=‚unreachable‘
network.wan6_unreachable.table=‚1‘
network.wan6_unreachable.target=’::/0’
network.wan6_unreachable.metric=‚65535‘
network.wan6_unreachable.gateway=’::’
network.wan6_unreachable.interface=‚loopback‘
network.mesh_wan=interface
network.mesh_wan.ifname=‚br-wan‘
network.mesh_wan.index=‚0‘
network.mesh_wan.proto=‚gluon_wired‘
network.mesh_wan.disabled=‚1‘
network.mesh_wan.transitive=‚1‘
network.mesh_lan=interface
network.mesh_lan.igmp_snooping=‚0‘
network.mesh_lan.ifname=‚eth2‘
network.mesh_lan.index=‚4‘
network.mesh_lan.proto=‚gluon_wired‘
network.mesh_lan.transitive=‚1‘
network.mesh_lan.macaddr=‚4a:f6:99:f0:ac:a4‘
network.mesh_lan.disabled=‚0‘
network.mesh_vpn=interface
network.mesh_vpn.ifname=‚mesh-vpn‘
network.mesh_vpn.transitive=‚1‘
network.mesh_vpn.mtu=‚1312‘
network.mesh_vpn.macaddr=‚4a:f6:99:f0:ac:a7‘
network.mesh_vpn.fixed_mtu=‚1‘
network.mesh_vpn.proto=‚gluon_mesh‘
network.client=interface
network.client.igmp_snooping=‚1‘
network.client.type=‚bridge‘
network.client.auto=‚1‘
network.client.ra_holdoff=‚30‘
network.client.multicast_querier=‚1‘
network.client.macaddr=‚00:15:5d:01:64:0b‘
network.client.ifname=‚eth0‘ ‚local-port‘ ‚bat0‘ ‚eth2‘
network.client.ipv6=‚1‘
network.client.keep_ra_dnslifetime=‚1‘
network.client.sourcefilter=‚0‘
network.client.peerdns=‚0‘
network.client.robustness=‚9‘
network.client.reqprefix=‚no‘
network.client.query_interval=‚2000‘
network.client.query_response_interval=‚500‘
network.client.proto=‚dhcpv6‘
network.local_node_dev=device
network.local_node_dev.type=‚veth‘
network.local_node_dev.name=‚local-node‘
network.local_node_dev.peer_name=‚local-port‘
network.local_node_dev.macaddr=‚16:41:95:40:f7:dc‘
network.local_node_dev.peer_macaddr=‚00:15:5d:01:64:0b‘
network.local_node=interface
network.local_node.ifname=‚local-node‘
network.local_node.ip6addr=‚fd74:fdaa:9dc4:2800::1:1/128‘
network.local_node.ip6deprecated=‚1‘
network.local_node.proto=‚static‘
network.gluon_bat0=interface
network.gluon_bat0.proto=‚gluon_bat0‘
network.bat0=interface
network.bat0.multicast_router=‚2‘
network.bat0.ifname=‚bat0‘
network.bat0.auto=‚1‘
network.bat0.macaddr=‚00:15:5d:01:64:0b‘
network.bat0.learning=‚1‘
network.bat0.proto=‚none‘
network.local_node_route6=route6
network.local_node_route6.target=‚2a06:e881:2000:4901::/64‘
network.local_node_route6.gateway=’::’
network.local_node_route6.interface=‚client‘
network.fallback=interface
network.fallback.sourcefilter=‚0‘
network.fallback.proto=‚dhcp‘
network.fallback.peerdns=‚1‘
network.fallback6=interface
network.fallback6.sourcefilter=‚0‘
network.fallback6.ifname=’@fallback
network.fallback6.peerdns=‚1‘
network.fallback6.proto=‚dhcpv6‘
Leider funktioniert das Mesh on ETH2 nicht. Mein Test Router hat MOL activ, aber der Knoten kommt nicht UP und er strahlt auch kein Wifi aus.

Hat jemand ne Idee?

Referenz Ticket: Freifunk Offloader Mesh WLAN

Moin,

„Offloader“ ist ein weitfassender Begriff, was ist das für Hardware?

Zeig mal bitte

ip a 

und

batctl if

Viele Grüße
Matthias

Ich hab’ 'ne Frage: warum machst Du hier einen neuen Thread auf ohne Referenz auf den alten?

1 Like

Hi,
@MPW
hier das „ip a“

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-client state UP qlen 1000
link/ether 00:15:5d:01:64:0b brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-wan state UP qlen 1000
link/ether 00:15:5d:01:64:0c brd ff:ff:ff:ff:ff:ff
4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master bat0 state UP qlen 1000
link/ether 4a:f6:99:f0:ac:a4 brd ff:ff:ff:ff:ff:ff
5: dummy0: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN qlen 1000
link/ether a2:d4:3d:7c:2e:43 brd ff:ff:ff:ff:ff:ff
6: teql0: mtu 1500 qdisc noop state DOWN qlen 100
link/void
7: br-client: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
link/ether 00:15:5d:01:64:0b brd ff:ff:ff:ff:ff:ff
inet6 fd74:fdaa:9dc4:2800:215:5dff:fe01:640b/64 scope global dynamic
valid_lft 86390sec preferred_lft 14390sec
inet6 2a06:e881:2000:4901:215:5dff:fe01:640b/64 scope global dynamic
valid_lft 86390sec preferred_lft 14390sec
inet6 fe80::215:5dff:fe01:640b/64 scope link
valid_lft forever preferred_lft forever
8: br-wan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
link/ether 4a:f6:99:f0:ac:a0 brd ff:ff:ff:ff:ff:ff
inet 172.16.100.2/24 brd 172.16.100.255 scope global br-wan
valid_lft forever preferred_lft forever
inet6 fe80::48f6:99ff:fef0:aca0/64 scope link
valid_lft forever preferred_lft forever
9: local-port@local-node: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-client state UP qlen 1000
link/ether 00:15:5d:01:64:0b brd ff:ff:ff:ff:ff:ff
10: local-node@local-port: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
link/ether 16:41:95:40:f7:dc brd ff:ff:ff:ff:ff:ff
inet6 fd74:fdaa:9dc4:2800::1:1/128 scope global deprecated
valid_lft forever preferred_lft 0sec
inet6 fe80::1441:95ff:fe40:f7dc/64 scope link
valid_lft forever preferred_lft forever
11: primary0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1532 qdisc noqueue master bat0 state UNKNOWN qlen 1000
link/ether 4a:f6:99:f0:ac:a3 brd ff:ff:ff:ff:ff:ff
inet6 fe80::48f6:99ff:fef0:aca3/64 scope link
valid_lft forever preferred_lft forever
12: bat0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-client state UNKNOWN qlen 1000
link/ether 00:15:5d:01:64:0b brd ff:ff:ff:ff:ff:ff
inet6 fe80::215:5dff:fe01:640b/64 scope link
valid_lft forever preferred_lft forever
13: mesh-vpn: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1312 qdisc fq_codel master bat0 state UNKNOWN qlen 1000
link/ether 4a:f6:99:f0:ac:a7 brd ff:ff:ff:ff:ff:ff
inet6 fe80::48f6:99ff:fef0:aca7/64 scope link
valid_lft forever preferred_lft forever

und hier das „batctl if“

eth2: active
primary0: active
mesh-vpn: active

@wusel
ich hab ein neues Thema auf gemacht, weil ich es als 2 verschiedene Themen gesehen habe…

Sieht soweit gut aus. Man könnte nochmal

brctl show

überprüfen.

Ich wiederhole nochmal die Frage nach der Hardware und was ist die Gegenstelle?

Hey @MPW,

der Offloader ist eine VM mit 3 eths.
das brctl show zeigt folgendes:

bridge name bridge id STP enabled interfaces
br-client 7fff.00155d01640b no eth0
local-port
bat0
br-wan 7fff.4af699f0aca0 no eth1

ein batctl o wenn der AP der mesh on LAN ran soll an ist sieht so aus (gefiltert auf ETH2):

  • 26:55:98:ca:f6:db 4.070s ( 12) 26:55:98:ca:f6:d8 [ eth2]
  • 26:55:98:ca:f6:d8 4.400s ( 12) 26:55:98:ca:f6:d8 [ eth2]

Auf dem Unifi UAP mit Freifunk Firmware:
batctl if

br-wan: active
primary0: active
mesh0: active

brctl show:

bridge name bridge id STP enabled interfaces
br-wan 7fff.265598caf6d8 no eth0
br-client 7fff.44d9e77b4b8d no local-port
bat0
client0

batctl o (auszug)

 * e2:7e:51:81:fe:23    3.660s   (198) 4a:f6:99:f0:ac:a4 [    br-wan]
 * 3e:92:0c:76:a2:9b    1.230s   (211) 4a:f6:99:f0:ac:a4 [    br-wan]
 * 0e:61:8e:d5:65:03    3.660s   (211) 4a:f6:99:f0:ac:a4 [    br-wan]

batctl gwl

Router ( TQ) Next Hop [outgoingIf] Bandwidth

  • 0e:90:79:19:1f:f4 (240) 4a:f6:99:f0:ac:a4 [ br-wan]: 1000.0/1000.0 MBit

das WLAN wird auch ausgestrahlt, jedoch ist keine Verbindung möglich und der Knoten ist auch Offline.

Welcher Hypervisor? Promiscuous-Mode eingeschaltet? Die Mac-Adressen ändern sich beim booten.
image

2 Likes

ja das MAC Address Ändern ist Aktiv. ist nen Hyper-V.

Mein Beileid. Da bin ich eher raus. :see_no_evil:

Vllt. kann @Parad0x helfen.

Das reicht nicht, der Promiscuous-Modus muss auch aktiviert sein.

Ich kann höchstens raten das Problem systematisch einzugrenzen.

  • Ist der Knoten korrekt konfiguriert? Könnte man mit einem zweiten Hardwarefreifunkrouter testen.
  • Geht das virtuelle Gluon über VPN online? Sieht man im batctl o die anderen Knoten der Domäne?
  • Geht das Klientnetz?

Grüße
Matthias

Also der Offloader ist online und läuft. Da brauchte ich den MAC Modus auch schon.
Es ist nur noch das MOL der Rest vom Offloader läuft.
Ich sehe ja sogar am Offloader und am AP die Verbindung, jedoch schaltet sich der MOL Knoten nicht online.

Moin,
hast du am Knoten auch MoL eingeschaltet und das Kabel korrekt gesteckt?

MOL und WOL ist auf den Knoten an.

lese ich das richtig, dass die bat0-bridge gar nicht aus dem offloader herauskommt?

Bist Du sicher, dass Du MoL beim Offloader aktiv hast?

Falls „Knoten“ den Offloader mit einschließt, dann ist der Output von „brctl show“ und „batctl if“ des offloaders unplausibel.

Hi @adorfer
jetzt mal nur der Output aus dem Offloader:

brctl show

bridge name bridge id STP enabled interfaces
br-client 7fff.00155d01640b no eth0
local-port
bat0
br-wan 7fff.4af699f0aca0 no eth1

batctl if (eth2 ist MOL)

eth2: active
primary0: active
mesh-vpn: active

uci show network.mesh_lan

network.mesh_lan=interface
network.mesh_lan.igmp_snooping=‚0‘
network.mesh_lan.ifname=‚eth2‘
network.mesh_lan.index=‚4‘
network.mesh_lan.proto=‚gluon_wired‘
network.mesh_lan.transitive=‚1‘
network.mesh_lan.macaddr=‚4a:f6:99:f0:ac:a4‘
network.mesh_lan.disabled=‚0‘

  • Matze

Kannst Du mal von außen (auf diesem vswitch auf dem das eth2 der vm landet) tcpdumpen/wiresharken, was da an Packets herauskommt?

Idealerweise evtl. sowohl auf dem VM-Blech/hypervisor aus und einmal auf dem physikalischen Kabel was zum anderen FF-Knoten geht.

Da sollten Unmengen von Batman-ADV-Frames herumfliegen… und nichts anderes.

1 Like

Wake on LAN?

das passt so nicht zusammen.
Du hast dann in der Config sowohl Clientnetz als auch MoL auf eth2.
jede Wette, dass da -zwischen den irrelevanten/belanglosen syslog-Meldungen im logread- irgendwo eines der Up-Scripte ein Config-Problem beim Booten bemängelt.

1 Like

@MPW ich meinte Mesh on WAN sorry

@adorfer
Danke für den hinweiß habe es Korrigiert und bereite gerade Wireshark vor.


Hab jede menge BATADV Broadcast

1 Like

Dann würde ich jetzt mal schauen, was der Plasterouter tut. Ob da die Pakete auf dem richtigen Interface ankommen (Paketzahlen in „ifconfig“ sollten schon reichen.)

sieht nach jeder menge broadcast aus:


ifconfig