Funktionen standortabhängig?


#1

Moin. Ich stehe ratlos vor einem merkwürdigen Problem:
Ich möchte für eine befreundete kleine Pizzeria Freifunk aufsetzen. Zu Start will ich das ganze testen & demonstrieren mit einem kleinen “TP-Link TL-WA850RE v1”, das ich zu Hause fertig konfiguriert habe. Dort funktioniert es problemlos an einer Cable-Fritzbox mit 400MBit Unitymedia-Vertrag.
Dann nehme ich das ganze Paket (TP-Link & Kabel) und stecke es in der Pizzeria in eine Steckdose in die dort verfügbare Fritzbox. (Auch am Unitymedia-Kabel, keinen km von mir zuhause entfernt). Auch nach einer Viertelstunde Warten passiert genau NIX, der Knoten ist nur als OFFLINE-Freifunk zu sehen.

Wenn ich meinen Laptop (Ubuntu 18/04 LTS, 32Bit) an das gleiche Internetkabel anschließe, zeigt Speedtest 50/5 MBit ins Internet - ich sehe keine Einschränkungen.

Die Firmware des kleines TP-Link Freifunkers ist “2.0.4 / gluon-v2017.1.8”, für FF-Dortmund, Domäne 11.

Ich hab ihn jetzt wieder zuhause ans Netz gehängt - da er schon eine fertig konfigierte GPS-Koordinate hat, wird der derzeit übergangsweise mit 750m langen WLAN-Strecke in der Karte angezeigt - aber jemand mit dem nötigen Technikwissen kann ja mal draufschauen - was kann / muss ich tun, damit die kleine Kiste auch in der Pizzeria funktioniert?

Das Gerät in der Ansicht aus der Map: https://map-ng.ffdo.de/map11/#!v:m;n:60e327d1e75e

Ich hab keine Ahnung, wo ich noch ändern oder nachschauen kann.

(PS: ja - derzeit kommt das Internet für das Gerät aus der Luft und nicht aus dem Kabel, aber am Ethernet-Kabel funktioniert es bei mir zu Hause ebenfalls perfekt. )


#2

Vermutlich ist in der Zieladresse irgendeine Form von “Gastnetz” auf den Lanports aktiv und daher der benötigte UDP-Port nicht nutzbar für das VPN.


#3

Hallo adorfer - Danke für die flotte Antwort. Aber ne reine Vermutung löst noch nicht mein Problem.

Also nächste Frage: Wie könnte ich das feststellen?
Am liebsten wäre mir die Diagnose über das am gleichen Port angeschlossenen Ubuntu/Linux - Netbook.

Abgesehen davon - wäre das “normal” für eine Unitymedia-Fritzbox?
Gastnetz gibt’s bei Fritzboxen eigentlich nur auf Port 4 - den hab ich ganz bewusst NICHT genutzt. Abgesehen davon, dass mMn Freifunk auch über das Fritzbox-Gastnetz funktioniert.

(ach - DANKE noch für das korrekte Einordnen in die richtigen Kategorien)


#4

Was dann noch sein könnte: In dem Docsis-Homegateway ist die Firewall irgendwie aktiv und meint “UDP-Flood” bekämpfen zu müssen.
Oder “Teredo-Tunnel” erkannt und verhindert zu haben.
(Ja, das wird per TR.69 gern immer wieder von Providern angeschaltet, auch wenn $KUNDIN das schon x-mal deaktiviert hatte.)


#5

Hmm. Danke für die weiteren Tipps - aber meine Fragen von eingangs bleiben bestehen:

  • Wie kann ich das verifizieren?
  • wie kann ich das umkonfigurieren/beheben?

Ich hab schon viele Fritzboxen konfiguriert - Einstellungen zum Bekämpfen von “UDP-Flood” und / oder Verhinderung eines “Teredo-Tunnels” hab ich noch nie gesehen. Ausser der Fritzbox ist in der Pizzeria auch nichts am IP-Verkehr beteiligt - das UM-Koaxkabel geht direkt in die Fritte.


#6

Vielleicht einfach nur DS-Lite … oder IPv6 Problem … hatten wir auch alles …


#7

Funzt der bei dir Zuhause auch mit eigenem VPN? Falls ja, ist es der Anschluss bzw. die dortige Fritte. Falls nein der 850er


#8

Das Ratespiel ist nicht so zielführend.

Geh mal in das FF-Offline-WLAN, und geh per SSH auf den Knoten (über V6 geht das auch ohne Gatewayverbindung) und zeig die Ausgabe von

logread

Die V6-Adresse findest du in der site.conf deiner Community. Vorher ggfs. im Konfigurationsmodus einen SSH-Schlüssel aufspielen oder ein Passwort setzen.

Viele Grüße
Matthias


#9

Auf der Statusseite ist kein Mesh VPN zu erkennen:
http://[2a03:2260:300a:b:62e3:27ff:fed1:e75e]

Auf dem Knoten bei dir Zuhause ist das Mesh VPN aktiv:
http://[2a03:2260:300a:b:ea94:f6ff:fede:f95e]

Der Knoten für die Pizzaria ist bei dir Zuhause also nur online weil er per WLAN den Uplink deines Knotens mitverwendet.

Am wahrscheinlichsten erscheint mir daher, dass du beim konfigurieren des Knotens für die Pizzaria vergessen hast den Haken für’s Mesh-VPN zu setzen.


#10

Ja, das ist korrekt, derzeit ist das Döschen bei mir zuhause ohne Kabel im Netz. Ich teste da noch nebenbei, wie weit ich das WLAN in den Garten strahlen kann, wenn ich ne passende Steckdose nehme. Und ich hab an der Stelle kein Ethernet.

Wenn ich statt meinem TP-Link das für die Pizzeria mit Kabel an meine Unitymedia-Fritzbox hänge, dann hab ich das funktionierende Freifunk- Netz.

Gibt’s für Dortmund Unterschiede durch das Ausrollen der NG-Infrastruktur? Zu Hause hab ich die neue Firmware per autoupdate bekommen (email an die Ansprechpartneradresse wäre nett gewesen) und für die Pizzeria-Box hab ich mir extra die neue Firmware manuell geholt. Oder sollte ich da erst noch die alte Firmware-Version nehmen? Dazu hab ich leider auch keine Infos gefunden.


#11

Tja, wenn Du den Test daheim nur per Wifimesh machst, dann solltest Du auch in der Pizzeria den zweiten Freifunk-Router mitnehmen, der sich dann dort um das VPN kümmert.


#12

Ach Leute - echt jetzt - das ist der “Lösungsvorschlag”: den ersten Teil meiner Antwort vereinzeln, den zweiten Teil ignorieren und mir dann vorwerfen, ich teste falsch? - das ist mir zu blöd! -

Immerhin scheint die Antwort von MPW sehr vielversprechend: wenn ich an ein Log aus dem Router komme, sehe ich Chancen, aus dem Ratespiel hier 'ne technische Analyse zu machen. Danke dafür. Ich melde mich mit Daten aus dem Log wieder - das kann aber noch ein paar Tage dauern…


#13

Okay, der übrige Dialog hier, lässt tatsächlich darauf schließen, dass vllt. einfach nur das Mesh-VPN nicht aktiviert ist.

Überprüf das bei der Gelegenheit auch noch mal.

Viele Grüße
Matthias


#14

Das heisst übersetzt soviel wie: Der für die Pizzeria vorgesehene TP-Link Repeater funktioniert problemlos (mit dem Mesh-VPN), wenn meinen Heim-Freifunk-Repeater ausstöpsele und nur die “Pizza-Box” benutze. Mesh-VPN IST aktiviert. Ich dachte, wenn ich die Worte “mit Kabel” und “funktionierende Freifunk-Netz” benutze, ist das klar genug.

Sorry, aber ich bin heute Abend etwas gehetzt und genervt! :frowning:

Ich hab aber Fortschritte zu vermelden: das ssh-Login auf die Pizza-Box klappt (erstmal noch bei mir @home) und logread liefert hübsch viele Log-Zeilen.

Wenn ich Zeit hatte für den nächsten Feldversuch in der Pizzeria, melde ich mich wieder.

PS: Die Pizza-Box hängt jetzt wieder MIT Kabel bei mir im Netz, wie ein Blick auf die Karte zeigen sollte. :wink:


#15

Wenn es bei dir funktioniert und am Aufstellungsort nicht kann das darüber hinaus noch am DNS oder an der MTU liegen.

Trage mal im Konfigurator Modus des Routers den Google DNS 4.4.4.4 oder den von Cloudflare 1.1.1.1 ein.

Manchmal hat man da mit 1&1/Versatel Anschlüssen das Problem dass die DNS Auflösung zu dem GWs nicht klappt, warum auch immer.

Liegt es an der MTU die ggf. mit dem Anschluss beim Pizza Mann inkompatibel ist kannst du leider nichts machen.

Ich hatte auch schon Orte bei denen ich keinen Router aufstellen konnte weil dieser keine Verbindung aufbauen konnte.


#16

“Mit Kabel” heisst aber doch “Mesh-on-Ethernet” (also “MeshOnLan” oder “MeshOnWan”) zu einem zweiten Knoten, der per Wan-Uplink das MeshVPN herstellt.

Ich dachte, ich könnte mir den Link diesem Thread vielleicht sparen, aber da Du offensichtlich bislang nicht systematisch vorgehen wolltest oder die anderen Threads zu ähnlich gelagerten Themen noch nicht gelesen hast, hier nochmal explizit die ToDo-Liste zum Abarbeiten, um ggf. über die Ausgaben von Logread (weiter oben hier im Thread nachgefragt) dem Problem auf die Schliche zu kommen.

https://wiki.freifunk.net/Mein_Freifunk_funktioniert_nicht_mehr


#17

Hallo a15n!

Ich komme aus Dortmund und kann dir vielleicht weiterhelfen.

NG heißt Next Generation, das heißt, das Dortmund seine Infastruktur zum Jahreswechsel verändert/erneuert hat und jetzt nur noch das neue System fährt. Was schneller, stabiler und besser läuft.
Warum du keine Info bekommen, liegt vielleicht daran, das in deinen Router keine Emailadresse hinterlegt war. Es sind einige Mails rumgeschickt worden, vielleicht solltest du Dich in die Maillingliste eintragen.

Ich kann dir nur sagen, das die Dortmunder das Forum nicht mitbenutzen und nur ab und zu rein schauen. Werde einen der beiden anschreiben, die können dir auf jeden Fall helfen.

Ich denke, du hast nur einen Hacken vergessen zu setzen in der Config.

Erstmal schönen Abend noch


#18

Hast Du mal Deinen Freifunk-Router in der Pizzeria getestet?

Falls Du Zugriff auf die Fritte dort hast kannst Du ja mal den jeweiligen Router als bevorzugtes Gerät eintragen.


#19

Nein, ich hab nur eine der beiden WA850RE in der Pizzeria angestöpselt. Die Geräte sind baugleich (ja, auch die HW-Revision), bis auf Name und Koordinaten gleich konfiguriert und funktionieren beide sowohl einzeln als auch zusammen bei mir Hausnetz. Da brauche ich keine Geräteparade in der Pizzeria abzuhalten.

An die Fritzbox möchte ich nicht ohne Not rangehen, solange ich im FF-Router noch auslesbare Logs analysieren kann.


#20

:rofl: soso - ich “will nicht systematisch vorgehen”, adorfer??? - Nein, ich werde mich nicht auf diese Ebene der persönlichen Auseinandersetzung begeben.

Nochmal ganz geduldig: Meine Konfiguration @home: Am Unitymedia-Anschluß kommt das Koax-Kabel-Signal an, geht per Koax-Kabel an meine Fritz-Box. Die macht ne prima Internet-Verbindung. An diese Fritzbox stecke ich ein Ethernet-Kabel, das auf der anderen Seite in das für Freifunk konfigurierte “TP-Link TL-WA850RE v1” Gerät steckt. Das Gerät selbst steckt in einer Steckdose.

In dieser Form funktioniert das bei mir zu Hause. Und es wäre mir neu, wenn meine Fritzbox ohne Freifunk-Software jetzt das Mesh-VPN besorgt.

In der gleichen Form, auch mit Unitymedia-Kabel und auch mit Fritzbox funktioniert es in der Pizzeria nicht. Da mag ich nicht glauben, dass es an einem Konfigurationshäkchen in der Freifunk-Software liegt.

… und - ja natürlich hab ich erstmal in andere Postings geschaut und keine Lösung gefunden. Das muss nicht heissen, das keine Lösung da ist. Logisch. Glaubt mir, ich setze mich nicht freiwillig ohne Notwendigkeit diesem Geduldsspielchen aus, jedem hier erklären zu müssen, dass ich wirklich ein Problem hab und nicht nur zu blöd bin.

Zum Link: diese Liste aus dem Wiki hab ich tatsächlich noch nicht abgearbeitet - Danke für den Tipp!