Funktionen standortabhängig?


#16

“Mit Kabel” heisst aber doch “Mesh-on-Ethernet” (also “MeshOnLan” oder “MeshOnWan”) zu einem zweiten Knoten, der per Wan-Uplink das MeshVPN herstellt.

Ich dachte, ich könnte mir den Link diesem Thread vielleicht sparen, aber da Du offensichtlich bislang nicht systematisch vorgehen wolltest oder die anderen Threads zu ähnlich gelagerten Themen noch nicht gelesen hast, hier nochmal explizit die ToDo-Liste zum Abarbeiten, um ggf. über die Ausgaben von Logread (weiter oben hier im Thread nachgefragt) dem Problem auf die Schliche zu kommen.

https://wiki.freifunk.net/Mein_Freifunk_funktioniert_nicht_mehr


#17

Hallo a15n!

Ich komme aus Dortmund und kann dir vielleicht weiterhelfen.

NG heißt Next Generation, das heißt, das Dortmund seine Infastruktur zum Jahreswechsel verändert/erneuert hat und jetzt nur noch das neue System fährt. Was schneller, stabiler und besser läuft.
Warum du keine Info bekommen, liegt vielleicht daran, das in deinen Router keine Emailadresse hinterlegt war. Es sind einige Mails rumgeschickt worden, vielleicht solltest du Dich in die Maillingliste eintragen.

Ich kann dir nur sagen, das die Dortmunder das Forum nicht mitbenutzen und nur ab und zu rein schauen. Werde einen der beiden anschreiben, die können dir auf jeden Fall helfen.

Ich denke, du hast nur einen Hacken vergessen zu setzen in der Config.

Erstmal schönen Abend noch


#18

Hast Du mal Deinen Freifunk-Router in der Pizzeria getestet?

Falls Du Zugriff auf die Fritte dort hast kannst Du ja mal den jeweiligen Router als bevorzugtes Gerät eintragen.


#19

Nein, ich hab nur eine der beiden WA850RE in der Pizzeria angestöpselt. Die Geräte sind baugleich (ja, auch die HW-Revision), bis auf Name und Koordinaten gleich konfiguriert und funktionieren beide sowohl einzeln als auch zusammen bei mir Hausnetz. Da brauche ich keine Geräteparade in der Pizzeria abzuhalten.

An die Fritzbox möchte ich nicht ohne Not rangehen, solange ich im FF-Router noch auslesbare Logs analysieren kann.


#20

:rofl: soso - ich “will nicht systematisch vorgehen”, adorfer??? - Nein, ich werde mich nicht auf diese Ebene der persönlichen Auseinandersetzung begeben.

Nochmal ganz geduldig: Meine Konfiguration @home: Am Unitymedia-Anschluß kommt das Koax-Kabel-Signal an, geht per Koax-Kabel an meine Fritz-Box. Die macht ne prima Internet-Verbindung. An diese Fritzbox stecke ich ein Ethernet-Kabel, das auf der anderen Seite in das für Freifunk konfigurierte “TP-Link TL-WA850RE v1” Gerät steckt. Das Gerät selbst steckt in einer Steckdose.

In dieser Form funktioniert das bei mir zu Hause. Und es wäre mir neu, wenn meine Fritzbox ohne Freifunk-Software jetzt das Mesh-VPN besorgt.

In der gleichen Form, auch mit Unitymedia-Kabel und auch mit Fritzbox funktioniert es in der Pizzeria nicht. Da mag ich nicht glauben, dass es an einem Konfigurationshäkchen in der Freifunk-Software liegt.

… und - ja natürlich hab ich erstmal in andere Postings geschaut und keine Lösung gefunden. Das muss nicht heissen, das keine Lösung da ist. Logisch. Glaubt mir, ich setze mich nicht freiwillig ohne Notwendigkeit diesem Geduldsspielchen aus, jedem hier erklären zu müssen, dass ich wirklich ein Problem hab und nicht nur zu blöd bin.

Zum Link: diese Liste aus dem Wiki hab ich tatsächlich noch nicht abgearbeitet - Danke für den Tipp!


#21

In den Postings geht es mit den (Fach-) Begrifflichkeiten und Nicht-Fachbegrifflichkeiten etwas hin und her. Techniker müssen sich dann oft erst mal zurechtfinden, was wohl gemeint ist. Da Hilft es, wenn man exakt beschreibt, auch wenn es länger wird.

Wenn du mit “besorgt” meinst, dass über das Internet, welches deine FritzBox bereitstellt, das Mesh-VPN (Tunnel) aufgebaut wird: Genau so ist es. Und dafür wird auch keine Freifunk Firmware beim Internet zur Verfügung stellenden Gerät benötigt.

Vermutlich verwechselst du die verschiedenen Mesh. Es gibt auch noch ein Mesh-over-LAN und ein Mesh-over-WLAN. Die funktionieren nur mit anderen Freifunkknoten mit gleicher Freifunk Firmware / aus der gleichen Community. Da hast du dann recht. Ach ja, und das Mesh-over-WAN hab ich noch vergessen. Das ist aber u. U. noch mal ein Sonderfall :slight_smile:


#22

Hallo @a15n, ich gehe stark davon aus das dein Heim-FF-Router auf experimental und Autoupdate stand und sich deswegen die neue Firmware gezogen hat.
Die Änderungen sind mehrfach über die Mailinglisten gegangen.


#23

Haben beide Anschlüsse die gleichen Verträge? Hintergrund: ist beides Dual-Stack (Fritzbox hat öffentliche v4- und öffentliche v6-Adresse) oder beides Dual-Stack Lite (Fritzbox hat keine v4-, aber öffentliche v6-Adresse)?

Was sagt dort jeweils ip addr show dev $(ip route show | grep default | awk '{for(i=1; i<NF; i++) if($i=="dev") print $(i+1);}') (“ip addr show dev eth0” in Zeiten der predictable device names :frowning:)? Hintergrund der Frage, wie oben: UM Business und UM Privat sind (zumindest hier) unterschiedliche Netze (UM Business ist v4-only, MTU 1500; UM Privat ist normalerweise DS Lite, MTU bei IPv4 deutlich unter 1500, ggf. aber auf DS umstellbar, dann MTUv4 wieder 1500).

Andererseits: lt. site.conf nutzt Dortmund 1280 als MTU für fastd => das sollte eigentlich kein Problem darstellen.

Um Portblockade (auf der Pizzeria-FB) auszuschließen vom Laptop aus: sudo traceroute -m 20 -U --port=10001 sn-dtm01.ffdo.de (es sollte nach ~12 Hops “sn-dtm01.ffdo.de (31.172.33.5)” erreicht werden). Gegenprobe mit “‑‑port=10000”, sollte ggf. nach 20 Hops austimen, wenn da fastd läuft… Im Zweifel mit den anderen Nodes aus der site.conf wiederholen.

Zweimal gleiche Fritzbox und UM-Koaxkabel sagt nichts über den jeweils gelieferten Dienst aus; es unterscheiden sich ja schon die Geschwindigkeiten, warum nicht auch andere grundlegende Netzparameter?


#24

Was für Änderungen? Wechsel nach vxlan für das Mesh?


#25

Hallo @lumo, mein Heim-FF-Router stand natürlich auf Autoupdate, aber stand und steht auf ‘stable’. Was meinst Du mit ‘Mailinglisten’? Meine Kontaktadresse ist im Router hinterlegt. Ging die Mail dorthin? (dann muss ein Spam-Filter aktiv geworden sein). Oder muss ich mich noch woanders eintragen?

@wusel: Danke für die Hinweise. Diese V6-Thematik hab ich bisher weitestgehend ausgeblendet und ignoriert. Bislang hat bei mir alles noch mit V4 problemlos funktioniert. Aber gut, V6 ist inzwischen alt genug. :wink: Ich hatte gehofft, dass ohne Eingriff in Fritzbox-Konfiguration & Vertrag geht.

Wenn Du sn-dtm01.ffdo.de aus der site.conf liest, ist das noch die alte Dortmunder Infrastruktur, oder? Mein Home-FF-Router hat als Supernode snng-dtm2_ffdo-d11.

@steneu: ich meine exakt das Mesh-VPN. Mag sein, dass die einzelnen Meshes gerne verwechselt werden. Aber anzunehmen, dass der Frager die Meshes verwechselt, nur damit Antworten leichter ist, halte ich nicht für zielführend.


#26

Das ist die verlinkte site.conf, soweit ich das sehe. Im Zweifel nimm’ die Hostnamen, die in der FW drinstehen … Beide Knoten haben gleiche FW jetzt?


#27

soweit sind wir noch nicht.
Einfach der Split in mehrere Domänen… verbunden mit dem Wechsel von FastD nach L2TP sind Baustellen genug.


#28

ok, dann hat sich vermutlich dein Knoten bei einer versehentlicher Brücke der alten und neuen Struktur in die neue Struktur aufgemacht.
Wir haben es auf den Mailinglisten des ffdo angekündigt und bisher mehr auf Wunsch umgezogen. Der große Umzug steht noch aus…


#29

Hallo @lumo, mein Heim-FF-Router stand natürlich auf Autoupdate, aber stand und steht auf ‘ stable ’.

Welche Version hat er denn jetzt? Sollte 2.0.4 sein. Oder ging es um das Update von alter auf neue Struktur? Da gab es (leider) Ende 2018 einen Fehler bei uns der dafür gesorgt hat das viele Router auf die neue Struktur umgezogen wurden. War leider nicht so geplant… Die meisten haben dann aber auch noch ein Downgrade verpasst bekommen. Evtl. ist uns deiner durch gegangen.

Was meinst Du mit ‘Mailinglisten’?

Ist halt ein Mailverteiler. Eintragen geht hier: freifunk-do Infoseite

Meine Kontaktadresse ist im Router hinterlegt. Ging die Mail dorthin? Oder muss ich mich noch woanders eintragen?

Wir nutzen die Kontaktdaten auf den Routern nicht wirklich. Kommunikation läuft nahezu komplett über die obige Liste. Bei einem Freifunk-Treffen in Unna (Dortmund und Unna sind eine FF-Community) haben wir auch mal länger diskutiert ob man die Mailadressen in den Routern überhaupt so ohne weiteres DSGVO-mässig verwenden darf. Ich hab da eine relativ klare meinung zu aber letztlich hat das nix mit deinem Problem zu tun. Entsprechend will ich das Fass hier jetzt nicht aufmachen. :wink:

Wenn Du sn-dtm01.ffdo.de aus der site.conf liest, ist das noch die alte Dortmunder Infrastruktur, oder? Mein Home-FF-Router hat als Supernode snng-dtm2_ffdo-d11 .

Exakt. Ich hoffe allerdings, dass du da mehr als nur einen Supernode drin hast?

Nun auch noch kurz zum eigentlichen Problem: Ich hatte schonmal sorgen mit DNS. Der Router konnte keine Namen auflösen und entsprechend auch keinen Tunnel zum Supernode aufbauen. Neben dem oben erwähnten Logs wäre entsprechend auch ein “ping www.freifunk-dortmund.de” noch einen Versuch wert.

Gruß,
Stefan


#30

Hallo Stefan,

Danke für die Info. Hab mich jetzt in den Mailverteiler eingetragen.

Ist es denn in Ordnung, wenn ich die von mir betreuten FF-Router manuell auf die neue Infrastruktur umziehe oder sollte ich das dem “offiziellen” automatischen Update überlassen?

Ich hab das Gefühl (ohne systematisch zu messen), dass die neue Struktur für deutlich bessere Bandbreite sorgt.
@supernode: ich meine nicht die site.conf sondern die Info, die der FF-Router per HTTP ausgibt. Da steht eben immer ein Supernode.


#31

Kannst du sehr gerne machen. Die Verfügbarkeit auf der neuen Struktur ist aber noch nicht so hoch wie sie sein könnte da wir da noch dran arbeiten. Die “Wartungszeiten” sind aber sehr, sehr überschaubar. Allerdings kündigen wir die nicht groß/immer an weil wir die neue Struktur noch nicht als wirklich produktiv sehen. Letztlich ist es deine Entscheidung, denn…

Ich hab das Gefühl (ohne systematisch zu messen), dass die neue Struktur für deutlich bessere Bandbreite sorgt.

… dem ist definitv so. Hab gestern Spätabend mit einem Freifunker der eine SEHR große Gruppe Clients in Unna betreut mal einen kurzen (~2-3 Minuten) Lasttest gemacht. 400Mbit/Sek sind aktuell mit den neuen Supernodes machbar. Flaschenhals war dann am Ende die CPU der Supernodes… allerdings ist aktuell in der VM auch nur ein Kern aktiv. Wenn die alten Supernodes irgendwann ™ abgeschaltet werden können, dann werden wir die CPUs den neuen Supernodes zuordnen. Dann sollte noch mehr gehen…

@supernode: ich meine nicht die site.conf sondern die Info, die der FF-Router per HTTP ausgibt. Da steht eben immer ein Supernode.

ACHSO! Das ist dann vermutlich der aktuell verbunden/genutzte Supernode AFAIR. Ich gebe aber zu, dass die Router Firmware nicht wirklich meine Baustelle ist.


Günstiger Einstiegsrouter? (für aktuelles Gluon-Release)
#32

Dann geh doch mal mit gutem Beispiel voran. Die Infos liegen ja hier, man muss sie nur auswerten, denn:

Aber ein gewisser Knoten namens „FF-DO-Holzwickede-UnnaerStr19“.

In der Karte ist eindeutig zu sehen, dass der Router NICHT selbst VPN nutzt, sondern über den benachbarten Knoten per WLAN-Mesch online geht.

Du hast das Mesch-VPN nicht aktiviert oder es funktioniert nicht. Zur Erklärung, die Rubrik „Gewähltes Gateway“ zeigt an über welche Knoten hinweg der ausgewählte Knoten den Weg zum Gateway gewählt hat. Dabei wird immer der kürzeste Weg gewählt. Dass er den Umweg über den anderen Knoten nimmt, zeigt, dass Mesch-VPN nicht aktiv ist oder nicht funktioniert.

Grüße
Matthias


#33

Matthias, herzlichen Dank für Deine Beobachtung. Die gleiche Beobachtung hab ich schon vor ein paar Tagen kommentiert. S.o.


#34

Herzlichen Dank an euch alle, die ihr euch in der einen oder anderen Form um mein Problem gekümmert habt!

Ich hab keine Ahnung, was ihr gemacht habt, aber jetzt läuft es. Ich war’s definitiv nicht. Ich hab den FF-Router nur mit einem ssh-Passwort zur Fernwartung versehen und an verschiedenen Stellen bei mir im Haus ausprobiert. Für alle “Thomasse” unter euch: ja, doch (!) das Hä©kchen für VPN-Mesh war die ganze Zeit aktiv - nur das Ethernet-Kabel war halt nicht immer angeschlossen.
Heute Abend bin ich mit viel neuen Know-How über Freifunk-Einzelheiten und meinem Laptop bewaffnet nochmal in der Pizzeria aufgetaucht, hab den FF-Router wieder da angeschlossen, wo er hin soll und hat darauf gewartet, dass die FF_OFFLINE-SSID auftaucht.
… und gewartet …

… und dann hatte sich mein Laptop schon ins “Freifunk”-Netz eingewählt. Der Router hat angesichts der Drohung mit Know-How und Equipment aufgegeben. :wink:

Ich hab KEINE AHNUNG, woran es letztendlich gelegen hat. Jetzt geht’s.

Und ich hab einiges Neues über Freifunk und auch 'ne Menge über Kommunikationsprobleme beim Helfen und sich helfen lassen gelernt. :wink:

Danke dafür! Und allen Mitlesern noch einen schönen Rest vom Sonntag!


#35

Freut mich, dass es klappt. Dann hat sich die Mühe ja gelohnt.

Oh ja, da sprichst du sicherlich vielen hier aus der Seele. Wir hinterfragen halt die Selbstangaben immer sehr kritisch, weil gerade bei Neulingen viele Fehler und Missverständnisse passieren.

Und die verschiedenen Sichtweisen muss man auch berücksichtigen.