[gelöst] Freifunk stört WLAN des Nachbarn

Hallo zusammen,
ich hoffe jemand kann mir einen Tipp geben. Ich habe eine Ubiquiti PicoStation M2HP 2.4GHz bei mir auf dem Dach installiert. Von der Sendeleistung her, steht diese auf 100mw.
Die Adresse lautet: 2a03:2260:114:ac01:6a72:51ff:fe0e:1aeb

Zur Verbesserung der Performance hatte ich bei dieser Mesh on WAN aktiviert und einen TL-WR1043ND dahintergeschaltet. Bei diesen war ebenfalls Mesh on WAN an.

Inzwischen ist das aber wieder abgeschaltet. Die PicoStation baut ihr eigenes VPN auf und der TL-WR1043ND ist abgeschaltet.

So, nun das Problem:
Immer wenn die PicoStation läuft, haben meine Nachbarn (Einfamilienhäuser ca. 30m Abstand) massive Probleme mit ihrem WLANs. Wir hatten dort Speedtest laufen lassen. An einem VDSL 25 Anschluss kam dort nur noch ca. 1mbit an. Sobald das Freifunk weg ist, steigt der Speedcheck auf volle 25mbit. Natürlich habe ich überprüft, mit welchem WLAN der Test-Laptop und das Test-ipad verbunden sind und wir sind sämtliche anderen Störquellen im Haus durchgegangen.
Probiert hatten wir u.a.alle anderen Geräte abzuschalten (Haussicherungen entfernt) , den Router zu tauschen (Fritzbox zu Easybox) und die Kanäle zu wechseln, was alles nicht geholfen hat.

Rausgefunden habe ich dabei, dass die Störung schon auftritt, wenn das MESH-WLAN aktiv ist (wifimesh-g-ac) und das Clientnetz abgeschaltet ist.
Im 5 ghz-Bereich funktioniert alles problemlos.

Mein eigenes WLAN im Haus (auch 2,4Ghz) hat keinerlei Probleme. Allerdings bekomme ich von der Picostation auf dem Dach auch nicht soviel mit.

Was kann das sein? Meine Picostation mesht mit zwei weiteren Knoten, die selber keinen Uplink haben und wo momentan auch keiner angemeldet ist. Selbst wenn die Picostation die ganze Zeit dauersendet, sollte es doch egal sein, wenn die Nachbarn auf anderen Kanälen (1 oder 6) unterwegs sind. Als nächstes werde ich die Picostation vom Dach holen und schauen ob sie dann mein WLAN stört, wenn sie direkt neben dem Router liegt.

Mein Nachbar ist richtig sauer, weil er mit dem Problem schon eine Menge Zeit verschwendet hat und jetzt einen Schuldigen gefunden hat.

Ich bin für jeden Tipp dankbar.

Meine Fritz!Box zeigt in den Funkeinstellungen benachbarte Netzwerke und andere Störquellen an. Kannst du das bei deinem Nachbarn mal abchecken? Der Dialog sieht ungefähr so aus.

Der Klassiker ist, dass sich einfach zuviele Netze in einem Kanalbereich aufhalten. Meine Fritz!Box habe ich dabei gezielt auf 13 senden lassen - weit weg von der 1, die bei FFEL genutzt wird. Im 2.4 GHz-Band stören sich die Kanäle auch gegenseitig, deshalb folgen viele einem 1, 5, 9, 13 Schema.

Im 5 GHz gibt es dieses Problem nicht, da sind die Kanäle von vorneherein störungsfrei angelegt. Das würde dafür sprechen, dass die Kanalwahl dein Problem ist.

Ein Kanalwechsel hatte leider nichts gebracht. Aber selbst wenn viel los ist, sollte nicht das eigene WLAN immer gewinnen, wenn Router und Laptop nur 1m auseinander stehen? Das Freifunk aus 30m Luftlinie + Glasscheibe sollte doch dann nichts zu melden haben.

Nichtmal mit großem Abstand? Verrückt.

Die Entfernung ist schon fast „zu“ nahe an der Antenne - Funk ist mit den ganzen Reflektionen gerade in Innenräumen auch sehr schwer vorherzusagen, Wenn du ein Android-Handy hast, würde ich die Lage mal mit der App WiFi Analyzer checken.

Dafür hat so ein Freifunk-Router auch meist bessere Antennen also die Fritz!Box. Funkmagie, siehe oben. :wink:

Man könnte überlegen, Freifunk nur auf 5 GHz anzubieten, aber gerade beim Meshen ist das natürlich eher doof.

In welcher Community bist du überhaupt unterwegs? Habe gerade keine Tabelle zur Hand, zu welcher die IP gehört. :wink:

wobei in Europa wohl 1-7-13 richtiger wäre, aber Kanal 13 sollte eigentlch immer klappen.
http://freifunk-burscheid.de/?page_id=619

5 GHZ Indoor ist kein Ding, Outdoor sind nur bestimmte Kanäle erlaubt 100-140 jedoch nur mit DFS, praktisch unterstützt OpenWRT das zumindest nicht.
Die Kanäle dort drüber empfangen die Endgeräte nicht.

Ich weiß gerade nicht ob ich lachen oder weinen soll.

Wer also in Reichweite eines unserer Freifunksender noch einen
Heimnetz-Router betreiben will, sollte diesen entweder auf „automatisch“
einstellen, oder IEE 802.11b einstellen und Kanal 13 nehmen.

Ihr ratet wirklich den Menschen sie sollen 11b WLAN mit 11 MBit maximal verwenden? Wie war das mit Schaden von Freifunk abwenden? Wenn man technisch nicht kompetent ist, sollte man es lieber lassen technische Empfehlungen von sich zu geben.

@Harald
Hast du Zugriff auf deine Pico per SSH? Wenn ja poste mal bitte die WLAN Daten mit dem Befehl iwinfo

Falls möglich, kannst du temporär einen anderen Knoten am gleichen Standort wie die Pico aufstellen und prüfen ob deine Nachbarn dann immer noch Probleme haben?

2 Likes

Das klingt eher so als ob es zu dem „MoW“ auch noch auf dem gleichen Layer2-Netz ein privates Wifi geben würde, z.B. in Deiner Fritzbox oder ein andererweite „privater“ AP auf dem gleichen Netz.

das ist meine Quelle, bei uns ist auf 40 eingestellt.
und richtig, bei mir ist es falsch abkopiert.
Wird berichtigt.
Danke für den Hinweis.

Wie dem auch sei, wir haben hier vermutlich einen Fall der beweist, dass ETSI EN 300/328 doch nicht so völlig grundlos beschlossen wurde.
(Und wogegen wir als Freifunker geflissentlich verstoßen indem wir behaupten, unserer Geräte seien vor dem 1.1.2015 erstmalig in Verkehr gebracht worden. Selbst wenn die Stockfirmware es inzwischen „kann“, bauen wir es halt gleich wieder aus mit unsererer Openwrt-Version.)

Es geht sich hierbei um die Aachener Firmware. An der Entfernung beim Nachbarn zwischen Router und Laptop liegt es nicht, da ohne Freifunk alles schön schnell ist. Das Freifunk auf 5GHz wollte ich eigentlich nicht umbauen, da ich gerade erst eine zweite Picostation aufgebaut habe.

Ich vermute, dass diese Probleme erst bestehen, seit diese untereinander meshen. Warum das so ist, weiß ich nicht :frowning:

Hallo,
iwinfo sagt nichts, da abgeschaltet. Momentan werde ich es auch nur wieder einschalten, wenn es nicht in den halben Ort strahlt. Ich kann folgendes liefern und hoffe das es hilft.

root@ffac-Gressenich-Bergerhof27:~# uci -P/var/state show wireless
wireless.radio0=wifi-device
wireless.radio0.type=mac80211
wireless.radio0.hwmode=11g
wireless.radio0.path=pci0000:00/0000:00:00.0
wireless.radio0.country=DE
wireless.radio0.channel=11
wireless.radio0.htmode=HT40-
wireless.radio0.disabled=0
wireless.radio0.txpower=8
wireless.client_radio0=wifi-iface
wireless.client_radio0.ifname=client0
wireless.client_radio0.network=client
wireless.client_radio0.device=radio0
wireless.client_radio0.mode=ap
wireless.client_radio0.macaddr=6a:74:52:0e:1a:eb
wireless.client_radio0.ssid=Freifunk
wireless.client_radio0.disabled=1
wireless.mesh_radio0=wifi-iface
wireless.mesh_radio0.ifname=mesh0
wireless.mesh_radio0.network=mesh_radio0
wireless.mesh_radio0.device=radio0
wireless.mesh_radio0.bssid=CA:FF:24:FF:AC:24
wireless.mesh_radio0.mcast_rate=12000
wireless.mesh_radio0.mode=adhoc
wireless.mesh_radio0.macaddr=6a:75:52:0e:1a:eb
wireless.mesh_radio0.ssid=wifimesh-g-ac
wireless.mesh_radio0.disabled=1

Was ist ein „MoW“ ? Das Gesamtsetup ist hier Standard. Meine Fritzbox kümmert sich um mein WLAN. An der Fritzbox hängt ein großer Switch und dort hängt die Picostation dran. Außer mit den Einstellungen für das Mesh on WAN und die Sendeleistung habe ich dort nichts gemacht.

Das ist für mich die heißeste Spur. Ist ETSI EN 300/328 mit Openwrt inzwischen umsetzbar?

Was ich mich auch gerade Frage ist, warum das wifimesh-g-ac hier auf Kanal 11 + 7 angezeigt wird. Ich dachte es läuft alles über einen Kanal?

Es verhält sich hier so, dass wenn die Picostation mit nur 25mW sendet, er einen ungefähren Download von 10mbit hat. Drehe ich das auf 100mW hoch, singt der Download wieder auf 1mbit.

Deine Community benutzt Kanäle, die 40 MHz breit sind, also mehr als einen Standardkanal belegen. Das könnte jenach Tool zu so einer Anzeige führen.

Probier doch mal -

uci set wireless.radio0.htmode=HT20
uci commit wireless
wifi

Vielleicht ändert das was am Verhalten.

Hallo, ich bin mir ziemlich sicher, dass die Störung durch die Mesh on wan Pakete entsteht die von deinem eigen wlan verteilt werden. Dieses wlan ist ja sozusagen im WAN des Freifunk Routers.

Sehr gut analysiert in diesem Blog Post:
„Das »Problem« ist, daß Multi- und Broadcastpakete im WLAN typischerweise mit der niedrigsten Geschwindigkeit ausgestrahlt werden (802.11bgn: 1 MBit/sec); Hintergrund ist, daß der AP nicht zwingend weiß, welche Geschwindigkeit die Ziel-Clients unterstützen.“

https://v2.blogdoch.net/2015/06/22/wusel-062653/

Wenn ich richtig liege ist Lösung also den zusätzlichen offloader wieder zu aktivieren, dort Mesh on LAN zu aktivieren und entsprechend an einen LAN Port die Pico Station per Mesh on wan anzubinden.
So kommen keine Batman Pakete in dein privates Netz und deine wlan Geräte werden nicht mehr zu Störenden.

Dein eigenes Netz bleibt übrigens gut nutzbar, da sich seine Geräte die Artime recht gut einteilen können, sie schicken die störenden Pakete ja selber.

2 Likes

Er schreibt aber das das WLAN seines Nachbarn, welches ~30m entfernt ist, gestört wird sobald bei der Pico das (Mesh) WLAN aktiv ist. Also kann es nicht an MoW liegen. Zudem schreibt der Threadstarter das die Pico selber Mesh-VPN jetzt macht, auch wenn das Leistungstechnisch für den Popo ist.

Ich habe so eine Problematik noch nicht gehabt, ich fahre, wie die meisten wohl auch, selber ein privates WLAN (Kanal 13) neben dem Freifunk WLAN (Kanal 1) Beide Router stehen auch nah beieinander.

In sofern kann natürlich auch ein defekt der Pico Station nicht ausgeschlossen sein. Aber das ist ohne entsprechendes Mess Equipment nur schwer heraus zu finden.

Sobald dort das Mesh Wlan aktiv ist kommen die Batman Paket er der umgebenden Mesh Router dazu, dadurch steigt die Belastung weiter an.

30m plus Wände ist eine fiese Entfernung. Nah genug um sich gegenseitig zu stören, aber weit genug damit die Mechanismen zu Aufteilung der airtime zwischen den Netzen nicht mehr zuverlässig funktioniert.

Trotzdem sollte es nicht dazu kommen wenn trotz HT40 der Abstand zwischen dem Privat WLAN und dem Freifunk WLAN groß genug ist. Deswegen ziehe ich auch ein defekt der Pico in Erwägung, das die bei aktiviertem WLAN das ganze Frequenz Band versaut. Hier nochmal mein Hinweis mal einen Test zu machen mit einem anderen Freifunk Router an selber Position wie die Pico zu betreiben um das festzustellen bzw. auszuschließen das es an der Pico liegt.

Genau: Wenn es wirklich stimmt, dass der Freifunk-Router auf Kanal 11 (auch mit HT40) ein WLAN auf Kanal 1 massiv stört, dann kann ich mir das auch nur mit einem Hardwaredefekt erklären.

Alternativ wäre es denkbar, dass zunächst auf Kanal 6 getestet wurde, in der falschen Annahme, dass das von Kanal 11 weit genug weg ist, und dass dann der Test auf Kanal 1 nur halbherzig und nicht gründlich genug war und daher ein falsches Ergebnis geliefert hat.

Wenn die Montageposition der Picostation halbwegs vernünftig erreichbar ist, würde ich als erstes einen testweisen Austausch empfehlen. Passende Hardware kann bestimmt jemand aus der Regio Aachen verleihen, oder?

@skralle auf welchem Netz sendet denn dein privates wlan?

Das ist nicht zufällig etwas im Bereich 1-6?