Gluon v2014.4 - Firmware 0.6 stable

Oh, verlesen - die MAC sollte natürlich gleich bleiben.

Hi,
habe gerade die Firmware manuell neu installiert. Nach einiger Zeit kommt folgende Fehlermeldung in der Logdatei (die sich ständig wiederholt):

Jan 23 18:01:00 ff-hat1 kernel: [ 574.730000] batadv-vis: page allocation failure: order:5, mode:0x1040d0
Jan 23 18:01:02 ff-hat1 kernel: [ 574.730000] CPU: 0 PID: 1403 Comm: batadv-vis Not tainted 3.10.49 #1
Jan 23 18:01:02 ff-hat1 kernel: [ 574.740000] Stack : 00000000 00000000 00000000 00000000 803bce76 00000038 818d6fb8 00000000
Jan 23 18:01:02 ff-hat1 kernel: [ 574.740000] #011 802f5bc8 8033f9a3 0000057b 803b3a00 818d6fb8 00000000 00000057 00000000
Jan 23 18:01:02 ff-hat1 kernel: [ 574.740000] #011 00000057 80290d60 00000000 801f39cc 00000006 00000000 802f7258 80aa9d64
Jan 23 18:01:02 ff-hat1 kernel: [ 574.740000] #011 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Jan 23 18:01:02 ff-hat1 kernel: [ 574.740000] #011 00000000 00000000 00000000 00000000 00000000 00000000 00000000 80aa9cf0
Jan 23 18:01:02 ff-hat1 kernel: [ 574.740000] #011
Jan 23 18:01:02 ff-hat1 kernel: [ 574.780000] Call Trace:
Jan 23 18:01:02 ff-hat1 kernel: [ 574.780000] [<80235a54>] show_stack+0x48/0x70
Jan 23 18:01:02 ff-hat1 kernel: [ 574.790000] [<802a066c>] warn_alloc_failed+0x108/0x12c
Jan 23 18:01:02 ff-hat1 kernel: [ 574.790000] [<80081e48>] __alloc_pages_nodemask+0x3a0/0x634
Jan 23 18:01:02 ff-hat1 kernel: [ 574.800000] [<800930f8>] __get_free_pages+0x18/0x4c
Jan 23 18:01:02 ff-hat1 kernel: [ 574.800000] [<802242d0>] seq_read+0x270/0x48c
Jan 23 18:01:02 ff-hat1 kernel: [ 574.810000] [<80296ac4>] vfs_read+0xa4/0x164
Jan 23 18:01:02 ff-hat1 kernel: [ 574.810000] [<80078198>] SyS_read+0x58/0xa4
Jan 23 18:01:02 ff-hat1 kernel: [ 574.820000] [<800625b0>] stack_done+0x20/0x44
Jan 23 18:01:02 ff-hat1 kernel: [ 574.820000]
Jan 23 18:01:02 ff-hat1 kernel: [ 574.820000] Mem-Info:
Jan 23 18:01:02 ff-hat1 kernel: [ 574.820000] Normal per-cpu:
Jan 23 18:01:02 ff-hat1 kernel: [ 574.830000] CPU 0: hi: 0, btch: 1 usd: 0
Jan 23 18:01:02 ff-hat1 kernel: [ 574.830000] active_anon:957 inactive_anon:16 isolated_anon:0
Jan 23 18:01:02 ff-hat1 kernel: [ 574.830000] active_file:674 inactive_file:708 isolated_file:32
Jan 23 18:01:02 ff-hat1 kernel: [ 574.830000] unevictable:0 dirty:0 writeback:0 unstable:0
Jan 23 18:01:02 ff-hat1 kernel: [ 574.830000] free:546 slab_reclaimable:339 slab_unreclaimable:1681
Jan 23 18:01:02 ff-hat1 kernel: [ 574.830000] mapped:389 shmem:40 pagetables:116 bounce:0
Jan 23 18:01:02 ff-hat1 kernel: [ 574.830000] free_cma:0
Jan 23 18:01:02 ff-hat1 kernel: [ 574.860000] Normal free:2184kB min:676kB low:844kB high:1012kB active_anon:3828kB inactive_anon:64kB active_file:2696kB inactive_file:2832kB unevictable:0kB isolated(anon):0kB isolated(file):128kB present:32768kB managed:28592kB mlocked:0kB dirty:0kB writeback:0kB mapped:1556kB shmem:160kB slab_reclaimable:1356kB slab_unreclaimable:6724kB kernel_stack:392kB pagetables:464kB unstable:0kB bounce:0kB free_cma:0kB writeback_tmp:0kB pages_scanned:32 all_unreclaimable? no
Jan 23 18:01:02 ff-hat1 kernel: [ 574.910000] lowmem_reserve[]: 0 0
Jan 23 18:01:02 ff-hat1 kernel: [ 574.910000] Normal: 1424kB (UEMR) 1268kB (UEMR) 2016kB (EMR) 232kB (R) 164kB (R) 1128kB (R) 0256kB 0512kB 01024kB 02048kB 0*4096kB = 2152kB
Jan 23 18:01:02 ff-hat1 kernel: [ 574.930000] 1454 total pagecache pages
Jan 23 18:01:02 ff-hat1 kernel: [ 574.930000] 0 pages in swap cache
Jan 23 18:01:02 ff-hat1 kernel: [ 574.930000] Swap cache stats: add 0, delete 0, find 0/0
Jan 23 18:01:02 ff-hat1 kernel: [ 574.940000] Free swap = 0kB
Jan 23 18:01:02 ff-hat1 kernel: [ 574.940000] Total swap = 0kB
Jan 23 18:01:02 ff-hat1 kernel: [ 574.950000] 8192 pages RAM
Jan 23 18:01:02 ff-hat1 kernel: [ 574.950000] 977 pages reserved
Jan 23 18:01:02 ff-hat1 kernel: [ 574.950000] 265127 pages shared
Jan 23 18:01:02 ff-hat1 kernel: [ 574.960000] 5507 pages non-shared

Was mich beunruhigt ist : page allocation failure

Desweiteren erscheint mein AP in den Online-Listen als offline oder ist gar nicht vorhanden. Mit Version 0.53 hatte ich keine Probleme.
An welcher Schraube kann ich drehen ?

Hardware : TP-WR841N V8

MFG

Tobias

Die Meldungen liefen gerade nur noch durch die Logdatei.
Der Load vom Accesspoint lag bei > 14, so dass ich ihn erst mal abgeschaltet habe…

Irgendwas läuft da leider nicht rund :frowning:

Tobias

Seit 0.6 gibt es bei uns auf der Karte auch Probs.
http://map.freifunk-ruhrgebiet.de/HAM/geomap.html
Gaanz links ist „Nordherringen 1“ als Router aktiv. Schaltet man um auf Liste fehlt er.
Schaltet man auf Graph hat er ein Symbol wie ein Client - allerdings hat er keinen Router?!

Dasselbe Prob tritt auch bei „Ammerweg“ auf, aber der ist schlechter zu finden :wink:

@paulinsche
https://github.com/ffruhr/site-ffruhr/tree/0.6

Immer noch: regdom = ‚US‘
Gibt es einen einzigen vernünftigen Grund, das nicht mal auf DE umzustellen?
Außer natürlich: „Das haben wir schon immer so gemacht! 1elf“

Das steht: „Das ist der Schlüssel deines Freifunkknotens zur Information. Der Knoten ist nun direkt nutzbar.“ - D.h.: keine Registrierung mehr nötig?

Jupp, daher steht es dort auch so.
Ich finde gerade den Beitrag mit der Ankündigung nicht…

1 Like

Das steht nur in den anderen Beiträgen, wir haben mit der offiziellen Ankündigung gewartet, bis zum Launch der neuen Firmware (mit neuem Text), um keine Irritation ins Spiel zu bringen…

Bitte auch die Anleitung unter Anleitung | Freifunk-Ruhrgebiet aktualisieren. Unter Punkt 9 steht noch, dass der Knoten registriert werden muss.

1 Like

Anleitung ändere ich, danke für den Hinweis!!!

Die offizielle Ankündigung habe ich nachgeschoben, findet sich dort:

Die Anleitung ist entsprechend geändert…

1 Like

Hallo Freifunker,

seit dem Update auf 0.6 werden meine Nodes nicht mehr korrekt in der Karte dargestellt. Der Node FF-Essen-Doro-01 erscheint zwar, aber ohne Link zu FF-Essen-Doro-02. Dieser erscheint in der Liste nur mit seiner MAC Adresse 12:01:ee:9c:16:e0. In der Konfiguration der Nodes kann ich keinen Grund für den Darstellungsfehler entdecken.

Hat jemand eine Idee woran es liegt?

Gruß … Erik

Ist da Mesh on Wan an?

Hab das Gefühl, dass Ruhrgebiet-Karte gerade Probleme hat: Karten und Router Probleme

Wenn ich die Config richtig interpetiere - ja.

root@FF-Essen-Doro-02:~# uci show network.mesh_wan
network.mesh_wan=interface
network.mesh_wan.auto=0
network.mesh_wan.ifname=br-wan
network.mesh_wan.mesh=bat0
network.mesh_wan.proto=batadv

Das muß auf 1 gesetzt werden für mesh-on-WAN!

Nein, Mesh on WAN ist aus. Ein löschen der Node Konfiguration und Neuinstallation nebst Änderung des MAC Adressen hat nichts gebracht. Die nodeinfo sieht ok aus:

root@FF-Essen-Doro-01:/usr/bin# gluon-neighbour-info -p 1001 -d ff02:0:0:0:0:0:2:1001 -i wlan0 -r nodeinfo
{„node_id“:„e894f6d44c4c“,„network“:{„mac“:„e8:94:f6:d4:4c:4c“,„addresses“:[„2a02:f98:0:26:ea94:f6ff:fed4:4c4c“,„fe80:0:0:0:ea94:f6ff:fed4:4c4c“,„2a03:2260:50:1:ea94:f6ff:fed4:4c4c“],„mesh_interfaces“:[„ea:98:f6:d4:4c:4c“,„ea:97:f7:d4:4c:4c“,„ea:97:f8:d4:4c:4c“]},„hostname“:„FF-Essen-Doro-01“,„location“:{„longitude“:7.007,„latitude“:51.43668},„software“:{„fastd“:{„enabled“:true,„version“:„v16“},„autoupdater“:{„enabled“:true,„branch“:„stable“},„batman-adv“:{„compat“:14,„version“:„2013.4.0“},„firmware“:{„base“:„gluon-v2014.4“,„release“:„0.6“}},„hardware“:{„model“:„TP-Link TL-WDR4300 v1“}}
{„node_id“:„10feed9c16e0“,„network“:{„mac“:„10:fe:ed:9c:16:e0“,„addresses“:[„fe80:0:0:0:12fe:edff:fe9c:16e0“,„2a03:2260:50:1:12fe:edff:fe9c:16e0“,„2a02:f98:0:26:12fe:edff:fe9c:16e0“],„mesh_interfaces“:[„12:01:ee:9c:16:e0“]},„hostname“:„FF-Essen-Doro-02“,„location“:{„longitude“:7.00695,„latitude“:51.43645},„software“:{„fastd“:{„enabled“:false,„version“:„v16“},„autoupdater“:{„enabled“:true,„branch“:„stable“},„batman-adv“:{„compat“:14,„version“:„2013.4.0“},„firmware“:{„base“:„gluon-v2014.4“,„release“:„0.6“}},„hardware“:{„model“:„TP-Link TL-WR841N/ND v8“}}
root@FF-Essen-Doro-01:/usr/bin#

Wenn man aber in die nodes.json schaut, so fehlt der Inhalt des Attribut macs:

{
„uptime“: 18163.92,
„macs“: „“,
„name“: „FF-Essen-Doro-02“,
„clientcount“: 0,
„flags“:
{
„client“: true,
„gateway“: false,
„online“: true
},
„model“: „TP-Link TL-WR841N/ND v8“,
„firmware“: „0.6“,
„geo“:
[
51.43645,
7.00695
],
„id“: „12:01:ee:9c:16:e0_0“
}

Ist das Script welches die nodes.json erstellt, verfügbar? Dann würde ich das Problem weiter eingrenzen.

Das wäre dann das da:

https://github.com/ffruhr/ffmap-backend