Gluon v2014.4 - Firmware 0.6 stable

@paulinsche
https://github.com/ffruhr/site-ffruhr/tree/0.6

Immer noch: regdom = ‚US‘
Gibt es einen einzigen vernünftigen Grund, das nicht mal auf DE umzustellen?
Außer natürlich: „Das haben wir schon immer so gemacht! 1elf“

Das steht: „Das ist der Schlüssel deines Freifunkknotens zur Information. Der Knoten ist nun direkt nutzbar.“ - D.h.: keine Registrierung mehr nötig?

Jupp, daher steht es dort auch so.
Ich finde gerade den Beitrag mit der Ankündigung nicht…

1 Like

Das steht nur in den anderen Beiträgen, wir haben mit der offiziellen Ankündigung gewartet, bis zum Launch der neuen Firmware (mit neuem Text), um keine Irritation ins Spiel zu bringen…

Bitte auch die Anleitung unter Anleitung | Freifunk-Ruhrgebiet aktualisieren. Unter Punkt 9 steht noch, dass der Knoten registriert werden muss.

1 Like

Anleitung ändere ich, danke für den Hinweis!!!

Die offizielle Ankündigung habe ich nachgeschoben, findet sich dort:

Die Anleitung ist entsprechend geändert…

1 Like

Hallo Freifunker,

seit dem Update auf 0.6 werden meine Nodes nicht mehr korrekt in der Karte dargestellt. Der Node FF-Essen-Doro-01 erscheint zwar, aber ohne Link zu FF-Essen-Doro-02. Dieser erscheint in der Liste nur mit seiner MAC Adresse 12:01:ee:9c:16:e0. In der Konfiguration der Nodes kann ich keinen Grund für den Darstellungsfehler entdecken.

Hat jemand eine Idee woran es liegt?

Gruß … Erik

Ist da Mesh on Wan an?

Hab das Gefühl, dass Ruhrgebiet-Karte gerade Probleme hat: Karten und Router Probleme

Wenn ich die Config richtig interpetiere - ja.

root@FF-Essen-Doro-02:~# uci show network.mesh_wan
network.mesh_wan=interface
network.mesh_wan.auto=0
network.mesh_wan.ifname=br-wan
network.mesh_wan.mesh=bat0
network.mesh_wan.proto=batadv

Das muß auf 1 gesetzt werden für mesh-on-WAN!

Nein, Mesh on WAN ist aus. Ein löschen der Node Konfiguration und Neuinstallation nebst Änderung des MAC Adressen hat nichts gebracht. Die nodeinfo sieht ok aus:

root@FF-Essen-Doro-01:/usr/bin# gluon-neighbour-info -p 1001 -d ff02:0:0:0:0:0:2:1001 -i wlan0 -r nodeinfo
{„node_id“:„e894f6d44c4c“,„network“:{„mac“:„e8:94:f6:d4:4c:4c“,„addresses“:[„2a02:f98:0:26:ea94:f6ff:fed4:4c4c“,„fe80:0:0:0:ea94:f6ff:fed4:4c4c“,„2a03:2260:50:1:ea94:f6ff:fed4:4c4c“],„mesh_interfaces“:[„ea:98:f6:d4:4c:4c“,„ea:97:f7:d4:4c:4c“,„ea:97:f8:d4:4c:4c“]},„hostname“:„FF-Essen-Doro-01“,„location“:{„longitude“:7.007,„latitude“:51.43668},„software“:{„fastd“:{„enabled“:true,„version“:„v16“},„autoupdater“:{„enabled“:true,„branch“:„stable“},„batman-adv“:{„compat“:14,„version“:„2013.4.0“},„firmware“:{„base“:„gluon-v2014.4“,„release“:„0.6“}},„hardware“:{„model“:„TP-Link TL-WDR4300 v1“}}
{„node_id“:„10feed9c16e0“,„network“:{„mac“:„10:fe:ed:9c:16:e0“,„addresses“:[„fe80:0:0:0:12fe:edff:fe9c:16e0“,„2a03:2260:50:1:12fe:edff:fe9c:16e0“,„2a02:f98:0:26:12fe:edff:fe9c:16e0“],„mesh_interfaces“:[„12:01:ee:9c:16:e0“]},„hostname“:„FF-Essen-Doro-02“,„location“:{„longitude“:7.00695,„latitude“:51.43645},„software“:{„fastd“:{„enabled“:false,„version“:„v16“},„autoupdater“:{„enabled“:true,„branch“:„stable“},„batman-adv“:{„compat“:14,„version“:„2013.4.0“},„firmware“:{„base“:„gluon-v2014.4“,„release“:„0.6“}},„hardware“:{„model“:„TP-Link TL-WR841N/ND v8“}}
root@FF-Essen-Doro-01:/usr/bin#

Wenn man aber in die nodes.json schaut, so fehlt der Inhalt des Attribut macs:

{
„uptime“: 18163.92,
„macs“: „“,
„name“: „FF-Essen-Doro-02“,
„clientcount“: 0,
„flags“:
{
„client“: true,
„gateway“: false,
„online“: true
},
„model“: „TP-Link TL-WR841N/ND v8“,
„firmware“: „0.6“,
„geo“:
[
51.43645,
7.00695
],
„id“: „12:01:ee:9c:16:e0_0“
}

Ist das Script welches die nodes.json erstellt, verfügbar? Dann würde ich das Problem weiter eingrenzen.

Das wäre dann das da:

https://github.com/ffruhr/ffmap-backend