Planung von Freifunk an meiner Wetterstation bei Siegen


#21

wird seit Gluon 2016.1 unterstützt - selbst wenn die FW deiner Comunity hinter her “hinkt” sollte das klappen. Allerdings sind die Ubiquitis nicht ganz so einfach (wie z.B. TP-Link 841er) zu flashen… (keine Factoy Images, must alles per Console machen)


#22

Ich glaube wir drehen uns im Kreise, siehe Planung von Freifunk an meiner Wetterstation bei Siegen
Ob die Firmware in Siegen hinterherhinkt: Wie in so vielen Communities hat auch dort noch niemand 2017.x gebaut. Aber schlicht, weil dazu bislang weder Notwendigkeit bestand noch Vertrauen in die Stablität besteht.
(konkret: Uns macht derzeit noch Angst, dass im Wochentakt Meldungen kommen, dass irgendwelche Gerätemodelle “nach Firmwareupdate händischen powercycle brauchen”)


#23

So gravierend ist das Problem bisher eigentlich nicht bei den Updates. Ich würde die vorerst ausmachen. Ich habe aber auch ein Modell an einer Fahnenstange hängen, das hat die letzten Updates problemlos mitgemacht.


#25

Updates ausmachen?

Auf keinen Fall. Während der Migration von Bat 14 auf 15 hat sich gezeigt, dass dies eine der, sorry wegen dem Ausdruck, dümmsten Entscheidung überhaupt ist.

Wenn man das macht braucht man auch uneingeschränkten einfachen Zugang zu dem Knoten.


#26

Nunja, wenn das Flashen und die Inbetriebnahme schwieriger ist als gewöhnlich, muss mir jemand dabei helfen! Entweder mit genauer Anleitung oder aber am besten via Teamviewer-Session direkt am “lebenden” Objekt :smiley: Habe was das angeht kaum Hintergrundwissen und Programmieren, bzw. Editieren im Quelltext kann ich gar nicht.

Aber irgendwie kriegt man das Teil denke ans Laufen :smiley:


#27

Nichts davon ist erforderlich.

Anders als per Weboberfläche, musst du die Firmware per SSH aufspielen: https://wiki.openwrt.org/toh/ubiquiti/unifi_outdoorplus#installation


#28

Ui, sieht trotz Anleitung immernoch kompliziert aus für mich. Aber ich warte erstmal ab bis das Teil hier ist :smiley:


#29

Ihr konstruiert hier lauter Probleme, die es nicht gibt.

a) "aber erstmal die lokale Community fragen"
Ich bin zwar nicht in Siegen, aber täglich mit demjenigen in Gespräch, der da die Firmware und Supernodes betreut
b) "was wenn das Gerät nicht unterstützt wird"
Ich habe bereits auch schon Firmware für die Siegener gebaut, wenn es auch nciht die primär Firmware dort ist.
c) "Was aber wenn die Community kein aktuelles Gluon verwendet"
Der Threadstarter hat doch bereits gemeldet, dass er ein Gerät bestellt hat, was nicht “Archer C25” heisst. Und andere Geräte kenne ich nicht, die in Gluon2017-Master unterstützt und in 2016.2.7 fehlen.

Man muss halt beim Starten des Gerätes den Reset gedrückt halten für 10 bis die Lampe blinkt.
Also der Vorgang, der in


beschrieben ist.


#31

Theoretisch könnte der Freifunk bei mir am Dienstag oder Mittwoch nächster Woche in Betrieb gehen, je nach Hürden und Schwere des Flashens etc. Warum auch immer es solange dauert aber der Router kommt erst am Samstag (wo ich nicht daheim bin, meine Eltern aber)

Am Montag könnte ich mich dann damit befassen den zu flashen etc.

Brauche unter Umständen aber Hilfe, bis hin zu Team-Viewer-Sessions wenn ich dran verzweifeln sollte :confused: Ist das realisierbar irgendwie?


#32

Vermutlich sind nach wie vor noch viele in Urlaub.

Da Du aber nun das gleiche Probleme hast, wie x leute in y Parallelthreads, schau doch
Ubiquiti Bullet M2 Firmware "not trusted" mal an.
(Ja, das ist ein anderes UBNT-Modell, aber bis auf die Gehäuse ist das bei dem Hersteller fast immer das gleiche. Du musst den Reset-Knopf halt an anderer Stelle suchen.)


#33

Der Router ist heute gekommen, vorzeitig. Versuche den mal zu flashen. Werde aber denke erst am Montag richtig dazukommen. Probiere es gerade aber komme kaum voran weil ichs nicht verstehe :confused:

Update: Nach jetzt gut 1,5 Stunden schlägt meine Stimmung nun in Aggression um! Nichts geht, und keinen Schimmer wie ich via Konsole da den Flash reinkriege weil ich einfach kein Plan von sowas habe und mich die Lösungsansätze hier als Laie in dem Bereich nicht weiterbringen. Kriege nichtmal Internet aus dem Router!

Ein manuelles Einspielen des Flashs in der Software selbst ist nicht möglich - der sucht nur dann intern beim Hersteller nachm Update.

Fehlermeldungen aller Art auf der UniFie Controller-Webseite (localhost): “Ein UniFi Security-Gateway (USG) ist erforderlich.” Alle Anzeigen gehen nicht (grau, teils mit Fragezeichen), nur WLAN ist grün und dies und das ist erforderlich um XYZ zu sehen etc…

Das Gerät selbst wird aber gefunden aber ich hab jetzt alles versucht und Google spuckt Müll.

War mit Putty drin aber ohne Kenntnisse über die nötigen Befehle bringt mir das alles nix. Der offenbar passende Flash für dieses Gerät ist schon runtergeladen und muss bloß vom Desktop in den Router…

Bin grad echt schwer genervt…

Ich pausiere jetzt erstmal bis Sonntag Abend/Montag (bin bei nem Kumpel) und hoffe ja noch dass in der Zeit die Lösung auftaucht. Am liebsten wäre mir eh ne Team-Viewer-Session.

Hab nen Upgrade aus dem Controller-Programm aufgespielt und jetzt funktioniert WLAN, nicht besonders schnell (15-30 mbit) aber es geht. Das Kernproblem besteht aber halt immernoch das ich es nicht hinkriege.


#34

Warum nimmst Du nicht die verlinkte Anleitung? (Also der Thread dorthin)
Du kannst es natürlich auch anders versuchen als sämtliche Vorredner beschrieben haben.
Zielführend wird das aber nicht sein.

Nochmal zum Mitschreiben: Hochladen per TFTP-recovery.


#35

Hab alle Links geprüft aber es nicht hinbekommen wegen fehlender Kenntnisse. Ich versuche es am Sonntag wenn ich zu Hause bin mit dem Tftp Kram. Das Video da ist für mich als Windows Nutzer wohl nutzlos… Brauche das für Windows…


#37

habe auch ein unifi ap outdoor+ geflasht
vorrausetzung man nimmt die richtige firmware und man hat 3 hände, 2 gehen auch

Zur Installation der Freifunk - Firmware wird das Tool PumpKIN benötigt: TFTP PumpKIN.

Den heimischen PC auf die IP Adresse 192.168.1.254 / Netzmaske 255.255.255.0 setzen
Den LAN Port des POE Netzteiles mit dem PC verbinden
PumpKIN starten, und die vorher von der Freifunk - Webseite geladene Firmware - Datei auswählen.
In PumpKin die IP 192.168.1.20 eingeben
Den Router umdrehen, und den Reset Taster mit einer Büroklammer oder ähnliches gedrückt halten
Erst jetzt den Router mit Strom versorgen
Abwarten, bis der Router abwechselnd Amber / Grün / Aus blinkt (nach ca. 15 Sek). Nach 8 Sek leuchtet er Grün: Weiter den Reset - Taster gedrückt halten
Wenn der Router Amber / Grün / Aus blinkt den Reset - Taster loslassen
In PumpKin "PUT" anklicken
Den Router jetzt nicht vom Netz trennen, oder den PC ausschalten
Es dauert eine Weile (ca. 3...5min) bis der Flashvorgang und Neustart beendet sind
Am Ende des Prozesses leuchtet der AP grün,blau,weiss...
Jetzt ist der AP über 192.168.1.1 erreichbar, und kann (muss) wie jeder andere Freifunk - Router konfiguriert werden

habe nicht länger als 2 min dafür benötigt das programm ist eigentlich selbst erklärend


#38

Soweit war ich auch schon beim Versuch den Inhalt des Links da umzusetzen… Bin aber bis morgen Abend nichtczu Hause. Den Tipp von Route66 find ich sehr gut beschrieben, werde dies morgen abend probieren :hugs:


#39

viel glück dabei…


#40

Auf jedenfall schonmal danke für den tipp, sollte dann schaffen :slight_smile:


#41

Es läuft! Der Router vehrält sich aber anders wie beschrieben: Er leuchtet erst weiß, dann gar nicht und dann weiß-blau-aus. Im 3. versuch hat er die FW geschluckt und ist jetzt netzfähig, habe ihn bereits getestet.

Er steht in meiner Wohnung am Boden gerade noch (Testaufbau) aber trotz fehlendem Sichtkontakt und dicker Wände konnte ich bis ca 40 m bereits ein Signal empfangen.

Allerdings lässt die Geschwindigkeit zu wünschen übrig. Es kommen nur 6-9 mbit heraus. Das reicht zum surfen, ist aber doch eher lahm. Habe die Bandbreite auf 100 mbit down und 5 mbit up begrenzt.

Im freien Feld habe ich ne Reichweite von bis zu 120 m feststellen können - bei Sichtkontakt.


#42

Hi,

ich konnte nicht rausfinden, welches VPN-Protokoll in Siegen genutzt wird (Fastd oder L2TP). Eventuell wissen andere mehr.

Wenn die Fastd nutzen, ist das normal, dann müsstest du einen sogenannten „Offloader“ bauen. Also irgendeinen kleinen Thinclient, der die Verschlüsselung übernimmt, weil die kleinen Prozessoren in den Routern nicht mehr schaffen.

Wenn sie L2TP verwenden, gibt es eventuell ein Problem mit dem DSL-Router, manche schlucken L2TP-Pakete, oder die Gateways sind überlastet.

Grüße
Matthias


#43

Also mein Hauptrouter ist eine Fritzbox 6490 (Unitymedia) und ich möchte jetzt nicht nochmehr Geld für externe hardware ausgeben. Habe bereits gut 160 Euro investiert. Mit 6-10 mbit ist die Übertragunsgeschwindigkeit dazu sehr langsam, auch wenn sie zum Surfen reicht. Nun noch ein teures Gerät (das ja ebenfalls auch wieder konfiguriert werden muss…) kommt daher nicht in Frage.

Gleichzeitig sind dazu noch neue Probleme entstanden: Meine Webcams sind nicht mehr im Netz zu sehen! Habe nichts verändert, ausser eben den Freifunk-Router an den Switch angeschlossen. Jemand ne Idee woran das liegen könnte?

Werden durch den Tunnel Router-Einstellungen verändert oder bringt das PoE Störungen in den Switch von dem der FF-Router sein Netz bekommt?