TP-Link TL-WR1043N v5


#41

Es gibt einen LEDE-Patch und Gluon basiert auf LEDE. Und LEDE-technisch wird auch LEDE fortgeführt, es heißt dann nur wieder OpenWRT.

Das einzige, was halt etwas kniffelig sein könnte, wäre es den Patch von LEDE-Master auf Lede-Release zu portieren. Das hat aber @rotanid scheinbar getan, weil es einen PR gibt.


#42

Was @MPW schreibt stimmt, was @adorfer schreibt auch - was @Felix schreibt ist falsch.

nur in einem stimmt @MPW 's Aussage nicht: ich habe den Backport-Patch nicht gemacht, sondern blocktrron von ffda


#43

Im gluon master branch ist der Patch jetzt drin


#44

und sobald jemand nachweislich erfolgreich auf dem v2017.1.x branch getestet hat, kommt er auch dorthin.
sollte funktionieren, aber ohne test trotzdem erstmal nicht.


#45

Kennt jemand von euch das Passwort von dem Snapshot für den 1043N v5?
https://downloads.lede-project.org/snapshots/targets/ar71xx/generic/openwrt-ar71xx-generic-tl-wr1043n-v5-squashfs-factory.bin


#46

In dem Snapshot ist wohl für den Root ein Passwort, leider finde ich dazu nichts genaues? :frowning:


#47

Das sollte keines gesetzt sein. Einfach im Konfigurationsmodus per ssh auf 192.168.1.1 gehen.

Grüße
Matthias


#48

Danke Mathias, ich seh das der Router auf die IP 10.83.0.1 nur Anfragen per SSH zulässt.

Es läuft über Netzwerkkabel auch kein DHCP, über WLAN SSID “trainstation.freifunk” bekomme ich eine IP zugeweisen aus dem Bereich: 10.83.0.x

Hallo Christian

danke, ich hatten soeben die IP 10.83.0.1 gepingt und hatte etwas unter 6 ms, und das über WLAN dachte erst es sei der Router selbst. Nachdem ich das WAN Kabel enfernt habe, war auch kein Ping mehr auf die 10.83.0.1 möglich. Einzugriff auf die LAN Ports 192.168.1.1 ist auch nicht möglich.

Dachte wirklich diese bassiert auch auf OpenWRT :smiley: ops…


#49

Hallo

das hört sich nach Freifunk Franken an :wink:

Der Router hat keine IPv4 Adresse, diese bekommst du von einem Gateway. Dieses hat die 10.83.0.1.

Probier es mal per IPv6:

http://localnode.fff.community
oder
http://[fdff::1]

Adressen sollten auch per SSH gehen, default PW ist root:ffol sowohl ssh als auch Webui (bitte umgehend ändern)

P.S. Der Webserver auf dem Gateway der in der Trainstation eine Sperrseite ausliefert war leider auch kaputt, ich hab das eben mal repariert. Wenn du nun “einfach” example.com (oder irgendeine andere Seite bis auf ein paar wenige Ausnamen) aufrufst, sollte eine Sperrseite mit einem Link zur Routerkonfiguration kommen. Der keyxchangev2 den du aktuell nutzt, ist noch stark in der Entwicklung daher gibt es hier oder da noch hakler, also nicht wundern. Danke auf jeden Fall für die Info hab gerade wieder paar Probleme beheben können :wink:

Und achja, das ganze hat nix mit Gluon zu tun, du hast kein Gluon also werf alle Gluonanleitungen über den haufen :wink:

mfg

Christian


#50

wie bereits gesagt, wir nutzen kein Gluon und bei uns gibt es kein 192.168.1.1 oder irgendeinen Konfigurationsmodus, vergess alles was Gluon so sagt, das ist für uns nicht gültig. Der Router wird im laufenden Betrieb konfiguriert. Die richtigen Adressen sind:

http://localnode.fff.community
oder
http://[fdff::1]

per http die Webkonfigurationsseite oder per SSH. User jeweils root, Passwort jeweils ffol.

mfg

Christian


#51

Was macht ihr (Du und andere) dann hier? Das hier ist das Gluon-Unterforum, nicht das “generell für Hardware”.
Wenn es um die Bedienung von Gluon ging, dann wäre das hier richtig.
Aber generell die Unterschiede zwischen Gluon und anderen Firmwares herauszuarbeiten erscheint mir zumindest dieser Thread hier nicht geeignete.


#52

Und der Nutzer, der Hilfe sucht, muss auf solche Unterschiede nicht hingewiesen werden, weil …?
Wüsste er, warum er im falschen Unterforum fragt, müsste er ja nicht mehr fragen…


#53

ich les nur mit und mir ist aufgefallen das “der andere” eben meint das er Gluon nutzt was aber falsch ist, also hab ich das klar gestellt. Ich hab nur geholfen aber wenn das auch nicht mehr gewünscht wird nun gut, dann helf ich halt nicht mehr ¯_(ツ)_/¯

@der andere (immer schön abwertend schreiben ja…?) kontaktiere doch Freifunk Franken auf unseren Kontaktwegen https://wiki.freifunk-franken.de/w/Kommunikation dann muss man sich nicht mit einen unfreundlichen Forum herumschlagen :wink:


#54

Ich habe hier jetzt 10 Router tp-loink tl-wr1043n-v5 mit meinen Images aus dem Master Branch vom 05.01.2018 geflasht. Bisher läuft alles einwandfrei.


#56

Kleine Ergänzung. Christian vom Freifunk Harz e.V hat mich drauf aufmerksam gemacht, dass Mesh on LAN auf dem Master mit eine 1043v5 nicht funktioniert.

Es gibt jetzt im Vergleich zu anderen Routern ein zusätzliches Interface vx_mesh_lan.

root@x:~# ifconfig

vx_mesh_lan Link encap:Ethernet HWaddr 2A:E2:30:B8:AB:5C
inet6 addr: fe80::28e2:30ff:feb8:ab5c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1430 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:13634 errors:1 dropped:0 overruns:0 carrier:1
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:3227780 (3.0 MiB)

root@x:~# batctl if
primary0: active
ibss0: active
mesh0: active
vx_mesh_lan: active
mesh-vpn: active

Mit folgendem Befehl funktioniert Mesh on LAN zwischen dem 1043v5 mit Routern und Gluon 2017.1.4.

root@x:~# batctl if add br-mesh_lan

Offensichtlich ist die Änderung im Master nicht kompatibel / noch nicht vollständig mit alten Konfigurationen.


#57

NEIN. Mailing Liste lesen ist für Firmware-Bauer pflicht, und dort wurde die “Lösung” legacy am 27.06.2017 genannt. Sobald es ein major release gibt, steht das auch in den release notes. In der Doku steht es nicht, weil nicht-Upgrades, neue Communities, das nicht brauchen.


#58

könntest du bitte den Backport Pull Request testen stattdessen?
Wenn der als erfolgreich getestet wird, freuen sich viele weil man dann nicht den Master Branch braucht für das Gerät in v5:
https://github.com/freifunk-gluon/gluon/pull/1295


#59

Es soll Leute geben, die haben auch ein Leben außerhalb des Freifunks. Und
nicht habe nicht vor mehrere Monat rückwärts zu lesen.

LG Thomas


#60

Soweit ich es jetzt verstanden habe, schaltet

network.mesh_wan.legacy='1’
network.mesh_lan.legacy=‘1’

in das bisherige Protokoll um. Leider bleibt diese Einstellung nicht über ein Autoupdate erhalten. Für eine Migration ist der Default ‘0’ nicht geeignet, denn alle Router müssen aufdatiert und umgestellt werden oder ein neuer Router muss per Hand auf das alte Protokoll umgestellt werden. Wenn der Router nur über eine Kabelverbindung erreichbar ist, muss man wohl die Turnschuhe bemühen.


#61

der TP-Link TL-WR1043N v5 ist seit einigen Stunden im stable-Branch (v2017.1.x) von Gluon enthalten.