UAP-AC-LITE flashen


#1

Ich habe erfolglos versucht, eine UAP-AC-LITE mit Gluon zu flashen.

Der erste Versuch war, das direkt über den Controller zu machen; der AP ist danach mit der alten, sprich originalen Firmware neu gestartet.
Der zweite Versuch mit tftp und der dritte nach dieser Anleitung haben auch nicht funktioniert. Mir ist aufgefallen, dass die Orginal-Firmware fast 8MB,das Gluon-Image aber nur etwa 4MB groß ist.

Hat jemand Erfahrung damit? Wie kriege ich Gluon auf den UniFi-AP?

Bruno


Ubiquiti Nanostation Loco M2 XW auf gluon flashen (UBNT ETSI/FCC lockdown)
#2

Evtl. bringt dich die OpenWRT-Anleitung weiter…?

https://wiki.openwrt.org/toh/ubiquiti/unifiac


#3

Welche Firmwaredatei genau hast du denn versucht zu flashen? Das klingt so, als hättest du die falsche Firmware für das Gerät gewählt.


#4

Ich habe eine Weile gebraucht, um das Problem zu lösen: Offenbar lässt die aktuelle ubnt-Firmware ab Version 3.4.14 (seit Anfang 2016) nur noch signierte Images zu, so dass es unmöglich ist, die Freifunk-Firmware zu flashen; der AP startet stets mit seiner Originalfirmware. Sowohl auf der Downloadseite, als auch im Forum von Ubiquiti wurden alle Spuren zur alten Firmware gelöscht, so dass man eine Weile googeln muss, um fündig zu werden.

Ich habe erfolgreich einen AP geflasht und hier alle Informationen zusammengefasst: http://ffhgw.de/howto-unifi-ac-lite-ap-flashen/

Bruno


#5

Also also FW einspielen per dowlgrad vor dem einspielen des Gluon-Images?

Übersehe ich etwas, oder war’s das schon?


#6

Ja, das war es schon. Der Haken ist nur, dass das nicht per tftp geht und ubnt alle alten Images gelöscht hat, die für das Downgrade in Frage kämen. Hoffentlich wird das nicht die neue Strategie.

Das Howto ist bewusst “allgemeinverständlich” formuliert.

Bruno


#7

Was ich aus dem von Dir verlinkten Artikel entnommen habe, ist: Ich habe immer das falsche Image probiert.
Mir war nicht klar, dass man auch “wenn von Stock kommt” ein Sysupgrade-Gluon nehmen muss und eben kein “passendes” factory-Image. (Die Info war ja bei Dir etwas zwischen den Zeilen versteckt.)

Erstaunlich finde ich, das es eben nicht per tftp gehen soll, selbst nachdem man downgedated hat.
Da fehlt mir die Erklärung für.


#8

Hm, gibt’s denn überhaupt factory-Images dafür? Ich habe das selbst kompiliert und nur ein sysupgrade rausbekommen.


#9

Ja eben nicht. Daher haben -nach dem was ich gehört habe- Leute (natürlich erfolglos) diverse andere UBNT-Unifi-Images durchprobiert.

(BTW: so richtig “gelöst” wie im Betreff suggeriert finde ich die Frage noch nicht. Nicht nur in den Details, sondern weil hier keine Lösung zu lesen ist. “extern verlinkte Lösungen” haben das Risiko, dass die Links nach ein paar Monaten/Jahren kaputt gehen und sich dann Leute beschweren, dass es nicht mehr auffindbar wäre. Zumindest hatten wir das jetzt bei Threads aus 2015.)


#10

Abend,
also ich bin derzeit dran meinen Unifi AP AC light mit der Freifunksoftware zu flashen. Allerdings krieg ich das nicht. Hab was von Downgrad gelesen aber da find ich keine passende funktionierende Software.
Habt ihr eine funktionierende Anleitung für mich oder ein paar Tips?
Wäre echt super Danke!


#11

So ohne jegliche Fehlermeldung: Lese doch einfach mal nach, was hier weiter oben im Thread geschrieben wurde.


#12

Mein Tipp wäre: Keinen neuen Thread aufmachen, sondern schlicht mal mit Details zum Fehler um die Ecke kommen. “Mein Computer geht nicht, was könnte es sein” ist nicht so besonders einladend als Fehlermeldung, um “auf’s Blaue” mal eine ewig lange Liste zu schreiben, was alles sein könnte.


#13

Vielen Dank für die schnelle sehr hilfreiche Unterstützung.
Also das Downgrad funktioniert nicht und ohne krieg ich das Freifunk Image nicht drauf.
Heißt er nimmt das Image welches ich finde nicht an.
Deshalb meine Frage gibt es eine Möglichkkeit ohne Downgrade? Wenn ja welche und wie?
Oder habt ihr ein anderes Image zum Downgraden? …
Hier die Die SSchritte nach dennen ich Vorgegangen bin:


Die Fehler tritt bei Putty auf das er das Image nicht aufspielen kann/erkennt.


#15

Themen zusammengeführt (dabei ist der zu seinem vorherigen identische Beitrag von @Red_Med nicht mitgekommen, weil ich diesen zuerst nicht mit verschoben hatte und sich im Nachhinein die Reihenfolge der Beiträge nicht ändern lässt).


#16

Wie lautet die Fehlermeldung wörtlich?

Wie lautet die Fehlermeldung wörtlich?


#17

Ich habe gerade eben einen UAP AC Lite nach der OpenWRT-Anleitung erfolgreich mit Gluon geflasht.

Stock-FW war 3.7.58, daher mtd noch vorhanden.
Alles was man dann machen muss:

Anschliessend startete er automatisch neu und gab mir die FF-Konfigseite unter 192.168.1.1 aus.

Falls die Stock-FW schon zu neu ist, kann man eine ältere auf der Ubnt-Seite downloaden (zurzeit jedenfalls ist das möglich - scheint wohl schon mal anders gewesen zu sein) und downgraden:

Das zumindest hatte für mich bei einem UAP AC Pro funktioniert, sollte beim Lite auch so sein.


#18

Jo, das heißt:

  • Du hast WinSCP & PuTTY auf deinem Rechner installiert.

  • Mit WinSCP das Image mit dem Namen fwupdate.bin nach /tmp auf den AP kopiert. (Windows zeigt Dateierweiterungen (.bin) nicht immer an, obwohl die existieren. Doppelte Endung (.bin.bin) wäre dann ein Problem beim Namen).

  • Mit PuTTY eine ssh-Verbindung zum AP aufgebaut & folgendes ausgeführt:

    syswrapper.sh upgrade2 &
    

Wenn jetzt eine Fehlermeldung kommt, kopieren & hier posten. Wenn der AP einfach neu startet & die ssh-Verbindung abbricht, hat es mit dem Downgrade vermutlich geklappt.


#19

Guten Morgen,

Vielen Dank für die Hilfe.
Kam leider erst jetzt dazu und weiß jetzt auch woran es lag es ich hatte mich idiotischer Weise beim “syswrapper.sh upgrade2” vertippt. :confounded:

Jetzt hat er es direkt gefressen.

Allerdings startet er nicht (kein Licht, etc) mehr nach dem ich die Freifunk gluon draufgespielt hab.
gluon-ffan-2017.1.5+20180305-ubiquiti-unifi-ap.bin

Auch hilft fer Reset Button nicht.
Und eine Ansteuerung über 192.168.1.1 sowie 192.168.1.20 bleibt erfolglos. Des Weiteren bleibt im Netzwerkstatus der Empfang von Pakete auf 0.

Hättet ihr evtl. noch einen Tipp zur Hand oder wars das für den AP?

Vielen Dank schon Mal.


#20

Du hast beide Partitionen geschrieben? (und nicht schon beim ersten mtd-Aufruf mit “-r”?)


#21

Ja hab beide Partitionen beschrieben und erst:
mtd write /tmp/gluon.bin kernel0
dann
mtd -r write /tmp/gluon.bin kernel1
und beides hat er sauber durchgeführt.
Dann wollte er selbständig rebooten und ist nicht wieder erwacht.