Ubiquity AirOs5.6 / U-Boot-Änderung: Brick-Gefahr: Rocket M2/Nanostation /LocoM (erst downgraden auf AirOS5.5) für Gluon 2015.x

Sage mal Bescheid, wenn’s geklappt hat.
Ansonsten können wir auch gerne mal via Hangout&Co gemeinsam zu basteln versuchen.
Ich bin nämlich ehrlich gesagt ein wenig neugierig.

:smile:
Ich muss das mal so bauen, dass man von aussen drauf schauen kann … also auf die serielle Console.
Heisst, ich pack nen Teamviewer auf die Kiste, dann kannste dir das mal anschauen, wenn du Lust hast.
Da packt mich so langsam der Ehrgeiz. Ich lass mich doch nicht von soner blöden Kiste ärgern :slight_smile:

3 Likes

Hey, hast du hier eigentlich was erreichen können?

Ich habe jetzt mal die mindestens 4(?) parallelen Threads zusammengelegt,
Alles zum Thema „Ubiquity XY beim Versuch von AirOS5.6 auf Gluon/OpenWRT zu flashen“
(Das ist eder ein Hardware-Probleme, noch eines von einer Communty-Firmware, sondern schlicht ein OpenWRT-Issue. Da es dafür aber kein Forum gibt, ebne „Gluon“, die meisten geht’s schließelich darum und nicht um PlainOpenWRT.)

Ich hab heute eine NanoStation M5 mit AirOS v5.6.2 (XW) mit dem aktuellen Gluon Master Stand (v2016.1-32-g79bc3a8) (wird vmlt. release 2016.1.1) direkt geflashed ohne Firmware downgrade auf AirOS 5.5.x




2 Likes

Das Downgrad auf AirOs5.5 vor dem Aufspielen von Gluon ist (derzeit) unbedingt notwendig völlig unabhängig vom Montageort der Station oder auch vom späteren Verwendungszweck.

Ohne diesen Schritt funktioniert es schlicht gar nicht und man sitzt dann mit einem Backstein da.
Sofern die Piloten die Picostation also nicht als Gewicht zur Trimmung nutzen wollen: Auf jeden Fall erst downgraden.

1 Like

Das ist mir bewusst. Mir geht es da eher um das WIE nicht OB. Da man allerdings kaum etwas dazu findet bin ich etwas verunsichert.

Wenn ein Downgrade ohne weiteres klappt, sprich „altes Firmware-Image im Webinterface hochladen und auf Update klicken“ dann ist es kein Problem.

Beim CPE210 gibt es ja unterschiedliche Erfahrungen. Für CPE210 - CPE210 bzw CPE210 - 841N habe ich gute Erfahrungen gemacht. Allerdings würde ich die CPEs in diesem Falle überwiegend für das Client-Netz einsetzten und da gehen ja die Reichweitenerfahrungen auseinander. Aber dafür gibt es ja schon genügend Threads.

Das Gluon kümmert sich um die genutzte Radio-Leistung.
Ich denke mal nicht, dass im Rahmen des „upgrades“ von AirOS5.5 auf AirOS5.6 an der ART-Partition so viel geändert wurde, dass es Auswirkungen auf die Radio-Performance der Geräte hat, wenn soweiso Gluon läuft und eben nicht AirOS.

hi,

schau dir mal folgenden Beitrag an wo das bereits angesprochen wurde:

Grüße

1 Like

Danke genau sowas habe ich gesucht. :smile:
Die Abkürzung M2 steht dann sowohl für die Nano- als auch die Picostation?
Dann werde ich das demnächst mal testen…

für die Picostation musst du natürlich dann die entsprechende Firmware laden die dazu passt:
https://dl.ubnt.com/firmwares/XN-fw/v5.5.11/changelog.txt
http://dl.ubnt.com/firmwares/XN-fw/v5.5.11/XM.v5.5.11.28002.150723.1344.bin

Ich hab für das Downgrade von UBNT Geräten eine Anleitung geschrieben: https://wiki.md.freifunk.net/Anleitungen/router-flashen-ubnt

4 Likes

Im übertragenen Sinn steht die information auf der Packung :wink:

Wenn man sich das Hardware-Test Datum anschaut
alles nach 2014 sind die neuen

Wobei es mit dem Fix ja nun egal sein sollte.

@danielkrah
Kann man so nicht sagen.
Eine Loco im Dezember (Testdatum August 15) kam mit XM 5.5.9

Heute wurde Gluon 2016.1.1 released. Gluon 2016.1.1 — Gluon 2016.1.1 documentation

AirOS 5.6.x compatiblity
Downgrading to AirOS 5.5.x before flashing Gluon on Airmax M XM/XW devices (NanoStation, Bullet, …) is not necessary anymore.

3 Likes

Ich habe eine nanostation loco m2 XM unter airos 5.6.x mit einer freifunk-firmware zerflasht.
Via TFTP habe ich kein stock airos mehr draufspielen können, aber so als tipp:
OpenWRT läuft noch (via TFTP). Habe noch nicht geschafft, von openWRT dann zu freifunk zu wechseln, freifunk hängt beim booten trotzdem. Aber als Zwischenschritt sei das Image genannt:
„openwrt-15.05-ar71xx-generic-ubnt-bullet-m-squashfs-factory.bin“

Ich war mal mutig und habe die ersten 90 Router umgeflahed auf die 2016.1.1 geflashed, sieht alles gut aus.

Ich habe meinen Powerbeam M2 (XW 5.6.2) testweise auf 2016.1.2 upgedated mit aachener Factoryimage für loco XW (über Webinterface)
Leider Problem.
Nach Update ist Luci erreichbar und nimmt auch Einstellungen an - nach Reboot tut sich aber nicht viel. Der Router wird weder als neu in der map angezeigt, noch bei meinem Offloader (WDR4900).
Piekse ich das Netzteil einige Sekunden, komme ich in den Config und alle gemachten Einstellungen sind weg. Ich habe auch mal über Webinterface ein sysupgrade eingespielt- nüscht. Folgende LEDs sind grün: Power, LAN (schnell blinkend) und ganz links außen langsam blinkend).
Ist loco XW verkehrt oder hätte ich mit tftp einspielen müssen (oder beides)? Trotzdem frohe Feiertage. :smile:

Das ist ausgesprochen seltsam, ich teste morgen den factory Flash eines unfi outdoor ap +auf die Aachen Firmware.