Wie konfiguriere ich einen Gluon Router so, dass er nur auf 5GHz sendet?

Ich weis, dass es nicht besonders sinnvoll ist, aber ich würde bei meinem hamburger Freifunk-Router gern das 2.4 GHz-Wlan abschalten, so dass mein WDR4300 nur noch auf 5GHz das Freifunk-Netz aussendet.

Ich denke dies ist möglich, aber was genau muss ich da auf der Konsole einstellen?

Denke, dass du folgenden Teil loswerden willst:

wireless.client_radio0=wifi-iface
wireless.client_radio0.device=radio0
wireless.client_radio0.mode=ap
wireless.client_radio0.network=client
wireless.client_radio0.ssid=Freifunk

Das Interface willst du vielleicht noch für das meshen via 2,4 GHz oben lassen?

Dann sollte folgendes funktionieren:

uci del wireless.client_radio0

Ausprobiert habe ich es aber nicht.

Nein der darf auf 2,4 gar nicht mehr senden.

Können die Router nicht auch auf 5ghz maschen?

warum er nicht mehr auf 2.4GHz senden können soll: Erschliesst sich mir jetzt nicht. Vermutlich rätseln hier jetzt einige herum, was für ein Szenario das sein soll.
Aber anyhow: Ja, es ist einstellbar, siehe oben.

Problem bei 5GHz ist, dass unsere Router auf 5GHz nicht outdoor funken (meshen) dürfen, weil bekannte OpenWRT-radios kein DFS beherrschen.

1 Like

das sind zwei router, die nur indoor stehen aber sich miteinander vermaschen sollen. Ist das nicht aktiv? Bzw. kann man das nicht aktivieren auf 5 GHz?

Ja.

Nochmal: Openwrt hat bei keinem der mir bekannten Chipsätze DFS-Support.
Einen nicht vorhandenen Support kann man folglich auch nicht aktivieren.

Oder um es nochmal etwas länger zu sagen @rubo77 Was ist Dein Setup? Was möchtest Du erreichen?
(Du möchtest ja vermutlich nicht 2.4GHz abschalten „aus Prinzip“ kann ich zumindest nicht nachvollziehen, oder weil sich ein Nachbar mit ärztlich attestierter 2,4GHz-Allergie gemeldet hat und den die OGM-Pakete stören in dem Band.)

Das kommt am ehesten hin :wink:

Da ist ein admin, der meint: „Freifunk könnt ihr machen aber nur wenn ihr nicht auf 2,4 GHz sendet“ Weil wir sonst sein jahrelang optimiertes eigenes wlan im Gebäude mit 30 Routern stören könnten.

Ich denke es wird nur temporär sein bis er irgendwann auch das 2.4er band erlaubt, aber um erstmal einen Fuss in der Tür zu haben wollen wir das gerne dort so machen.

Also sehe ich als einzige Lösung dort maschen zu deaktivieren bzw. per LAN-Kabel maschen, oder?

Dann ist die UCI-Lösung aus dem 2. Posting des Threads von @paulinsche das was Du benötigst.
(Und ja, die Dinger meshen in #ffru sowohl auf ch3 und ch44)

Es ist in Deutschland verboten auf Kanälen 36-64 Draußen zu funken. Sie sind nur für Indoor-Betrieb zugelassen. Auf anderen erlaubten Kanälen (100-140) muss der AP den Kanal ändern und die Leistung drosseln können. Die Treiber dafür sind unausgereift. Darüber hinaus muss das ganze Mesh den Kanal ändern können. Das ist im Ad-Hoc Modus sehr schwierig zu realisieren, da ein Knoten dies vorzugeben hat. Außerdem ist es unmöglich den gleichen Kanal über ein weites Gebiet verteilt zu nutzen: ein einer Ecke braucht ein Wetterradar mal eben diesen Kanal frei, am anderen Ende der Wolke will das Militär auf einem anderen Kanal mal eben was machen. So lange Du diese Probleme nicht gelöst hast, so lamge musst Du im 2,4 GHz-Band maschen.

Hmm, danke erstmal für die ganze info. Eins ist mir aber immer noch niht klar, du sagtest:[quote=„adorfer, post:4, topic:1278“]
unsere Router auf 5GHz nicht outdoor funken (meshen) dürfen, weil bekannte OpenWRT-radios kein DFS beherrschen.
[/quote]

Hat sich deine Meinung jetzt geändert? Oder habe ich die ersten beiden Zitate falsch verstanden, das klang so, als wenn die dinger nicht auf 5GHz maschen.

Dann probier ich jetzt einfach mal @paulinsche Lösung und schau ob die beiden Router sich vermaschen.

Nein, meine Meinung hat sich nicht geändert.
„nicht outdoor meshen dürfen“ heisst: Nicht outdoor meshen dürfen.
(Grund: Kein DFS-Support in OpenWRT).

(„dürfen“ <> „können“. „outdoor“ <> „indoor“)

Oder anders: Natürlich meshen die Dinger auch auf einem Kanal >15. Und sie tun das auch outdoor, wenn man sie dort hinstellt/hinhängt. Man sollte sich dann nur nicht erwischen lassen.

1 Like

Wenn das 2,4GHz Band ganz abgestellt werden muss, dass muss wahrscheinlich neben

auch noch

uci del wireless.radio0
uci del wireless.mesh_radio0
uci del network.mesh_radio0

und nach dem

uci commit

ein

/etc/init.d/network restart

durchgeführt werden. Vorher besser die entsprechenden Einstellungen mit uci show sichern.

lass die UCI-Einstellungen so wie sie waren. mit

uci set wireless.radio0.disabled=1

wird die 2,4 GHz Endstufe deaktiviert.

uci commit wireless

speichert das ab. Mehr dazu in der OpenWrt Anleitung:
http://wiki.openwrt.org/doc/uci/wireless

Ich möchte Dich noch ein mal daran erinnern, dass die Ausstrahlung der Kanäle 36-64 draußen in Deutschland verboten ist.

Edit: ich doof habe einen Punkt im Befehl eingefügt, den ich so an dieser Stelle noch nie eingetippt habe. Keine Ahnung wie der sich dahin verirrt hat. danke @rubo77

3 Likes

Ich wusste, dass es einfacher gehen muss!

Geht! Ich habs ausgetestet mit 2 routern, die vermaschen sich auch noch über nur 5GHz.

Vielen Dank :slight_smile:

(Und ich werd das natürlich nur innen einsetzen)

1 Like