Mit Freifunk 400m² abecken

Ich hatte das Thema Freifunk für eine Veranstaltung schon mal angerissen. Hier wird es gerade aus einer anderen Richtung wieder aktuell.
Ich verstehe zwar, was @thomasDOTwtf in etwa meint, nur durchführen könnte ich es nicht.
Konkret: ich möchte etwa 400 m2 mit Freifunk ausrüsten. Spender kommt aus einem Gebäude gegenüber. Ich denke nun ganz einfach: ich setze bei dem Spender eine Nanostation ein und in dem Saal noch mal 4. Wie ist das zu machen? Und was ist Stock-Firmware?

Stockfirmware ist die Firmware die sich bei der Auslieferung der Geräte darauf befindet.
Sind die 400m² innerhalb eines Gebäudes in mehreren Räumen?

Die Fläche ist innerhalb eines Gebäudes aber auf 2 Halb-ebenen.
Mir erschließt sich gar nicht, wie die Original-Firmware sich in dad Mesh integriert? Oder bin ich nur verwirrt?

Prinzipiell wird es immer eng, wenn Dutzende von Leute gleichzeitig Youtube in HD schauen wollen.
Wobei das Kritische wird dann auch schnell der fastd-node der das meshvpn baut. Da wird’s zuerst „eng“.

Faktisch kann man für eine Einzelinstallation viel „teaken“, was nicht „normkonform“ ist.
Also z.B. die APs auf verschiedenen Frequenzen laufen lassen. Wird dann halt mit dem Meshen schlecht(-er).
Aber ist bei soetwas ja sowieso nicht die Stoßrichtung.

Also: Wenn ich mir das Gebäude (ich vermute mal es geht um foomap: http://goo.gl/yRzdCT ) so recht in Erinnerung rufe, dann ist die Sache funktechnisch ziemlich unkritisch.

Wenn Du keine Experimente mit Stock-FW machen möchtest, respektive dafür kein Experte greifbar ist):

1043v2 im Haus gegenüber am Fenster für die Internet-Zuführung, evtl, zwei(!) Antennen TL-ANT2409A dazu.
LocoM2 draußen am Zielgebäude (max. 250m entfernt, sonst NSM2 für beides)
Nun kommt es darauf an: Gibt es im Gebäude eine Verkabelung die man nutzen kann (strukturiert) oder kann man selbst eine kurzfristig „werfen“? Dann: Switch plus „MeshOnWan“ aktivieren,
Drinnen jeweils für jede Halbetage eine weiter LocoM2, möglichst „von außen nach innen“ oder anderweitig „von den beiden GEbäudeenden“ hineinstrahlen lassen.
Wenn noch weiterer Bedarf ist: Mit evtl. zwei bis drei weiteren WR841N Treppenhaus/WC-Bereich oder Raucherecke hinterm Haus „füllen“.

Wenn man KEIN MeshOnWan machen kann, dann muss man die Router näher zusammenrücken. mehr als 3 Hops zum WR1043 (der dann "der vierte) sollte man nicht haben.
Dann auch durchaus lieber auf die letzte Ecke verzichten, dafür die Links intern vom „Hauseingangspunkt“ redundant haben, falls ein Gerät mal -warum auch immer- unpässlich ist.

Man kann sicher noch viel justieren oder beschleunigen. Ich denke aber, dass es wichtiger ist, eine zuverlässige Lösung zu präsentieren, die ohne viel Installationsaufwand auskommt, um zu vermitteln, was Freifunk sein will. (Und nicht den Eindruck zu erzeugen, das sei nur was für die Cracks, die dann mit speziellen x64-Routerboards (alix) anrücken, tdm-Justage betreiben etc.pp… Klar, geht immer mehr… aber beim durchschnittlichen VW-Golf-Kunden punktet man auch nicht im Verkauf, indem man GTIs von der Tunermesse vorführt.)

2 Likes

Es handelt sich um das Foyer der Neandertalhalle in Mettmann: http://goo.gl/PHOKhY
Internet bekomme ich gegenüber von der AWO (B).
Es ist mir tatsächlich wichtiger Freifunk als das was es ist darzustellen, als den Eindruck von technischer Magie zu erwecken.
Was macht eigentlich den Unterschied MeshOnWan an/aus?

Mesh on Wan → Meshen über Kabel (Wan Anschluss). hast du z.B. mehrere Geräte an ein Switch angeschlossen, werden die über das Kabel meshen.

und, da bin ich mir aber unsicher: auch gleichzeitig über Luft? Denn ich habe eine ähnliche Konfiguration und dort werden mir Geräte angezeigt die über Luft meshen. So habe ich z.B. auch in der FFmap mehr Geräte angezeigt als ich tatsächlich habe :wink:

Das ist aber nur ein Statistik-Problem.
Fakt ist, dass der Batman schaut, wo die OGM-Pakete, die die anderen Nodes regelmäßig auf allen bat-Interfaces broadacsten am besten rüberkommen, also geringster Paketverlust.
Und die Strecke wird dann jeweils benutzt. Normalerweise sollte das dann das ethernet-Kabel am Switch sein.
Aber wenn nicht, dann geht er halt wieder auf die Luftschnittstelle zurück.

Oder um zum Thema zurückzukommen: Wenn man eine Lanverkabelung zum Meshen mitnutzen darf oder selbst eine wirft, dann ist man innerhalb des Hauses ziemlich variabel mit der Aufstellung der Nodes und muss sich keine großen Gedachenk machen, wer wen hören kann via Wlan. Sogar besser weiter auseinander als näher zusammen.

Wenn man kein Lan verwenden kann, dann muss man die Dinger näher zusammenstellen (aber nach Möglichkeit auch nicht näher als 2-5m), und auf Redundanz achten.

Alternative ist natürlich eine Top-Highperformance-Lösung hinzubauen, mit lokalen fastd-offloadern, mit Nutzung unterschiedlicher Kanäle und evtl. noch speziellen supernodes auf der Gegenstelle, die ansonsten unbelastet von normalem Traffic sind. Da schreibt man dann „Freifunk“ drauf, in Wirklichkeit geht’s dann aber eher darum, Eindruck zu schinden :wink:

Das ist jetzt natürlich schwarz-weiss. Dazwischen sind viele Abstufungen möglich.

@Lutz wie hast du es denn letztenlich realisiert?
Habe nämlich ein ähnliches Szenario bald :wink: und deine Erfahrungswerte könnten helfen

Der praktische Teil kommt erst in ein paar Monaten.
Mesh On Wan schließe ich mal aus, nicht mal weil eine Verkabelung der Nodes zu aufwendig wäre, sondern weil ich das „Mesh On Air“ zeigen möchte. Zur Zeit sieht meine theoretische Überlegung so aus:
5 TP-Link WDR4300 um Client- und Mesh-WLAN auf unterschiedlichen Bändern betreiben zu können (Clients auf 2.4GHz, WiFi-Mesh auf 5GHz).

Die 30 Meter zwischen dem Uplink und der Stadthalle sollte der WDR4300 wohl ohne große Verluste schaffen. Wenn es klappt möchte ich als Sahnehäubchen noch eine Richtfunkstrecke zwischen der Halle und unserer Wohnung aufbauen. Das sind etwa 200 Meter, die für eine Nanostation nicht das Problem darstellen sollte.
Wir haben hier inzwischen sehr guten Kontakt zu den Amateurfunkern, die da gerne mit ins Boot holen möchte.
Ich werde jedenfalls berichten.

1 Like

Die Hardware habe ich heute bekommen. @THiSCO habe ich wohl mißverstanden. Ich will kein WLAN ausschalten, sondern das WIFI-MESH auf 5 GHz laufen lassen. Die SSID Freifunk soll auf 2,4 GHz bleiben. Ich habe weder ausreichend Wissen das einzurichten, noch etwas dazu gefunden.
Wer weiß Rat?

1 Like

Also wenn du was einstellen musst, wäre es vermutlich über Terminal in der site.conf

https://gluon.readthedocs.org/en/latest/user/site.html

siehe auch Beispieldazu speziell für „wifi24“ und „wifi5“
Jetzt frag mich nicht welche Einstellungen abgeändert werden müssen :wink:

OK, läuft. War bei mir eine Mischung aus Unwissen und zu kompliziert Denken. :wink:
Mir war nicht bewußt, dass Dual-Band Router 2 mal Wifi-Mesh plus 2 mal SSID senden.
@THiSCO folgend habe ich in /etc/config/wireless mesh_radio0 und client_radio1 disabled:

config wifi-iface ‚mesh_radio0‘
option disabled ‚1‘
option mcast_rate ‚12000‘
option network ‚mesh_radio0‘
option macaddr ‚16:cf:21:2b:90:95‘
option device ‚radio0‘
option mode ‚adhoc‘
option bssid ‚32:CA:FF:EE:BA:BE‘
option ssid ‚wifimesh-rheinufer‘

config wifi-iface ‚client_radio1‘
option disabled ‚1‘
option network ‚client‘
option device ‚radio1‘
option mode ‚ap‘
option macaddr ‚16:ce:22:2b:90:95‘
option ssid ‚Freifunk (5GHz)‘

Ein WDR4300 mit Uplink und einer ohne kommunizieren nun über 5 GHz Wifi-Mesh, die SSID läuft auf 2,4 GHz. Mit Uplink gibt etwa 10 Mbit/sec, ohne Uplink noch etwa 6 Mbit/sec raus. (Wir haben nur etwa 12 Mbit/sec verfügbar)
iwinfo:

wlan0 ESSID: „Freifunk“
Access Point: 16:CE:21:2B:90:95
Mode: Master Channel: 3 (2.422 GHz)
Tx-Power: 20 dBm Link Quality: 64/70
Signal: -46 dBm Noise: -95 dBm
Bit Rate: 130.0 MBit/s
Encryption: none
Type: nl80211 HW Mode(s): 802.11bgn
Hardware: unknown [Generic MAC80211]
TX power offset: unknown
Frequency offset: unknown
Supports VAPs: yes PHY name: phy0

wlan1 ESSID: „wifimesh-rheinufer5“
Access Point: 02:44:CA:FF:EE:EE
Mode: Ad-Hoc Channel: 44 (5.220 GHz)
Tx-Power: 14 dBm Link Quality: 34/70
Signal: -77 dBm Noise: -95 dBm
Bit Rate: 48.0 MBit/s
Encryption: unknown
Type: nl80211 HW Mode(s): 802.11an
Hardware: 168C:0033 168C:A120 [Atheros AR9580]
TX power offset: none
Frequency offset: none
Supports VAPs: yes PHY name: phy1

Wie sich das Ganze mit 5 Routern in der Halle mit etwa 80 Clients und nur einem Uplink verhalten wird, kann ich überhaupt noch nicht abschätzen …

Wenn wirklich 80 Clients drin sind, und die teilweise auch das Netz nutzen (Du willst Freifunk/ Mesh demonstrieren) dann wird es mE unbenutzbar.
Unter VDSL50 als Uplink sollte man sowas nicht probieren. Wenn als Nadelöhr auch noch eine in ihrer Bandbreite und bezüglich Packet Loss nicht perfekte Luftstrecke zwischen Halle und Uplink dazukommt schränkt dies weiter ein.
Problem ist bei solchen Setups die Bandbreite und Qualität des Uplinks und weniger Routing- und VPN-Leistung.
Bei solchen Nutzerzahlen sollte man überlegen, den Trafiic direkt ohne Gateway ins Internet zu kippen oder ein dediziertes Gateway zu verwenden. Mir ist nicht bekannt, ob solche Setups per Luftmesh noch gut performen. Sowas wurde bisher immer über Kupfer gemesht.

Glückwunsch erstmal. Das ist aber dann wahrscheinlich nicht Updatesicher, sodass man „autoupdate“ deaktivieren müsste, oder? Trotzdem finde ich den Ansatz Mesh auf 5 GHz zu dedizieren gut.

So ehrenhaft ich den Versuch finde, so skeptisch stehe ich dem Ansinnen inzwischen gegenüber.

Die Chancen sind nicht groß, dafür das Risiko für eine Blamage ist groß. Und der Mitteleinsatz steht in keinem guten Verhältnis zu dem erzielbaren Zugewinn.

Nach dem Beitrag von @percy habe ich nach weiteren Optionen gesucht.
An dem Internet-Router könnte ich neben dem WDR4300 noch zusätlich einen WR1043 als zweiten Uplink anschliessen um mit diesem vier oder fünf WR841N zu versorgen. Alternativ wären einige 100 Meter Strecke mit zwei Nanostation zu überbrücken um einen weiteren Uplink zu bekommen.
Ein Test vorab wäre mir lieb, ist aber leider mit Vollast nicht machbar.
Blamieren möchte ich mich natürlich nicht, schon gar nicht im Namen von Freifunk Rheinland! :frowning:

Bei solchen Events, je nach Größe natürlich, sollte professionelles Equipment aufgefahren werden. Freifunk Mainz hat dafür z.B. ein WLAN System mit Controller und WLAN Accesspoints in der Hinterhand. Die Senden die Stadtbekannte Freifunk SSID aus und der Uplink zum WLAN Controller mesht mit dem umliegenden Freifunk Netz oder linkt zu einem Backbone Knoten der auf einem höher gelegenen Standort steht.

http://blog.freifunk-mainz.de/2014/06/22/viel-freifunk-auf-openohr-festival-in-mainz/#more-451

Um die Machbarkeit beurteilen zu können, müsstest du mal angeben welche Art der Veranstaltung geplant ist, wieviele Leute, welche Rolle Internet und Freifunk dabei spielt. Welche Uplinkkapazität und wie zur Verfügung steht.
Ich würde beispielsweise mir für keine Veranstaltung Arbeit machen, bei der Internet nur ein kleiner Bonus wäre. Handyflatrates haben alle. Wenn Werbung für FF gemacht werden soll und jemand das Publikum auf WLAN / Freifunk hinweist, kramen viele ihr Gerät heraus, probieren aus und Netz ist blockiert. (Grundrauschen vieler Devices/ Apps und Dienste machen bei Einwahl in WLAN erstmal Handshake/ Leute laden erstmal gleichzeitig alle iregeneine Website)
In Hamburg bemühen wir uns nur um Veranstaltugen wo der Veranstalter hinter Freifunk steht, die Veranstaltung bezüge zu Netzpolitik oder anderen coolen Dingen hat, die Freifunk-Installation danach hängenbleibt, gerade wo vorher kein echtes Internet verfügbar war - kurz ein deutlicher Mehrwert unterm Strich bleibt.

3 Likes

Es handelt sich um einen „Aktionstag der Wirtschaft“ oder besser gesagt: gemeinnützige Vereine und Wirtschaft/Handwerk verabreden sich zu gemeinsamen Aktionen. Wobei es weniger um Geld als um Tatkraft geht. Link dazu: Planetvalue
Am 25.6. wird im Foyer der Neandertalhalle die Projektmesse stattfinden. Also der Teil, wo Gemeinnützige und Wirtschaft/Handwerk sich finden. Dort wird Internet für Registrierung und diverse kleinere Aktionen benötigt. Das Volumen hält sich in Grenzen.
Ich gehöre zum Kernteam von diesem Aktionstag, vertrete dort meine Firma und werde Freifunk als gemeinnützigen Verein vorstellen. Wenn du dich auf der Seite mal umsiehst, wirst du das Potential dieser Veranstaltung erkennen, neue Netzwerke aufzubauen.
Nebenbei: wäre das nicht auch eine Aktion für Hamburger Stadtteile? In Erkrath (43.000 Einwohner) sind 2013 daraus 67 gemeinsame Projekte entstanden!

hm, liest sich so als ob man von Großveranstaltern Abstand nehmen müsste, da Freifunk für diesen Zweck zu wenig leistet. Zumindest, wenn man als nicht-erfahrener Nutzer das ganze Netz schneller machen möchte und die drölf Mbit-Leitung doch zur Verfügung steht…

Freifunk zu etablieren und schnell einen kleinen Zugang zu bauen ist schon recht modular geworden. Es muss aber auch einen modularen und unkomplizierten Weg geben, den VPN Durchsatz zu erhöhen. Gerade für solch einen Einsatzzweck mit vielen Clients. Davon würde ich bisher nämlich Abstand nehmen, eben welchen solch genannten Blamagen…

Nur ein paar Gedanken, kurz notiert…