TP-Link Archer C50 v4

#1

Hallo zusammen,

hat hier schon jemand dieses Modell unter Gluon zum Laufen bekommen?
Sobald das sysupgrade-Image geflasht wird (factory ist nicht verfügbar) bootet der Router in einer Schleife neu und kann nur per TFTP-Recovery wieder zurück auf Stock geflasht werden.
Für den C50 v3 gibt es unter den “Other”-Images ja extra ein TFTP-Image, für den v4 aber nicht.

Hat jemand eine Idee?

#2
#3

Danke, das hat funktioniert.

Weiß jemand, warum die U-Boot Images nicht direkt von OpenWrt/Gluon im Build-Prozess mit eingebaut werden? Hat das technische oder lizenzrechtliche Gründe?

#4

Sowohl als auch. Die Lizenz des im TP-Link Image enthaltenen Bootloaders in Binärform ist ungeklärt. Der U-Boot aus dem TP-Link GPL-tarball hingegen kompiliert ohne grössere Anpassungen nur mit der beiliegenden x64-only Toolchain.

2 Like
#5

Hallo Michael,

ist deine “boot.bin” auch nur ~ 1/2 so groß wie da unter “output>images>other” erstellte BIN Datei für den C50 V3?

Bin hiernach vorgegangen:
=> TP-Link AC1200 Archer C50 Ver. 4.0

Hab einen “C50 V4” im Zulauf und würde den ungerne bricken :wink:
hast du (für alle Fälle) noch das (tftp) recovery-image (back2stock)?

#6

Hi, ja die erzeugte Datei ist deutlich kleiner. Sie funktioniert aber trotzdem.

Beachte bitte, dass die unter “other” liegenden Dateien nur für das TFTP-Recovery funktionieren.
Die Images für das Webinterface liegen an anderer Stelle.

1 Like
#7

Danke für’s “beruhigen” :wink:
Die selbst gebaute boot.bin lies sich problemlos per Original TP-Link GUI flashen…

#Da isser => https://map.freifunk-moehne.de/biggesee/#!v:m;n:d80d17479b3c