TP-Link CPE210/510


#241

Hallo,

es gibt im aktuellen Master schon Images dafür. Aus welcher Community bist du? Frage dort nach oder baue sie dir selbst.

Grüße
Matthias


#242

Hallo MPW, vielen Dank für die schnelle Antwort!
Community ist Freifunk Stuttgart.


#243

Wie lautet denn die Fehlermeldung “wörtlich”, die die StockFW beim Versuch liefert?
Zumindest beliebige Chaos-Calmer sollten schon laufen, hatte ich zumindest so verstanden.
(Und gluon vom Master natürlich auch seit etwa 2 Wochen.)


#244
`Failure - The hardware version is not supported.'

Mit dem aktuellen Masterbranch geht es aber. Vielen Dank @MPW


#245

Da es ja noch in einem anderen Thread zu der Antennencharakteristik Fragen (“bin enttäuscht”) gab:

Bitte vergegenwärtigt Euch stets die Konsequenzen einer gerichteten Antenne, insbesondere beim Empfang(!)

a) nur knapp daneben: kommt ganz wenig! (das Problem ist bei der CPE210 und erst recht bei der CPE510 meist der geringe Öffnungwinkel in der Vertikalen. Falsche Elevation oder schlicht hohe Montanteplätze sind da ein echtes Problem)
b) Empfindliche Richtantennen sind zu empfindlich für andere Netze im gleichen “Kegel”. Denn man verstärkt auch alles was “hinter” dem erwünschten Kommunikationspartner sitzt. Und wenn das eine analoge HDMI-Bridge 500m hinter der Gegenstelle ist. Die man mit einem Rundstrahler als Antenne nie gehört hätte.

Will sagen: Mit CPEs versorgt man nur in der Pampa Endgeräte sinnvoll.
Überall anders sollte man tunlichst das Clientnetz abschalten.


#246

Wie sieht es denn da mit modifizierten CPEs aus, also mit angebautem Rundstrahler? Gibt es da schon Erfahrungswerte?

Ich habe einen zwar umgebaut aber noch nicht wirklich ausgiebig getestet.


Freifunk mit WLAN als Internetleitung
#247

Würde mich auch interessieren.


EIRP-Limit/Calculation AirOS
#248

Ich habe hier eine CPE210 v1.1, mit der ich einem nahegelegenen Freifunk-Knoten einen 2. Uplink verpassen will. Aufgrund der Entfernung von ca. 250m (keine Hindernisse) habe ich erstmal Verbindungstests im Client-Modus gemacht, um zu sehen, ob das überhaupt so möglich ist.
Mit der Original-Firmware baut der CPE eine Verbindung auf (laut iwconfig), eine IP gab’s nicht (fehlende IPv6-Fähigkeit?). Die Link Quality schwankte zwischen 10 und 25, Signalstärke lag bei 84-90dBm.
Beim nächsten Versuch mit OpenWRT (CC mit der Modifikation von hier sowie Trunk daily image von heute) konnte der CPE das Freifunk-Netz nicht mal sehen. iwlist scan ergab weniger als 15 APs in Reichweite. Sendeleistung war auf den höchsten Wert, der mit Ländereinstellung Deutschland möglich war, eingestellt (Wert habe ich mir nicht gemerkt).
Ich hab dann die Original-Firmware wieder geflasht, damit waren dann über 50 APs in Reichweite. Mit Gluon hab ich keinen Versuch gestartet, da es bei uns in Lippe noch keine Variante für die CPE210 in v1.1 gibt.
Hat jemand ähnliche Beobachtungen mit der v1.1 oder auch der v1.0 gemacht? Hab ich evtl. irgendwo eine Einstellung übersehen?

Gruß aus dem Lipperland
Matthias


#249

Hab heute ähnliche Erfahrungen gemacht, bei uns auf dem Vereinsheim eine CPE210 aufgebaut um mit einem WR841 auf einem Geräteschuppen zu koppeln. Beide haben freie Sicht zueinander. Die CPE hat nur den WR841 auf dem Schuppen gesehen. Mit ca. -80dBm nicht mal besonders gut. Der WR841 hat den CPE dagegen gut Empangen (73dBm). Hab vorhin dann an der gleichen Stelle und Ausrichtung eine Loco gehangen die Koppelt mit fast allen Knoten in dem Bereich, den WR841 sieht er mit -66dBm. Hatte rein von den technischen Daten von der CPE mehr erhofft als von der Loco. Wenn das nur ein FF-Softwareproblem ist hab ich Hoffnung das dieses noch gelöst wird. Ansonsten wer braucht 2 CPE?. Den Test mit der Stock Firmware hab ich nicht gemacht.


#250

Eventuell kann @NeoRaider mehr dazu sagen, ob da Probleme bekannt sind, oder ob es am freien Treiber liegt?

Ich habe das leider auch schon hier gehört, dass Meshstrecken, die mit Gluon und Nanos problemlos möglich sind, mit CPEs nicht funktionieren. Ich hatte da allerdings auch den Verdacht, dass die Nanos zu stark senden. Dass die zu stark senden können, ist bekannt.


#251

Zumindest untereinander können cpe´s recht ordentlich kommunizieren:

http://map.rg-west.freifunk.ruhr/#!v:m;n:60e327d61890
http://map.rg-west.freifunk.ruhr/#!v:m;n:30b5c2bcfdde

das ist immerhin eine Strecke über 2,7km

Meine auf dem Dachfenster in ca 11 m Höhe montierte cpe 210 1.0 baut meist eine (eigentlich nicht gewünschte) Strecke über 400m zum Hochhaus (mit ebenfalls cpe210 auf dem Dach) auf, obwohl ich meine leicht nach unten geneigt habe, um das gegenüberliegende Krankenhaus sowie den ganzen Vorplatz optimal zu erfassen, siehe:

http://map.rg-west.freifunk.ruhr/#!v:m;n:60e327b2d5de
http://map.rg-west.freifunk.ruhr/#!v:m;n:60e327ece18e

Das Signal liegt in 50m Entfernung und 90 Grad zur Hauptstrahlrichtung immer noch über -80dB, im Eingangs- und Aufenthaltsbereich des Krankenhauses sind es etwa -50dB :smiley:

Und ich habe an der cpe nichts “gedreht”, was die Leistung etc. angeht, nur Firmware druff, Strom druff, passt!


#252

Ich gene inzwischen von starken Fertigungsschwankugnen aus:

ChaosCalmer: 105m, 80% TQ
StockFW mit Tmax: 125m: 85% TQ


#253

An Fertigungsschwankungen kann es bei meinem CPE nicht liegen, der ist ja nur mit OpenWRT schwerhörig. Hat der evtl. einen separaten Empfangsverstärker, der per GPIO eingeschaltet werden muss?


#254

Die Schlussfolgerung halte ich für zulässig. Die Annahme jedoch für falsch.

Oder anders gefragt: Du hast mein Posting schon gelesen unter dem Du geschrieben hast, oder?


#255

Da ist der Patch frisch vom LEDE Projekt:
https://dev.openwrt.org/ticket/19402#comment:16


#256

Profitiert der CPE210 von diesem Patch auch oder gilt das nur für den CPE510?


#257

Profitiert? Darüber gehen die Meinungen auseinander.
Wäre schön, wenn Du da mit beitragen könntest.

Ich habe eindeutig negative Erfahrungen gemacht bei 5 Stück 210v1.0 und 2 Stück 210v1.1, allerdings nicht mit dem aktuellen Patch, sondern mit dem oben verlinkten.


#258

Ich habe noch keinen CPE210, wollte aber evtl. ein oder zwei für mein nächstes Projekt anschaffen. Deswegen habe ich gefragt :wink: Die Anmerkung des Commits liest sich doch recht positiv. Wenn also jemand den aktuellen Patch im Einsatz hat, dann wäre ich für ein Feedback dankbar :smile:

Edit: Hab’ drei CPE210 bestellt, dann kann ich ggf. selbst mal überprüfen. Kann aber noch ein bisschen dauern, bis die bei mir eintrudeln.


#259

Also ein manuelles setzen des GPIO Pins zeigt das Ausmaß der Änderung :smiley:

Über 760m Empfangspegel von -30 dBm, das ist schon wirklich extrem :slight_smile:


#260

Ich hatte den Eindruck, dass zwar der Pegel deutlich steigt, aber nicht die TQ.
Also ähnlich dem Effekt wie AnnoDunnemal mit den regelbaren “Vorverstärker-Antennen” für tragbare TV: Der Pegel steigt, die Qualtität sinkt.
Aber das mag ein Sonderfall für “Innenstadt-Lagen” sein.