TP-Link TL-WR841N v13 wird in DE ausgeliefert


#63

Bitte entschuldigt, dass ich ich mir quasi selbst antworte, ich muss aber meine Aussage zum WLAN widerrufen:

Ich hatte einen Fehler in meiner Konfiguration, weshalb schlicht kein Client mit dem vermeintlichen Repeater verbinden konnte, ergo gab es auch keine Probleme. Jetzt mit einer funktionierenden Repeater-Konfiguration kann ich die Schwierigkeiten bestätigen: Der Treiber ist instabil, die Verbindung ist regelmäßig unterbrochen.

Die Traces aus dem kernel.log habe ich an die mt76 Community weitergereicht. Wäre schade, wenn die v13 Unterstützung daran so kurz vor dem Ziel scheitern müsste. :cry:


#64

ich muss dich enttäuschen, aber das ist nicht kurz vor dem Ziel. Treiberentwicklung ist so ziemlich das aufwändigste überhaupt. Bei einem anderen Gerät, dessen WLAN instabil läuft, wurde geschätzt dass die Programmierung am Treiber eine deutlich 5-stellige Summe kosten würde.


#65

Klar, ich Sachen Treiberentwicklung gebe ich Dir vollkommen recht. Die Aufwandsabschätzung ist auch realistisch, wenn wir z.B. notwendigen weitreichenden Veränderungen ausgehen. Die Gefahr besteht hier natürlich auch - genauso gibt es aber die Chance, dass lediglich ein paar Modifikationen notwendig sind.

Initial waren die Entwickler auch anscheinend sehr optimistisch, zu den WLAN-Problemen mit dem MT7628x scheint es aber bisher noch kein Feedback aus Entwicklerkreisen zu geben. Meinen Optimismus behalte ich deswegen erstmal bei… und in der Zwischenzeit mache ich erstmal mit anderer Hardware weiter. :wink:


#66

ich möchte nur vermeiden, dass viele Leute sich den 841v13 kaufen und dann frustriert feststellen, dass er nicht für Freifunk tauglich ist.
Da diesen Thread nicht nur du liest, ist mir dieser mehrfache Hinweis wichtig.


#67

@rotanid

Ja, der Hinweis dass man von v13 abraten sollte ist wichtig und man kann Ihn nicht oft genug schreiben.

Ich müsste nun an meiner Rückgabefrist bei Amazon vorbei sein. Das schaue ich mal direkt nach.
Die liefern wohl auch 841N v13 und davor hatte ich noch v11 von denen bekommen. Mist.


#68

Ich bin eurem Link gefolgt und habe bei notebooksbilliger.de den WR841N bestellt. Geliefert wurde Version 13.

Soweit ich die Beiträge verstanden habe, gibt es dafür (noch) keine Firmware. Daher würde ich den Router zurück senden. Oder wäre es sinnvoll, noch eine Weile zu warten?

Gibt es preislich (in etwa 20-30 €) eine alternative Hardware?


TP-Link WR841N V11 läßt sich nicht mit anderer Firmware flashen
#69

Siehe diesen Thread: TP-Link TL-WR841N v13 wird in DE ausgeliefert

Meines Wissens nach werden alle WR841ND Modelle unterstützt, hier gibt es noch keine neuen Versionen, die nicht mehr unterstützt werden (dennoch natürlich Version prüfen). Ansonsten bin ich selbst noch auf der Suche nach einer preiswerten “Einsteigeralternative”, die man auch mal zum Experimentieren nutzen kann.


#70

Hallo,

den v13 Router würde ich einfach zurückschicken.

Als Alternative gibt den WR1043 der kostet ca. 32€ + Versand.

Vorteil hat mehr Speicher als ein WR841.

Am besten schaust du was deine community für Hardware unterstützt.


#71

Danke für die schnellen Antworten. Ich werde ihn zurück senden. Bei ebay habe ich das hier gefunden: eBay-Artikelnummer: 401197132092
Der sollte eigentlich funktionieren, zumal die Beurteilungen der Käufer darauf schließen lassen, dass es so ist.


#72

Heyho,
erschrocken lese ich die Diskussion hier, natürlich nachdem ich mir neue 841er bestellt habe. Wollte ja mal wieder etwas aktiver werden. Ich hoffe, ich bekomme noch 12er, mal schauen. Aber generell:

Jetzt gibt es neben an noch den “Alternativen für…” Thread und auch dort kommt man nicht wirklich auf einen Nenner, der ist auch im Juni stehen geblieben. ALso stehe ich hier und frage mich: Was im Rahmen um 20-25 Euro ist denn zukunftssicher (Stichwort 4MB Flash Ram zu wenig für die Zukunft)?


#73

Für den WR841v13 besteht derzeit keine Hoffnung auf rasche Erfolge.
Die Fallstricke sind allem Anscheinnach noch erheblich, wenn ich’s richtig verstehe.

Also sowohl “flashen per Webinterface vom Stock: Gar nicht”
als auch “sobald Wifimesh samt Clients: Instabil”

Derzeit ist die einzige greifbare Alternative WR1043v4. Solange bis


I have a same question so i copied this topic again
#74

Der WR1043 liegt auch bei 30 Euro +.
Was ist mit dem 841ND als Ausweichlösung?
Du hast ja geschrieben, der wäre noch nicht in neuer Rev. erschienen?

Könnten wir mal eine Tabelle zusammenstellen und die ggf. auch auf die Homepage oder ind Wiki stellen (lassen) - Basic Router mit Verfügbarkeit, Preis-Ranges, * für Zukunftssicher oder Bridge Lösung.

WR841Dv12 - jo - ab 15 - n.v. - Einstieg
WR841Dv13 - - ab 15 - Einstiegsmodell
WR841ND - ja - ab 22 - Einstiegsmodell
WR1043ND - ja - ab 30 - Einstiegsmodell+, 16MB Flash


Einstiegsrouter in der bis ~20€ und bis ~30€ Klasse - Wo geht die Reise hin wenn der TL-WR841 wegfallen würde?
#75

Bis auf dieses Gerät sind alle anderen nicht Thema dieses Threads.
Vermutlich suchst Du den Thread


#76

Im LEDE-Trunk gibt es bereits Images für die V13:
http://downloads.lede-project.org/snapshots/targets/ramips/mt76x8/
Tester vor!
Ich habe leider keine V13, da wir erstmal einen Kaufstopp für 841er ausgerufen haben.


#77

kannst du lesen? :wink:

  • flashen geht nur über TFTP
  • der wifi-treiber ist und bleibt sehr instabil

#78

also zumindest ein 841v13 läuft derzeit schon (scheinbar ohne Probleme) im Freifunk-Leipzig, sogar mit ad-hoc + vAP (dh gar kein 11s notwendig?). Die Firmware wurde nicht über Meshkit konfiguriert, sondern beim Standard-LEDE einige Freifunk-Paketen nachinstalliert und dann dort die Leipziger Einstellungen eingestellt.

Ein anderer Freifunker bei uns hat noch mehrere bei sich rumliegen. Die können nicht verwendet werden, weil die eigentlich für Freifunk-Vogtland gedacht waren und die dort nur Gluon verwenden.


#79

Gerade tut sich etwas.

Dieser commit ist im master branch, gluon verwendet bisher aber den lede-17.01 branch. Seit Samstag gibt es jedoch gluon next, wo der master branch von OpenWrt verwendet wird. Im Prinzip ist der Tresor jetzt auf.

Mit target ramips-mt76x8 funktioniert das hoffentlich. Ich habe einen v13 hier und melde mich, falls das geklappt hat.


Testfirmware für 841V13 erstellen
#80

TL-WR841N v13 Image bauen

  • git clone -b next https://github.com/freifunk-gluon/gluon.git && cd gluon
  • (z.B.) git clone -b lede https://github.com/ffac/site.git
  • in targets/ramips-mt76x8 folgendes hinzufügen:
    device tp-link-tl-wr841n-v13 tl-wr841n-v13
    factory
    
  • make update && make -j1 V=s BROKEN=1 GLUON_TARGET=ramips-mt76x8
  • :warning:️ Es wird kein factory image erzeugt, nur ein sysupgrade (output/images/sysupgrade)!

Flashen

  • OpenWrt recovery image wie hier (“Flash instruction”) beschrieben per TFTP flashen und neustarten
  • scp $sysupgrade.bin 192.168.1.1:/tmp
  • ssh 192.168.1.1 sysupgrade -v -n /tmp/$sysupgrade.bin
  • :beer:

Testfirmware für 841V13 erstellen
Router Recovery - TFTP Pushbutton und TTL (Serial Recovery)
#81

\o/ https://map.aachen.freifunk.net/#!v:g;n:d46e0ee67d06


#82

Das ist ja extrem vielversprechend!

Hast du die Kiste noch des öfteren neu gestartet oder ist da etwas instabil: