Ubiquiti Nanostation Loco M2 XW auf gluon flashen (UBNT ETSI/FCC lockdown)


#1

Hi zusammen,

ich versuche hier verzweifelt die FF-FW von uns im Webinterface einzuspielen.
aktuell ist XW.v5.6.15 (30572)

downgrad auf XW.v5.5.10-u2.28005.150723.1358.bin ist nicht möglich
Webinterface:
Es wurde eine falsche Firmware-Version hochgeladen. Bitte laden Sie die richtige Version hoch und versuchen Sie es dann erneut.

per TFTP:
received ERROR <code=2, msg=Firmware check failed>
Error code 2: Firmware check failed
Sent 6865920 bytes in 2.5 seconds

nach dem Einspielen der FF-FW im Webinterface-> Brick
ausprobiert habe ich

gluon-ffwss-ffwss-v024-ubiquiti-loco-m-xw.bin
gluon-ffwss-ffwss-v026-ubiquiti-nanostation-loco-m2-xw.bin

per TFTP hab ich noch nicht die FF-FW eingespielt, ist dies Möglich?
https://services.freifunk-suedwest.de/fw/ffwss/stable.v026/factory/

welche FW soll ich wie einspielen?


Ubiquiti Nanostation M2 (XW-board) gluon flashen - TFTP: 2: Firmware check failed
Kein Gluon oder Downgrade mehr bei Ubiquiti v6.1.x (XW)
#2

Hi,

die untere Firmware ist die richtige, also die nanostation-loco-m2-xw.

Ein Einspielen von 5.5.x sollte eigentlich mit einem aktuellen Gluon nicht erforderlich sein. Ich kann aus eurem Dateinamen aber nicht erkennen, auf welcher Gluonversion eure Firmware beruht.

Grüße
Matthias


#3

Ja Funktioniert :smiley:
Hochgeladene Firmware-Version: XW.v6.0.0-OpenWrt-r3435+32-65eec8b


#4

Hallo.

Könntest du ein paar Details liefern? Ich habe eine nagelneue Loco M2 xw mit Firmware 6.0.6 hier. Es gelingt mir weder ein Downgrade noch das testweise Aufspielen der o.g. Firmware per Webinterface, tftp oder ssh+fwupdate.
Ich bekomme immer nur Firmware check failed zu sehen.

Gruß Christian


#5

So wie in den 2-3 anderen UBNT 6er-Threads auch: 6er-Firmware geht nur sinnvoll über TFTP.

(Und nein, Dein Gerät ist nicht gebrickt, aber weggen des ETSI/FCC-Bootloaders ist der derzeit die einzige Möglichkeit, einen “unsigniertes” Image draufzuladen.)


#6

im IRC gab es Berichte, dass die neue 6.x auch mit TFTP nicht mehr geht.
In diesem Fall müsste man es über SSH und fwupgrade oder so ähnlich probieren, wie man es bei den UAP AC schon immer machen muss.


#7

Danke für die Links, Andreas. Entschuldige bitte, falls ich mich gerade ein wenig blöd anstelle.
Dort geht es aber um Unifi UAPs, geht es bei AirOS genauso? Also per ssh und syswrapper downgrade auf xw5.5.10 und dann per mtd Sysupgrade-gluon aufspielen?
Ich möchte die Loco ungern in einen Brick verwandeln, da sie nicht mir gehört. Zudem würde ich gerne verstehen, was ich dort warum tue. Ich habe bereits mehrere NSM2 per tftp geflasht, diese ist aber die erste bei der es auf “herkömmlichen” Weg nicht mehr geht.


#8

Nein, erstmal den einfach weg, so wie oben aufgezeigt.


#9

Ergebnis des einfachen Wegs:

  1. Versuch

cp XW.v5.5.10-u2.28005.150723.1358.bin firmware.bin
ping 192.168.1.20
PING 192.168.1.20 (192.168.1.20) 56(84) bytes of data.
64 bytes from 192.168.1.20: icmp_seq=1 ttl=64 time=0.081 ms
64 bytes from 192.168.1.20: icmp_seq=2 ttl=64 time=0.115 ms
^C
--- 192.168.1.20 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.081/0.098/0.115/0.017 ms

tftp

tftp> connect 192.168.1.20
tftp> binary
tftp> rexmt 1
tftp> timeout 60
tftp> put firmware.bin
received ERROR <code=2, msg=Firmware check failed>
Error code 2: Firmware check failed
Sent 6865920 bytes in 1.6 seconds
tftp>

  1. und 3. Versuch mit gluon-v2016.2.3 (jeweils Nanostation neugestartet und wieder neu in den TFTP-Modus versetzt)

cp gluon-ffhe-17.03-ubiquiti-loco-m-xw-sysupgrade.bin firmware.bin
bzw
cp gluon-ffhe-17.03-ubiquiti-loco-m-xw.bin firmware.bin

wie oben, Ergebnis:

tftp> put firmware.bin
Error code 2: Firmware check failed
Sent 3604480 bytes in 0.7 seconds
tftp>

Wo ist mein Fehler?


#10

o.k. dann bin ich jetzt auch ratlos… und dann ist hier leider nichts gelöst…


#11

Kannst du mal deine Firmware inkl. Quellenangebe hier posten?


#12

Hallo.

Puh, geschafft. Ich löse mal auf:
Die Funkamateure haben das gleiche Problem mit der neuen Firmware:
http://www.aredn.org/content/software

Wenn man bei 6.0.6 feststeckt, zuerst per TFTP downgrade auf XW.v5.6.15.30572.170328.1052.bin, dies ist wohl die einzige signierte 5.6er-Firmware. Von dort aus konnte ich aber nicht weiter downgraden.

Dafür konnte ich aber bei v5.6.15 direkt per Webinterface die factory gluon-ffhe-17.03-ubiquiti-loco-m-xw.bin hochladen. Airos identifiziert diese als die o.g. XW.v6.0.0-OpenWrt-r3435+32-65eec8b.

Nach einem weiteren Reboot und schwitzigen Händen kam dann endlich die Gluon-Configseite :smiley:

Gruß Christian


#13

Danke für die Analyse und den Weg!

Ich habe mir dann mal vorsörglich die Dateien weggesichert, falls die bei UBNT vom Webserver “verschwinden” sollten.
grafik
(Falls die später mal jemand brauchen sollte, bitte melden)

XM.v5.6.15.30572.170328.1107.bin
TI.v5.6.15.30572.170328.1038.bin
XW.v5.6.15.30572.170328.1052.bin
XM.v5.6.15-cpu400.30572.170328.1107.bin


#14

Das heißt dann quasi, dass Geräte, die jetzt neu auf den Markt kommen, nicht mehr Freifunk-tauglich sein werden :(.


#15

Ich kann ergänzend noch hinzufügen das wenn man per TFTP eine Firmware hochlädt immer zuvor das Gerät ausschaltet und die Reset Prozedur durchläuft.
Dies habe ich festgestellt, da die Ubiquiti bei mir öfters beim zweiten Versuch in einen Timeout gelaufen ist.

des weiteren ist die Eigene IP wahrscheinlich auch sehr wichtig,
192.168.1…254
denn ich hab meine Antenne auch erst nach dem X-ten Flashvorgang zum laufen gekrigt obwohl ich groß nichts anders gemacht habe.

also viel erfolg


Ubiquity AirOs5.6 / U-Boot-Änderung: Brick-Gefahr: Rocket M2/Nanostation /LocoM (erst downgraden auf AirOS5.5) für Gluon 2015.x
#16

Tftp ist leider ein recht simples Protokoll, welches eine einfache Sicherungsschicht über UDP legt d. h. kein TCP)
Wenn es irgendwie hakt, dann bricht es ab mit Timeout. Oder es schaltet auf sehr kleine Paketgrößen, die zu Datenraten von GPRS-speed führen. d. h. gefühltem Timeout…

Daher ist es in der Tat wichtig, einen sauberen Start zu erwischen.


#17

Nanostation Loco M2 mit FW 6.0.6, Board XW

(edited: Ausführliche Anleitung)

  1. Zuerst prüfen wir die Firmware und die Art des Boards (XW oder MW).

    1. auf https://192.168.1.20 mit User ubnt und Passwort ubnt einloggen
    2. Im Tab System sollte sowas wie XW 6.0.6 stehen => XW Board
  2. Downgrade der Ubnt Firmware

    1. Eine unsignierte FW von Ubnet herunterladen.
      Direktlink für XW.v6.0.4.30805.170505.1510.bin
    2. Versuchen ob sich die FW über das WebUI flashen lässt, falls nein mit 3. und 4. weiter machen.
    3. Die Nanostation in den TFTP-Mode versetzen.
      LAN-Kabel ziehen, Reset ca 20 Sekunden gedrückt halten während das LAN-Kabel wieder angesteckt wird. Dann sollten jeweils zwei Signal-Leds blinken.
    4. Per TFTP das Downgrade flashen:
    $ tftp 192.168.1.20
    tftp> binary
    tftp> trance
    tftp> put XW.v6.0.4.30805.170505.1510.bin flash_upgrade
    sent DATA <block=14148, 208 bytes>
    received ACK <block=14148>
    ...
    tftp> quit
    

    Paar Minuten warten bis der Reboot durch ist. Weitere Infos zu TFTP/Unbrick

  3. Nun sollte das Freifunk-Image (gluon-XXXX-2016.2.7+20170823-ubiquiti-loco-m-xw.bin) per WebUI flashbar sein.


#18

Hallo Christian,
ich stecke hier fest mit einem neuen Ubiquity nanostation loco M2
mit System 5.6.12 (XW). Ich will Freifunk flashen,
anleitungen:router_flashen [Freifunk Stuttgart] schreibt, dass man
die firmware erst auf 5.5.x downgraden muss. Das funktioniert aber nicht.

Frage: Habe ich dich richtig verstanden, dass es eine gluon-Version für das
loco M2 gibt, die man auf 5.6.12 (XW) auf einen Rutsch hochladen kann?
(die von dir erwähnte die factory gluon-ffhe-17.03-ubiquiti-loco-m-xw.bin finde
ich nirgends). Danke für einen Tip! Ulf, DK9SJ


#20

Ich ‘antworte’ mir mal selbst: Gluon auf Ubiquity Loco M2 hat schließlich nicht funktioniert, ich habe die Teile nach Amazonien zurückgeschickt.
Alternative Frage: Was empfiehlt man derzeit für Outdoor (PoE) ?


#21

Genau das Gerät.
Flashen nach der Anleitung oben.
Downgrade ist nicht mehr notwendig.

Wichtig nur

  1. XW-boards sind XW-boards (die Info ist zur Auswahl des Images wichtiger als die Info ob das eine Loco, Non-Loco oder ein LitebeamM oder gar NanobeamM ist. Es zählt nur das Board)
  2. Falls eine passende Downgrade-Firmware (5.6.15) nicht gefunden wird oder man das nicht hinbekommt: Auf aktuelles LEDE updaten und von dort aus dann die veraltete Firmware der lokalen Community aufspielen. (Wenn es nicht “direkt” ging, weil die Community seit >1 Jahr keine aktuelle Firmware herausbringt.)