Knoten über WLAN statt LAN ins Internet einbinden

Hallo zusammen,
ich möchte meinen Knoten statt über LAN über WLAN ins Internet einbinden.

Ich verwende einen TP-Link TL-WR841N v11, der weitgehend bis auf dem RAM Chip und den Switch baugleich mit v9 ist.

Dazu habe ich im Internet gesucht und eine Anleitung (leider von Freifunk Franken) gefunden, die mir aufgrund meiner OpenWRT Erfahrungen durchaus als plausibel und zielführend erschien. Zudem wird dort angegeben, dass diese Konfiguration erfolgreich durchgeführt wurde mit der Kombi TP-Link WR-841n(d) V9 (Firmware 0.5.1) an AVM Fritz!Box 7360 (Fritz!OS 6.30), was zu meinem Aufbau sehr ähnlich ist.

Ich bin der Anleitung gefolgt und habe meiner config die entsprechenden Teile hinzugefügt:

root@router:/# cat etc/config/wireless
config wifi-iface 'wwan'
        option ifname 'wwan'
        option network 'wwan'
        option disabled '0'
        option device 'radio0'
        option mode 'sta'
        option ssid 'myssid'
        option encryption 'psk2'
        option key 'mykey'

root@router:/# cat etc/config/network
config interface 'wwan'
        option proto 'dhcp'

root@router:/# cat etc/config/firewall
config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wwan'

An der übrigen Konfiguration habe ich nichts grundlegendes verändert.

Wenn ich dann die Verbindung starten will erhalte ich folgende Ausgabe:

root@router:/# wifi up wwan
wwan(): Interface type not supported
Command failed: Not found
Command failed: Not found
wwan(): Interface type not supported

Ich kann leider mit dieser Ausgabe nichts anfangen… im Gegenteil, wenn ich „wwan“ durch ein beliebiges anderes Wort ersetze kommt die gleiche Ausgabe. Die WLAN-Verbindung über „myssid“ wird nicht aufgebaut laut meinem Internetrouter.

Was muss ich tun, um einen KBU Knoten über WLAN mit dem Internet zu verbinden??

Danke für eure Hilfe!
ffreifunk :slight_smile:

Ohne einer eventuellen Antwort vorgreifen zu wollen, die da heisst „Bitte meldet Dich auf Mailingliste/Slack/IRC“:smile:

Wir hatten zu diesem Theme schon mehrere Threads.
Prinzipiell geht es als ProofOfConecpt (unter erheblichen Einschränkungen wie z.B. bei der Kanalwahl).
Und die Performance ist, dass es für 2-3 Clients für WhatsApp reicht. Sprich: Selbst DHCP könnte für die Clients schon zur Herausforderung werden.
Aber wenn man Freifunk unter dem „Forschungs-Aspekt“ betreibt, sicher eine schöne Sache, um zu Lernen, wie HiddenStation-Probleme entstehen und wie schlimm das werden kann.

1 Like

Du wirst lachen, bei IRC & Co habe ich mehrfach vorbeigeschaut, aber bis auf einige „Chatteilnehmer“ im Dauertiefschlaf war da nix zu finden… :wink:

Okay, ich kann die Entscheidung des/der Entwickler(s) akzeptieren, dass diese Lösung nicht in gluon aufgenommen wird, aber die Begründung kommt mir dann doch etwas merkwürdig vor. Ist ja nicht so, dass Freifunk nicht genau das gleiche machen würde mit zwei Netzen… Und abgesehend davon habe ich auf Kanal 1 ohnehin schon 4-8 (andere) Netze, auf eines kommt es da nun wirklich nicht mehr an. Was die Performance angeht… (2-3 Clients mit Whatsapp ist sicher untertrieben)… wer Performance will, nutzt LTE und nicht Freifunk. :wink: Ich hab mir einen 841N gekauft, keine High-End-Möhre, 1-3 Mbit/s sind da voll okay. Mir geht es bei Freifunk eher um den (Community-) Gedanken und nicht um die High-End-Performance - insofern steht IMHO eine alternative Anbindung über WLAN statt LAN keiner deiner genannten Gründe im Wege… Was ich nicht abschätzen kann, ist welche (schon implementierten) Features (da gab es in einem Thread, den du verlinkt hast eine Auflistung) man sich unersetzlich kaputt machen würde… (auf das was dort stand könnte ich verzichten - zumal es im Moment bei mir heißt: Einbindung über WLAN oder kein Freifunk).
Viele Grüße

Daher habe ich das ja auch nicht empfohlen.

Ich dass Du die die im anderen Thread angeführt Begründung nicht akzeptierst und/oder verstehst.
Dein Gegenargument ist aber ungültig. Deine Lesart von „genau das gleich“ ist ungültig.
Das ist etwas so ähnlich wie Auto fahren und Taxi fahren. Eigentlich ist es genau das Gleiche…

Ich könnte jetzt noch 2-3 Lösungen aufzeichnen, aber das wurde in den anderen Threads schon besprochen
(Und wenn Du diese 15€ nicht hast, dann kann und werde ich da nicht helfen.)

Stimmt, da ist „Kein Freifunk“ sicher die bessere Lösung.
Zumindest erspart es der Laufkundschaft ein semi-disfunktionales Netz.

10 Privatautos und 10 Taxis erzeugen jeweils den gleichen Verkehr. Der Straße ist egal wovon 10 Stück… Oder willst du auf etwas anderes hinaus?

Nana, ich bin ja durchaus an einer Lösung interessiert…

nur mal so als idee:
normalen TP-Link repeater zB 860re kaufen,einrichten als client, den mit deinem WLAN verbinden mit Key, an der LAN Buchse den FF Router. müsste doch klappen.

ok, der Chat hier ist schon was älter, probiere es trotzdem mit einer Frage dazu.
Was, wenn ich jetzt z.B. einen WDR3600 nehme und den mit dem 5GHz Beinchen ins private WLAN hänge und darüber die WAN-Anbindung realisieren möchte (nur WAN, sonst nichts).
Dann Freifunk über 2,4GHz. Unterscheidet sich das dann im Prinzip überhaupt noch von der skizzierten Lösung mit zwei Geräten?

Kann das klappen? Und welche Probleme sollte es da geben verglichen mit Kabel am WAN-Port?
Klar, Kabel != WLAN, darüber hinaus meine ich.

Da das ja nicht einmal einen Hardware-Invest bedingt, mach’s doch einfach und berichte. Kurzum: mit einer 2. Sender-Empfänger-Einheit umgehst Du das Problem, daß sich die Systeme gegenseitig behindern. Da dies in Gluon aber nicht vorgesehen ist (abschalten ja, anders als für AP und/oder Mesh zu benutzen nein), sind ggf. noch ein paar Dinge zu ändern, die Gluon ggf. voraussetzt/vorkonfiguriert hat.

Viel Erfolg beim Nachinstallieren der benötigten Pakete.

Die erste Versuche enden ernüchternd.
Mit Stock-Firmware eine WDS-Verbindung zur Fritz-box aufbauen geht (TP-Link WDR3600 - > Fritz-box 7590). Obwohl die Fritz-box das angeblich gar nicht unterstützt
https://avm.de/service/fritzbox/fritzbox-7490/wissensdatenbank/publication/show/1452_Unterstutzt-die-FRITZ-Box-das-WDS-Verfahren/

Womit ich gerade kämpfe ist, die saar.freifunk.net Version so zu konfigurieren, dass sie das gleiche tut wie die stock-Firmware zuvor (OpenWrt 18.06-SNAPSHOT, r7794+21).
OpenWrt Project: Atheros and MAC80211 WDS to implement a wireless network bridge (wireless repeater)
option mode ‚sta‘
option wds ‚1‘
zeigt nicht den erwarteten Effekt. Die Kiste verbindet sich nicht mit der Fritz-Box.

iwinfo

wlan1 ESSID: unknown
Access Point: E6:86:65:B3:9E:27
Mode: Client Channel: unknown (unknown)
Tx-Power: 19 dBm Link Quality: unknown/70
Signal: unknown Noise: -93 dBm
Bit Rate: unknown
Encryption: unknown
Type: nl80211 HW Mode(s): 802.11an
Hardware: 168C:0033 168C:A120 [Atheros AR9580]
TX power offset: none
Frequency offset: none
Supports VAPs: yes PHY name: phy1

bisschen dürftig :woozy_face:

iw phy1 info

Wiphy phy1
max # scan SSIDs: 4
max scan IEs length: 2261 bytes
max # sched scan SSIDs: 0
max # match sets: 0
max # scan plans: 1
max scan plan interval: -1
max scan plan iterations: 0
Retry short limit: 7
Retry long limit: 4
Coverage class: 0 (up to 0m)
Device supports AP-side u-APSD.
Device supports T-DLS.
Available Antennas: TX 0x3 RX 0x3
Configured Antennas: TX 0x3 RX 0x3
Supported interface modes:
* IBSS
* managed
* AP
* AP/VLAN
* monitor
* mesh point
* P2P-client
* P2P-GO
* outside context of a BSS

da steht ja auch nichts von „sta“ oder „client“ :face_with_monocle:
irgendwo übersehe ich offensichtlich was und bitte um einen Tipp.
Welche Pakete brauche ich dazu?
Oder wie kann ich bitte die WLAN-Konfig besser debuggen?

KBU geht bis ins Saarland? Wieder was gelernt.

1 Like

oh, dass ich in die Köln, Bonn und Umgebung Gruppe gerutscht bin war keine Absicht. :ok_man:
Wollte mich an die Bundesweite Community wenden.
Werde beim nächsten Mal aufmerksamer lesen zu welchem (alten) Post ich was schreibe, sorry. :raising_hand_man:

Wollt Ihr mir trotzdem sagen welche Hardware mit eurer Freifunk-Software den Client-Mode unterstützt?

Wollt Ihr mir trotzdem sagen welche Hardware mit eurer Freifunk-Software den Client-Mode unterstützt?

In der Regel keine, da die entsprechende Software mangels Notwendigkeit nicht an Bord ist. Bei einigen, die das „probiere Firmwareupate im Client-Mode als letzte Option“-Paket nutzen, sollte der Client-Mode an einem unverschlüsselten WLAN funktionieren; WPA dürfte aber auch dort aus Platzgründen (4 MB Flash) fehlen.

Bei Freifunk gibt es halt nicht DIE Software. Jede Community macht nach ihren Fähigkeiten und Bedürfnissen eine Software, die meistens auch dann nur für diese Gegend oder den Ort genutzt werden soll. Daran hängt dann auch die unterstützte Hardware.

Wenn du eine Community gefunden hast, die so was in deine Richtung schon gemacht hat, dann am besten dort gezielt nachfragen.

Ach ja, nicht alle Community s nutzen dieses Forum.

Das „KBU-Problem“ (wenn ich das mal so nennen darf und richtig verstanden habe) ist, dass der Autoupdater per Default nicht angeschaltet ist (war?) und dass es zudem aus Gründen der Diversität mehrere Firmware-Bauende gibt, die parallel im Netz ihre Firmware haben.

Ja, KBU kommuniziert vorwiegen per Mailingliste.